0
Network/Connectivity 1+3T - Daily issue with WiFi scanning and connectivity.

  1. dexterouz
    Froyo Dec 21, 2016

    dexterouz , Dec 21, 2016 :
    Oxygen OS 3.5.3
    Oneplus 3T 64GB


    I have a serious issue with my 3T WiFi.

    After switching on the phone, it doesn't connect to my saved wifi. Also, it doesn't detect any wifi networks. It just keeps on searching. This is happening every day. This is the 3rd day of my purchase.

    Last time I restarted the phone, I restarted the router too, and still the same issue. Removed the saved wifi, it took 5 mins to show 2 available networks (another phone was showing 7 wifis), then after next 5 mins, it showed my wifi network.

    Today, it's taking way more time to scan the network. After 10 mins it showed 2 but not mine.

    Again, I have removed my saved wifi. No progress. The phone is just scanning for networks.


    Update 1: Somehow it got connected, updated to latest Oxygen OS 3.5.4 after restart WiFi was gone again. Contacted customer care, wiped cache and wipe data. Just like the 1st time during initial phone setup WiFi is connected. Will update if I face the issue again. Hopefully, I do not have to return the phone.

    Update 2: After update 1, I switched off the phone and kept it aside for few hours. Now, after switching it back on. This time it got connected automatically but after 5 mins. Before that, I was not able to scan anything.

    UPDATE3: I don't know how? But WiFi has started working properly. I tried similar situations but now WiFi connects with a second. I hope I won't be facing any issues further :)

    Is the connecting to WiF slow in OnePlus 3/3T? OR should I ask for a replacement?
    I have never seen such slow or late connection in any phone irrespective of the cost.

    Please help! :(

    Regards
     
    Last edited: Dec 22, 2016

    #1
  2. papolytic
    Gingerbread Dec 21, 2016

    papolytic , Dec 21, 2016 :
    I never had any wifi connectivity problems with the 3t, on any of their OS's or 3rd party ones. I think these sort of problems could be something possibly "cured" by just doing the reset of the "wifi data" only, then trying again. I had used mine in different WiFi networks each day for ~couple of weeks. Not any problems so I know it "can" work fine. Of course: If you can't get it to work correctly, maybe you could narrow it down to a point where you're sure you understand the problem, by using $adb to see if DNS is being passed along and received correctly. You could get into adb shell and do an $ifconfig -a and check the DNS returned. Then try to ping a known good target using IP like 8.8.8.8. See if any packets are lost. If not, then your WIFI is working, just not your DNS and you can rephrase the question. If fact, you could solve it with a setprop (or a script addition, or a build.prop edit). Good luck.
     

    #2