1
256GB microSD gets corrupted when formatted within phone

  1. ksx4system
    Eclair May 9, 2021

    ksx4system , May 9, 2021 :
    I've got genuine (purchased from official distributor) Samsung EvoPlus 256GB microSD. I can format this card using Ubuntu 20.04 Linux or Windows 10 PC but after formatting within phone (N100 with 10.5.7 global ROM) it gets corrupted and even PCs no longer see any partitions on it.

    Is my card broken? Is that bug within Oxygen OS 10?
     

    #1
    ChriStefan likes this.
  2. obakesan
    Jelly Bean May 11, 2021

    obakesan , via OnePlus 9 Pro , May 11, 2021 :
    This is a bug with oxygen it android or both not sure tbh. I had the same issue and still do. Best fix is to format the drive in another device like on your computer to fat or exfat for example then put into phone and should be good. I used a 256 card fine this way
     

    #2
  3. ksx4system
    Eclair May 12, 2021

    ksx4system , May 12, 2021 :
    I'm sending that microSD for RMA anyway so we'll see how it goes after they will send me a replacement unit. This card was seen by Oxygen OS after cleaning it (exFAT format via Rufus app on Windows) but file transfers were painfully slow both via card reader and within phone. Of course formatting it again using phone rendered it corrupted again.

    Have you tried using smaller cards (128GB for example)? Did you have same issues?
     

    #3
    obakesan. likes this.
  4. obakesan
    Jelly Bean May 12, 2021

    obakesan , via OnePlus 9 Pro , May 12, 2021 :
    I tried with a 128GB card and formatted it via phone. It didn't error and it didn't say it was corrupt but then I don't think it actually formatted the card despite it saying so as existing files were still present.
     

    #4
  5. ksx4system , via OnePlus 8 Interstellar Glow , May 12, 2021 :
    I guess this is a bug in current OOS version...
     

    #5
  6. pkg3107
    Ice Cream Sandwich May 28, 2021


    #6