4
Sound 5.0.3 Bluetooth controls broken

  1. TerenceEden
    Cupcake Feb 5, 2018

    TerenceEden , Feb 5, 2018 :
    I've updated to 5.0.3 from 5.0.2. This has broken playback controls on Bluetooth. Specifically, play/pause and track skip.

    I've tried both my headphones and car's Bluetooth. They both worked this morning before the update. Since 5.0.3 the phone no longer responds to commands.

    I've tried a different phone, and both Bluetooth devices can control it successfully.

    I've restarted my phone. Deleted the Bluetooth devices. Changed the AVRCP options in developer settings. Changed the Codec. The only thing which works is volume control - nothing else.

    Please can you confirm when this will be fixed.
     

    #1
  2. G_Arjun_Amin_HoHR
    Cupcake Feb 5, 2018

    G_Arjun_Amin_HoHR , Feb 5, 2018 :
    Same issues but also including loss of music control through inline controls on wired headsets.

    Haven't found a solution yet.
     

    #2
    ashishabe likes this.
  3. Xavierpony
    Gingerbread Feb 5, 2018


    #3
  4. Rogerini
    Gingerbread Feb 6, 2018


    #4
  5. hugohca
    Cupcake Mar 13, 2018


    #5
  6. Iamrezap
    Donut Mar 13, 2018

    Iamrezap , Mar 13, 2018 :
    same issue after Oreo update. I have to wait for 5 minutes before it plays by itself
     

    #6
  7. ashishabe
    Cupcake Mar 22, 2018

    ashishabe , Mar 22, 2018 :
    I've been having the same issue on my OP5 - Bluetooth and Inline Controls don't change track on the music player. Volume control works fine though.

    Not sure if the issue popped up immediately after the 5.0.4 update, but it wasn't present earlier.

    I've noticed however that bluetooth and inline controls work perfectly for the Google Play Music app. It is set as the default music app, and this can't be set to any other app like SoundCloud or Apple Music.

    Anyone, please let us know if you've figured out what broke, or a work around for the time being.
     
    Last edited: Mar 22, 2018

    #7
  8. jdkbph
    Cupcake Jun 28, 2018

    jdkbph , Jun 28, 2018 :
    Hi. I see this is a relatively old thread, but was there ever a response? The last update pushed to my OP3T broke the skip forward/skip back controls for Google play Music and Slacker. Oddly, Amazon and Deezer still worked fine after the update, but I don't actually use those two.

    So is there a fix? Has there been any word or acknowledgement from Oneplus?

    Thanks.
     

    #8