40
ROM [5.1.1] Unofficial CyanogenMod 12.1 with CAF 3.4.0 kernel

  1. mrVazil
    Gingerbread Dec 28, 2015

    mrVazil , Dec 28, 2015 :
    The second to last build gave best battery life for me. It did better than the COS that came with my OPO. This last one has a weird drain somewhere, but Sultan has always been very good to us and this will probably be fixed after the holidays.
     

  2. dso
    Cupcake Dec 28, 2015

    dso , Dec 28, 2015 :
    Hey guys, first of all thanks to Sultan for his great work!

    I'm having issues with battery on the latest version too. Left Better Battery Stats running all night and found the culprit (I think): "radio-interface" under kernel wakelocks

    http://imgur.com/MKUik3F

    Any idea if this is a bug on the rom or something that can be fixed?

    EDIT: Wifi was off and I have all the usual settings that drain battery configured correctly
     

  3. butaixyz8016
    Honeycomb Dec 28, 2015

    butaixyz8016 , Dec 28, 2015 :
    Are you referring to the 13th December build??
     

  4. mrVazil
    Gingerbread Dec 28, 2015

    mrVazil , Dec 28, 2015 :
    Yes, that one still worked as it was supposed to.
     

  5. butaixyz8016
    Honeycomb Dec 28, 2015

    butaixyz8016 , Dec 28, 2015 :
    Okk then I will downgrade it
     

  6. mrVazil
    Gingerbread Dec 28, 2015


  7. Sultanxda
    Recognized developer Recognized Developer Dec 28, 2015

    Sultanxda , Dec 28, 2015 :
    I checked the kernel, and there is no wakelock called "radio-interface". Additionally, my changes in the Dec. 20 build were very minor; there is no way that any of my changes could have caused this.

    Either it's caused by an upstream change from CM, or it's caused by some app/configuration you have.
     

    dso, jstepa and rockhardy like this.
  8. butaixyz8016
    Honeycomb Dec 30, 2015


    iriad likes this.
  9. iriad
    Gingerbread Dec 30, 2015

    iriad , Dec 30, 2015 :
    Me too, I will go back to 13/12
     

  10. DrJMun
    KitKat Dec 30, 2015

    DrJMun , Dec 30, 2015 :
    Just clean installed sultan 12202015 version. Tried to install Xposed (I had Xposed when I was running Exodus) but I'm getting: Xposed is not yet compatible with Android SDK version 22 or your processor architecture (armeabi-v7a).

    CANNOT LINK EXECUTABLE DEPENDENCIES.

    I have Super User installed and that appears to be working.

    So what am I missing? It worked before (famous last words..LOL)
     

  11. ritco
    Froyo Dec 30, 2015

    ritco , Dec 30, 2015 :
    @Sultanxda @69gm i just flased the ROM yesterday, i like a lot, battery life is great and the camera is perfect, but i'm facing some speaker problems, when i call someone the sound is really low almost silent, i can barely hear them but they hear me perfect.
    The sound is at max, i always press the Volume up just to be sure, but it does nothing, i even flashed another modem from OxygenOS: http://forum.xda-developers.com/one...dio-updated-modem-radio-files-oxygen-t3072516 but it doesn't help too much.
    I didn't had this problem on CyanogenMod 12.1-20151117-SNAPSHOT-YOG7DAO1K6-bacon.
    Do you guys know how to fix this?

    Also i've noticed a bug with the volume slider, it just got stuck, i could change the volume by pressing the volume buttons but on screen it didn't move, a reboot fixed it.

    //Speaker got fixed after a dirty flash of the ROM.

    • I've done a clean install of the ROM, after i installed my apps i even did a wipe of cache and dalvik cache, but it didn't help, the speaker sound is really low.
     
    Last edited: Dec 30, 2015

  12. mrVazil
    Gingerbread Dec 30, 2015

    mrVazil , Dec 30, 2015 :
    not sure if you know this, but you have to install xposed through a flashable zip now due to android 5 restrictions. The installer will not work, it needs to be flashed.
     

    DrJMun likes this.
  13. DrJMun
    KitKat Dec 30, 2015

    DrJMun , Dec 30, 2015 :
    OK, thanks. That's what I did when I was on Exodus, I zipped it via TWRP. I just wish to avoid any bootloops. That warning makes it sound as if its no longer compatible. I already the zip file. Thanks for the response.
     

  14. DrJMun
    KitKat Dec 31, 2015

    DrJMun , Dec 31, 2015 :
    Just to wrap this up... flashing SDK 22 version 75 did indeed work out fine. I'm not sure why that error message was popping up if not true. Running Sultanxda 20Dec15 version, rooted.
     

  15. hayuatma
    Cupcake Jan 2, 2016

    hayuatma , Jan 2, 2016 :
    Just realized that one of my app (magicplan) using camera access cannot display image from camera. Only black image with app button interface.
    Works well previously when using stable CM 12.1 (before flashed with sultanxda 13 December).
    Strangely only this app which cannot display camera image, other work normally (whatsapp, skype, and on 3D measure).
     

  16. Dendedanamekian
    Gingerbread Jan 2, 2016

    Dendedanamekian , Jan 2, 2016 :
    I just installed sultan 12.1 Dec. 13 version. So far I like it. Good battery and very smooth. I have only run into one problem. I got the same theme from the theme store that I used to have on stock COS 12.1 but when I set it, it won't change my apps look. It only changes widgets look. All the apps stay default system look. I would really like to have my apps change with the theme. Any knowledge and help on this greatly appreciated :)
     

  17. Shubh21
    Honeycomb Jan 3, 2016

    Shubh21 , Jan 3, 2016 :
    Which theme is it?? Did you reboot? Usually, a reboot is recommended after changing a theme..
     

  18. Dendedanamekian
    Gingerbread Jan 3, 2016

    Dendedanamekian , Jan 3, 2016 :
    I did try a reboot and problem persisted. And it happened with every theme I tried. I went ahead and got Nova Launcher Prime. Best decision I've ever made. Theme's are all working now and tons of customization
     

  19. CaBooSe
    Gingerbread Jan 3, 2016

    CaBooSe , Jan 3, 2016 :
    Anynews from sultanxda if he will be updating his rom because of latest Y0G update?? would be nice :)
     

  20. CaBooSe
    Gingerbread Jan 3, 2016