0
5G Telstra on OnePlus 8 Pro in Australia

  1. chazzer86
    Cupcake Jun 2, 2020


    #21
  2. ssabhyankar
    Donut Jun 2, 2020


    #22
  3. happiboi
    Gingerbread Jun 2, 2020

    happiboi , Jun 2, 2020 :
    hi guys (@ssabhyankar & @chazzer86) and anyone else reading :)

    I can only speak from my experience with the phone so far:
    - Definitely IN2020 model which should be CN version
    - mine is 12GB RAM/256GB ROM
    - Default behaviour of the phone (until OnePlus provide an OTA update) is that 5G only works if second sim is disabled. If you enable both sims, the phone will only be dual 4G. I have a sim in both trays but have second one disabled most the time, as that sim for me is an overseas sim.

    2 things I did to make sure 5G worked with the phone on Telstra:

    1) You need to be on a Telstra plan that has aaccess to the 5G network. I was on an older grandfathered plan (good value, but no access to 5G). When I asked Telstra, they confirmed only their newer/current plans were provisioned for 5G access.

    2) The other thing I inadvertently did while messing around to try to get VoLTE/VoWiFi working (which I gave up cos it doesn't) was that I changed an entry in the phone's configuration:
    - Download and install: https://androidfilehost.com/?fid=11410963190603912872
    - Just use the standard settings and click on OK, next, until finished.
    - Connect your phone to your laptop via USB
    - ****IF your computer doesn't recognise your OP8 PRO, maybe need to install drivers. I jsut googled these ones to try and worked - https://www.getdroidtips.com/download-oneplus-usb-drivers/
    - Open dialer app and enter *#801# (If this doesn't do anything, just google search "Oneplus engineer mode apk", download and install it. Then retry)
    - Set Full-port switch to ON
    - Open "PDC" in your QPST start menu folder, best to do by right click & "run as administrator"
    - Click on dropdown and choose your device.
    - I selected "Volte_OEM_Lab", right click and SetSelectedConfig for both Sub0 and Sub1
    - Click on the above profile again and click on Activate
    - Restart your phone

    Not sure if step 2 was needed but it was a byproduct of me messing aroudn trying to get VoLTE working.

    As my previous post has captured, speed tests definitely indicate 5G access, as does the About Phone > Status > SIM Status (sim slot 1) > Mobile data network type = LTE & NR

    Hope this helps you guys
     
    Last edited: Jun 3, 2020

    #23
    chazzer86 and ssabhyankar like this.
  4. happiboi
    Gingerbread Jun 2, 2020

    Attached Files:


    #24
  5. cowboi007
    Donut Jun 3, 2020

    cowboi007 , via OnePlus 8 Pro , Jun 3, 2020 :
    So I have had 2 versions of this phone and both will not connect to telstra 5g. I am on a 5g plan and the s20 ultra and a90 will connect no issues. I originally had the cn version and returned when it would not connect to 5g. I then went to telstra and got a new sim just in case that was an issue. I now have the global version of the oneplus 8 pro and still it will not connect to telstra 5g. I have asked telstra if they need to push something out to my phone and yet to receive an answer. Has anyone else been able to connect with the global version as it's so bloody frustrating. I've attached screenshots of the info from kogan about the bands for 5g and the phones info. Any and all help very appreciated.
    1591147042701.jpg

    1591147042731.jpg
     

    #25
  6. happiboi
    Gingerbread Jun 3, 2020

    happiboi , Jun 3, 2020 :
    I have not had a new sim, nor had telstra push anythign out to my phone. In fact the only thing i've done is what I posted above - and you can see mine is CN model (IN2020) with global (NA) ROM flashed by the build number (10.5.8.IN11AA).

    Based on your info above, it appears you would have an EU variant of the OP8 Pro with global ROM flashed on it (based on the freq. it lists):

    4G bands 1, 2, 3, 4, 5, 7, 8, 12, 13, 17, 18, 19, 20, 25, 26, 28, 32, 34, 38, 39, 40, 41, 42, 46, 66 - EU
    1, 2, 3, 4, 5, 7, 8, 12, 13, 17, 18, 19, 20, 25, 26, 28, 29, 30, 34, 38, 39, 40, 41, 46, 48, 66, 71 - NA
    1, 2, 3, 4, 5, 7, 8, 12, 17, 18, 19, 20, 26, 34, 38, 39, 40, 41, 46 - IN
    1, 2, 3, 4, 5, 7, 8, 12, 17, 18, 19, 20, 26, 34, 38, 39, 40, 41 - CN

    5G bands 1, 3, 7, 28, 78 SA/NSA - EU
    2, 5, 41, 66, 71 SA/NSA - NA
    41, 78, 79 SA/NSA - CN
    78 SA/NSA - IN

    Having said that, the bands should be there to support it. Standard troubleshooting - you have dual/second sim disabled? You have 5G preferred on connectivity list. If you have all that, maybe try what i've done?
     

    #26
  7. cowboi007
    Donut Jun 3, 2020

    cowboi007 , via OnePlus 8 Pro , Jun 3, 2020 :
    Hi happyboi, thanks for your info. I have a 5g plan with telstra and the phone has all g's switched on. I'll give Ur suggestion a go soon and will post back. FYI telstra aren't any help at all.
     

    #27
  8. cowboi007
    Donut Jun 4, 2020

    cowboi007 , via OnePlus 8 Pro , Jun 4, 2020 :
    Hi sorry for being a pain but I downloaded the 1st suggestion in your post and when I extracted it and tried to open it I am either greeted with it wanting to open with an extracted which just ends up asking me to download a torch app which I'm not happy to do. Are you greeted with the same thing or am I missing something. Just so frustrating not having 5g work when I've been told by telstra shop staff that there wouldn't be any restrictions to access 5g but also told since it's a phone not readily available in Australia that I need to contact oneplus which I have and yet to get a response. This whole thing is just turning me off using oneplus but I love the phones.
     

    #28
  9. happiboi
    Gingerbread Jun 4, 2020

    happiboi , Jun 4, 2020 :
    Hi there,

    I did not get greeted with any request for "torch app?"...

    To be sure, I redownloaded the zip file [QPST_2.7.460.zip] via https://androidfilehost.com/?fid=11410963190603912872 (same link in above post).

    Then I used 7zip to "extract here" and it created a folder "QPST_2.7.460" with all teh contents inside (no subsequent extract, no torch app request)..then proceeded to install QPST apps by executing "QPST.2.7.460.exe"
     

    #29
  10. chazzer86
    Cupcake Jun 5, 2020


    #30
    happiboi likes this.
  11. ssabhyankar
    Donut Jun 6, 2020


    #31
  12. happiboi
    Gingerbread Jun 6, 2020


    #32
  13. happiboi
    Gingerbread Jun 9, 2020

    happiboi , Jun 9, 2020 :
    Just a PSA now that the 10.5.10 update should be rolling out to your phones (mine's updated already).

    With each OTA update, it wipes away the config changes made via the PDC tool, so after the update is installed and phone has rebooted - remember to redo the PDC steps if you want that 5G access
     

    #33
    chazzer86 likes this.
  14. chazzer86
    Cupcake Jun 9, 2020

    chazzer86 , via OnePlus 8 Pro , Jun 9, 2020 :
    did u lose the photochrom filter after updating?
     

    #34
  15. happiboi
    Gingerbread Jun 9, 2020

    happiboi , via OnePlus 8 Pro , Jun 9, 2020 :
    yep... from the feedback on the thread all IN2020/IN2025 models got it disabled.

    reading around, it's a temporary thing so hopefully in the next update it gets re-enabled
     

    #35
  16. cowboi007 , via OnePlus 8 Pro Ultramarine Blue , Jun 9, 2020 :
    Hi happyboi, I downloaded the oxygenos 10.5.9 in11ba (EU) version but would prefer to switch back to 10.5.10 in11AA. I've downloaded the in11AA version but it won't apply as stating the 10.5.9 in11ba version is higher. Any help would be appreciated.
     

    #36
  17. happiboi
    Gingerbread Jun 9, 2020

    happiboi , Jun 9, 2020 :
    Did you download it manually to try to get the phone to update it?

    I think when it's same level patch, it throws that error to to the internal checks. I would suggest the Oxygen Updater App instead. There seems to be an 'advanced mode' that allows for a "Full" system update to be applied, rather than an incremental (which does the check). Instructions posted here: https://forums.oneplus.com/threads/...21aa-to-europe-in21ba-the-simple-way.1236875/
     

    #37
  18. chazzer86
    Cupcake Jun 9, 2020

    chazzer86 , via OnePlus 8 Pro , Jun 9, 2020 :
    no I just got the standard notification that there was an update. the one previous mentioned the removal of the filter I didn't do that n the update disappeared. the lastest update mentioned nothing bout removing that feature so I updated but now lost that filter. hopefully I get it back soon
     

    #38
  19. cowboi007 , via OnePlus 8 Pro Ultramarine Blue , Jun 9, 2020 :
    Hi I did do it manually through oxygen updater app. I did so thinking it might help with 5g not working as I had global rom but it didn't. I've been in touch with oneplus and hope they have an answer soon. I now want to go back to the global rom of I can without any hassles. I've been notified through oxygen updater that there is an update 10.5.10 but the manual update won't let me install that version and states I have a version higher than the 10.5.10 but what is installed is 10.5.9 but EU version. Do you have any ideas of going back to global rom?
     

    #39
  20. happiboi
    Gingerbread Jun 9, 2020

    happiboi , Jun 9, 2020 :
    I don't know any other way apart from the 'full' system update via the Updater App.

    If nothign else works, might have to wait until next update is out and choose the NA version then?
     

    #40