0
5G Telstra on OnePlus 8 Pro in Australia

  1. ssabhyankar
    Donut Jun 11, 2020

    ssabhyankar , Jun 11, 2020 :

    I tried so much, however, PDC does not populate my phone, though it does show 'IN2020' in 'My Computer' before starting Full-port Switch ON.
    Any idea what could be the issue.
    Although I would be also trying one more time on another system.
     

    #41
  2. ssabhyankar
    Donut Jun 12, 2020

    ssabhyankar , via OnePlus 8 Pro , Jun 12, 2020 :
    Tries with another System as well, no luck.
     

    #42
  3. happiboi
    Gingerbread Jun 13, 2020

    happiboi , Jun 13, 2020 :
    @ssabhyankar - what do you get in the PDC screen when you connect?

    This has worked for quite a few of us now, so i am keen to help you.

    Have you installed the drivers? Do you run PDC as Administrator?
     

    #43
  4. ssabhyankar , via OnePlus 8 Pro Onyx Black , Jun 13, 2020 :
    The drop-down menu does not show anything. To be specific its blank.
    I have tried multiple times on 2 different systems. Also tried with QPST newer version.
    System does how IN2020, that does mean drivers are correctly installed.
    When phone is connected to system it shows the OnePlus drivers drive, but asa soon as full port switch is turned on, the drive goes away.
    Usb devices still keep to show an option safely remove IN2020 USB.

    Is that all it should look like?
    Indeed, PDC was being opened as administrator.
     

    #44
  5. cowboi007 , via OnePlus Community App , Jun 13, 2020 :
    Hi
    If you are referring to not being able to find the phones root directory on your pc, I have found that I needed to go into the phones settings and type USB. A few different options come up. You need to find USB menu that let's you change the preference and then choose file transfer and you will be able to access your phones memory on the pc. I don't know why it reverts back but it does and it's a pain. Hope this helps. [e]1f60a[/e]
     

    #45
  6. happiboi
    Gingerbread Jun 14, 2020

    happiboi , Jun 14, 2020 :
    Hi @ssabhyankar,

    I've uploaded some screen shots to show what mine looks like - https://imgur.com/a/lNvClKI

    Basically:
    - plug in usb cable to phone, i don't select any modes, leave it on no file transfer
    - You'll notice in 'my computer' that the phone is registered as a device (for me IN2020) and the drivers are loaded as a seperate drive
    - Then set "Full-port switch" to ON
    - You'll notice that the phone 'disappears' from the 'my computer view'
    - Then checking "Device Manager" , expand 'Ports' - should see an extra port (that being your phone because we enable Full-port)
    - Then startr up PDC as Admin
    - The drop down device should match with the port # shown in device manager
    - Selecting it should populate config options.

    If it doesn't work, i'm not sure what to really do other than uninstall everything and try again but you've tried on 2 different machines already. try searching for different drivers maybe - i've read the Oneplus 7 pro drivers work as well.
     

    #46
  7. happiboi
    Gingerbread Jun 15, 2020

    happiboi , via OnePlus 8 Pro Onyx Black , Jun 15, 2020 :
    Also wanted to let you guys know... i got both VOLTE and VOWIFI working on my OnePlus 8 Pro on Telstra too.

    pretty stoked to have it all working ( still trying to work out how to take it all for 2nd SIM too) but confirmed, tested 5G, VoLTE and VoWifi currently working on my IN2020.

    I'll post up what i did later but huge thanks to the XDA forums!
     

    #47
  8. happiboi
    Gingerbread Jun 16, 2020

    happiboi , Jun 16, 2020 :
    Here is some screenshots of 5G reception, VoLTE icon, VoWiFi icon & VoWiFi Calling while in aeroplane mode to confirm all these things are working!
    https://imgur.com/a/tau5wyX

    So what did I do? All credits go to this guy on XDA to get VoLTE & VoWiFi working

    For the TL;DR version, I did what I mentioned previously to get 5G going here: https://forums.oneplus.com/threads/...pro-in-australia.1225092/page-2#post-21673760
    https://forums.oneplus.com/threads/...pro-in-australia.1225092/page-3#post-21717398

    Then to get VoLTE & VoWiFi working download these files:
    EFS zip - https://drive.google.com/open?id=1PiVhB35MPx19sxqxQ4svgOvPXL1dxobt
    MBNs zip - https://drive.google.com/open?id=1v8V281EkYGI_C1KeMqVni8L2qjQLdx5P
    EfsTools 0.10 modded 1.2 - https://github.com/HomerSp/EfsTools...modded-1.2/EfsTools-0.10-modded-1.2-win32.zip
    EfsTools 0.10 modded 1.1 - https://github.com/HomerSp/EfsTools...modded-1.1/EfsTools-0.10-modded-1.1-win32.zip

    The reason I've linked both modded 1.1 & 1.2 is because 1.2 is the latest version and supports activation of 2nd SIM slot (but it errors for me so I used the modded 1.1 version but that only does SIM slot 1).

    So steps:
    - Enable the VoLTE/VoWiFi toggles first:
    - Download the OnePlus Log Kit app’s APK from > https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk
    -Install the OnePlus Log Kit APK
    - Open dialer, type in *#800# (If this doesn't do anything, just google search "Oneplus engineer mode apk", download and install it. Then retry)
    - Click 'Enter' on the warning
    - Select 'oneplus Logkit'
    - Scroll down & select 'Function Switch'
    - tick the VoLTE & VoWiFi switch options
    - Then reboot.
    - when your phone comes back after restart, in Settings > Wifi & network > SIM & network > SIM1 (and SIM2) > you should now see the 'Enhanced communications' area have the option to toggle on VoLTE/VoWiFi

    Onto the actual making VoLTE/VoWiFi work:
    - Unzip EfsTools into a directory
    - Open command window on PC & navigate to the directory created in above step
    - On your phone, go to dialer, type in *#801# - enter into it via 'engineer mode'
    - Select "Rndis, diag switch" - ON (last time we selected "full port switch on")
    - Then in the command window, you should be able to test connection to EFStools by typing "EfsTools.exe efsInfo"
    - This should give some info & not any errors (mine was like 2 lines of information)
    - Then the real fun begins.
    - Extract the efs.zip from above download into the same directory as the EFStools (make sure the mcfg_autoselect_by_uim file is there - yes it's 0 bytes) and then run 2 commands:
    - EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    - EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1 (this one I couldn't get working - it's for SIM slot 2 & only works if usinf modded 1.2 version)
    - should see 0 errors
    - then open the MBNs zip & look for your carrier file. Ours are \aunz\<your carrier - e.g. mine is Telstra>\commerci\mcfg_sw.mbn
    - copy this mbn file to the same dir as the EFStools, then run 2 commands:
    - EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    - EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1 (again this one I couldn't get working - it's for SIM slot 2 & only works if usinf modded 1.2 version)
    - If it worked your screen should spew out a load of output but no errors.
    - Reboot your phone & if you already enabled the switches from my above mentioned post, you should see the VoLTE/VoWiFi icons like in the screenshots linked above.

    Seems like a lot but that's literally step by step explanation & takes roughly 5-10 mins to do slowly.

    Happy days - 5G, VoLTE & VoWiFi all working on our OnePlus 8 Pro =)
     

    #48
    G_Jai_EbYG likes this.
  9. renato.libz
    Cupcake Jun 28, 2020

    Attached Files:

    Last edited: Jul 23, 2020

    #49
  10. Dominicstg
    Cupcake Jul 29, 2020 at 1:48 AM

    Dominicstg , Jul 29, 2020 at 1:48 AM :
    Can anyone confirm 5g is working on optus? Currently using a note 10 plus 5g and want to make the switch also got this email from them yesterday
     

    Attached Files:


    #50
  11. renato.libz
    Cupcake Jul 30, 2020 at 6:29 AM

    renato.libz , via OnePlus 8 Pro , Jul 30, 2020 at 6:29 AM :
    yes but youve gotta do a bit of a work around using a couple apps and a pc/laptop to change a few files on your phone... and it resets every update so so you gotta prepared to do it again to keep your 5g connection
     

    #51
  12. redders5
    Cupcake Aug 2, 2020 at 2:45 AM

    redders5 , Aug 2, 2020 at 2:45 AM :
    Thanks for the helpful info guys! Most of the previous posts have looked into getting Australian 5g working on the Chinese Version with Global ROM (available via Becextech).

    Am I right in saying that buying the Global Version via Kogan would avoid some of the additional backend work needed to get 5g working on Optus?
    Prefer to keep it as simple as possible even if it means paying a little extra.

    https://www.kogan.com/au/buy/oneplus-8-pro-8gb-ram-128gb-onyx-black-global-model-oneplus/
     

    #52