5G with Swisscom in Switzerland via OnePlus 8T

  1. RodSanderson
    Eclair Feb 13, 2021

    RodSanderson , via OnePlus 8T , Feb 13, 2021 :
    Hello Oneplus !

    I bought a Oneplus 8t 5g in Switzerland, but I still haven't 5G. You said it is a carrier problem but it is not. My carrier Swisscom says you have to add their carrier to your supported carriers's list to make Oneplus work in Switzerland.

    What's the problem ? Apple, Samsung and even Xiaomi are working with Switzerland, so do something please !

    M1620824873850, onephi and tobsin like this.
  2. O1575375110378
    Eclair Feb 13, 2021

    RodSanderson and Tokolozi like this.
  3. RodSanderson
    Eclair Feb 14, 2021

    RodSanderson , via OnePlus 8T , Feb 14, 2021 :
    That's not True. It's coming from Oneplus and they know it.

  4. O1575375110378
    Eclair Feb 14, 2021

    O1575375110378 , via OnePlus 8T , Feb 14, 2021 :
    Dude, why would I lie. A lot of people enabled 5g like this, even on Xiaomi device. It's carrier related 90%. For example, on Orange network 8t is supplied by operator, but I have to get a 5g subscription to be able to use 5g. On Digi Mobil they just enabled.

    Y1603743008207 and Tokolozi like this.
  5. Xpress0
    Gingerbread Feb 14, 2021

  6. RodSanderson
    Eclair Feb 15, 2021

  7. Tokolozi
    Most Original Avatar Feb 15, 2021

    Tokolozi , Feb 15, 2021 :
    That's generally not how it works, phones are just "slaves" to the carrier, the carrier need to white list devices to use the advanced network features such as 5G, Volte...

    By default they usually only white list devices they distribute (at least in the beginning)

    Y1603743008207 likes this.
  8. RodSanderson
    Eclair Feb 15, 2021

    RodSanderson , via OnePlus 8T , Feb 15, 2021 :
    So who's lying ? Oneplus or Swisscom ?
    And why xiaomi doesn't have this behaviour ?

  9. Tokolozi
    Most Original Avatar Feb 15, 2021

    Tokolozi , Feb 15, 2021 :
    For Belgium I can for sure say the operator, for Switzerland I woud assume the same.

    For Xiaomi they are usually already default whitelisted in the software since they are part of the top5 worldwide manufacturers

  10. G_Mr_....
    Jelly Bean Feb 19, 2021

    G_Mr_.... , via OnePlus 8T , Feb 19, 2021 :
    Hi all, I have an off topic question, with your 5G working do you have the voLTE toggle showing in your settings.
    I have the voLTE active in the top right hand corner but no toggle in my settings.



    Can't turn off voLTE if I wanted too, I could before the last update.

  11. StefanStark
    Ice Cream Sandwich Feb 19, 2021

    StefanStark , Feb 19, 2021 :
    For 5G to work you need ...

    A device that is capable of 5G in general.
    A device that supports the bands used in your region.
    A device that is supportet by the mobile provider (whitelisted) - as people already stated.

    You need a provider that supports 5G.
    You need a mobile plan that allows 5G.
    You need to be in an area that is 5G covered - antennas in your region nearby.
    You need to have 5G activated in the network settings of your SIM.

    If any of this points is missing / negativ / unknown - it is likely for you not being able to acess 5G.

  12. M1579601698385 , via OnePlus 8 Pro , Feb 20, 2021 :
    Its not a carrier problem, One Plus released a fully open carrier policy with 11.0.0 and I had 5G, VoLTE, VoWIFI for the time being. With 11.0.1 and later it stopped working...

  13. Aron.Stocker
    Eclair Mar 23, 2021

    Aron.Stocker , Mar 23, 2021 :
    I have this problem too.
    Called Swisscom so many times...but they told me i have to contact Oneplus Support.
    Oneplus support, last time i've contacted them, they told me to write down a feedback on the forum... And so 11 months have passed without 5G (i have all conditions, and a 5G contract).
    The only way to get it work is to edit carrier.xml using QPST.
    Tried a week ago with a Xiaomi Mi10 Lite and all went file at first sight.

    onephi, CAE2020 and yrogivue like this.
  14. Aron.Stocker
    Eclair Mar 23, 2021

    Aron.Stocker , Mar 23, 2021 :
    Just called Swisscom. They told me they need firstly to reach an agreement with Oneplus. Swisscom supports bands N1 and N78, the same Oneplus supports.
    So what can be done in order to make this happens? I think oneplus users in Switzerland are in a growing number.

    yrogivue likes this.
  15. Thaek
    Cupcake Mar 29, 2021

    Thaek , Mar 29, 2021 :
    Swisscom has all Devices Whitelisted, it's not a Network Provider Problem. OnePlus needs to add Swisscom to the Carrier Settings which are open and published by Swisscom.

    yrogivue and RodSanderson like this.
  16. Efixx
    Cupcake Mar 30, 2021

    RodSanderson likes this.
  17. oppo001
    Cupcake Apr 2, 2021

    oppo001 , Apr 2, 2021 :
    Switzerland: Any update on these content? It forced to change the phone and not to take any longer a oneplus.... I'm in since 1+1.... Absolutly important to get volte and vowifi.

    Aron.Stocker and RodSanderson like this.
  18. CAE2020
    Donut Apr 15, 2021

    CAE2020 , Apr 15, 2021 :
    I have the same issue since a year with my 8PRO.
    No 5G, no VoLTE or VoWIFI with Swisscom.

    there's simple no consideration of swiss market from OnePlus!!!!

    Aron.Stocker and RodSanderson like this.
  19. Tuukkа
    Cupcake May 6, 2021

    Tuukkа , May 6, 2021 :
    Hi all,

    Just to let you know, I recently inquired about the compatibility of the 8T with Swiss networks from the Oneplus customer service and the attached screen capture contains the response. Not catastrophic but not very promising either. Certainly not definitive.

    I'm thinking of taking the risk and updating my 7T to the 8T as I'm offered a very good deal. Even if 5G doesn't work out of the box, it seems many have been able to make it work with the instructions provided here: https://mt-tech.fi/en/modify-oneplus-7-pro-5g-8-and-8-pro-nr-lte-a-band-combos/

    Fingers crossed!

    Attached Files:

  20. oppo001
    Cupcake May 8, 2021

    oppo001 , May 8, 2021 :
    I know that isn't working out-of-the-box, unfortuannally... (still)

    here is the way how it works for me (swisscom , volte+vowifi OK):
    I tried it only for sim1

    OP7P_MBNs -> eu->dt->volte->commerci

    happiboi , Jun 16, 2020 :
    Here is some screenshots of 5G reception, VoLTE icon, VoWiFi icon & VoWiFi Calling while in aeroplane mode to confirm all these things are working!

    So what did I do? All credits go to this guy on XDA to get VoLTE & VoWiFi working

    Then to get VoLTE & VoWiFi working download these files:
    EFS zip - https://drive.google.com/open?id=1PiVhB35MPx19sxqxQ4svgOvPXL1dxobt
    MBNs zip - https://drive.google.com/open?id=1v8V281EkYGI_C1KeMqVni8L2qjQLdx5P
    EfsTools 0.10 modded 1.1 - https://github.com/HomerSp/EfsTools...modded-1.1/EfsTools-0.10-modded-1.1-win32.zip

    So steps:
    - Enable the VoLTE/VoWiFi toggles first:
    - Download the OnePlus Log Kit app’s APK from > https://downloadmirror.co/1MW9/com.oem.oemlogkit_1.0-1.apk
    -Install the OnePlus Log Kit APK
    - Open dialer, type in *#800# (If this doesn't do anything, just google search "Oneplus engineer mode apk", download and install it. Then retry)
    - Click 'Enter' on the warning
    - Select 'oneplus Logkit'
    - Scroll down & select 'Function Switch'
    - tick the VoLTE & VoWiFi switch options
    - Then reboot.
    - when your phone comes back after restart, in Settings > Wifi & network > SIM & network > SIM1 (and SIM2) > you should now see the 'Enhanced communications' area have the option to toggle on VoLTE/VoWiFi

    Onto the actual making VoLTE/VoWiFi work:
    - Unzip EfsTools into a directory
    - Open command window on PC & navigate to the directory created in above step
    - On your phone, go to dialer, type in *#801# - enter into it via 'engineer mode'
    - Select "Rndis, diag switch" - ON (last time we selected "full port switch on")
    - Then in the command window, you should be able to test connection to EFStools by typing "EfsTools.exe efsInfo"
    - This should give some info & not any errors (mine was like 2 lines of information)
    - Then the real fun begins.
    - Extract the efs.zip from above download into the same directory as the EFStools (make sure the mcfg_autoselect_by_uim file is there - yes it's 0 bytes) and then run 2 commands:
    - EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim
    - should see 0 errors
    - then open the MBNs zip & look for your carrier file. Ours are \aunz\<your carrier - e.g. mine is Telstra>\commerci\mcfg_sw.mbn
    - copy this mbn file to the same dir as the EFStools, then run 2 commands:
    - EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v
    - If it worked your screen should spew out a load of output but no errors.
    - Reboot your phone & if you already enabled the switches from my above mentioned post, you should see the VoLTE/VoWiFi icons like in the screenshots linked above.

    Seems like a lot but that's literally step by step explanation & takes roughly 5-10 mins to do slowly.

    Happy days - 5G, VoLTE & VoWiFi all working on our OnePlus 8 Pro =)

    I hope it will help you as well.

    RodSanderson likes this.