0
5Ghz not detecting on the OnePlus 3T

  1. nathan57971
    Eclair Jan 14, 2017

    nathan57971 , Jan 14, 2017 :
    As the title states the Oneplus 3T recently purchased a week ago doesn't detect my 5ghz network. My other devices such as the Nexus 6 and Nexus 6P do not have any problem connecting to the network. If I set the wifi setting on the OP3T to detect only 5ghz networks, nothing shows up. I tried rebooting into safe mode without any success. the 2.4ghz network works without any issues. My next option will be to reset the phone and see if that helps. I just wanted to know if there was anyone else with this issue and if there is a fix for it.

    I'm running stock Oxygen OS 4.0 Never unlocked the bootloader or tried flashing of any recovery

    I also tried a factory reset and it still doesn't detect the network
     

    #1
  2. F_Diganta_Koner_WIXu
    Jelly Bean Jan 14, 2017

    F_Diganta_Koner_WIXu , Jan 14, 2017 :
    Scroll down from notification bar, long tap on the WiFi icon. It will take you to the WiFi settings page, on the top right beside the gear icon you will find a three button icon click on that and then click advanced you will get the WiFi frequency option. Set it to automatic or 5ghz whichever you like. Your phone should now detect 5ghz frequency bands.

    Hope this helps
     

    #2
    ddaharu likes this.
  3. shishkamal
    Cupcake Jan 14, 2017

    shishkamal , Jan 14, 2017 :
    Just update ur phone to 7.0 or goto setting> wifi>advanced> wifi frequency band and set it manually

    Ur problem will be solved
     

    #3
    I got the juice and lostLambda like this.
  4. nathan57971
    Eclair Jan 14, 2017

    nathan57971 , Jan 14, 2017 :
    I did that, set it to detect only 5Ghz networks but nothing shows up in the list. my other devices have no issue connecting to the 5Ghz network.

    tried adding the network manually too but it still doesn't work. it's frustrating.
    it could be a hardware issue
     

    #4
  5. nathan57971
    Eclair Jan 14, 2017

    nathan57971 , Jan 14, 2017 :

    I am running Android 7.0
     

    #5
  6. F_Diganta_Koner_WIXu
    Jelly Bean Jan 14, 2017

    F_Diganta_Koner_WIXu , Jan 14, 2017 :
    Did you set it to automatic and try??
     

    #6
  7. F_Diganta_Koner_WIXu
    Jelly Bean Jan 14, 2017

    F_Diganta_Koner_WIXu , Jan 14, 2017 :
    Did you set it to automatic and try??
     

    #7
  8. nathan57971
    Eclair Jan 14, 2017

    nathan57971 , Jan 14, 2017 :
    yup did that too.. have no issues with 2.4Ghz networks
     

    #8
  9. nathan57971
    Eclair Jan 14, 2017

    nathan57971 , Jan 14, 2017 :
    Fixed! manually setting the 5ghz channel to 44 worked for me. Weird why it didn't work earlier on auto since mine is the only 5ghz network in my area. anyways thanks for the help.
     

    #9
    lostLambda likes this.
  10. G_Joe_Vincent_Iscala_irZ
    Cupcake Jan 15, 2017


    #10
  11. arif0790
    Donut Feb 16, 2017

    arif0790 , Feb 16, 2017 :
    Can you share the procedure to do that? It'll be helpful for others like me.
    Thanks
     

    #11
  12. G_Vasiliy_Safronov_ufue
    Eclair Apr 13, 2017


    #12
  13. G_Vasiliy_Safronov_ufue
    Eclair Apr 13, 2017


    #13
  14. G_Vasiliy_Safronov_ufue
    Eclair Apr 13, 2017


    #14
  15. isty
    Ice Cream Sandwich Apr 13, 2017


    #15