0
5Ghz wifi issues drive me nuts..

  1. grisuAMS
    Cupcake Apr 18, 2021

    grisuAMS , Apr 18, 2021 :
    Got 2 fully updated oneplus 9 pro.. Both experience the same 5ghz wifi issues. Shows connected but nothing goes through., both on 2.5 GHz wifi work without any issue. We had 2 opo 8pro before and never had such issues. I have seen all the posts with the same problem but somehow did not find any solution yet?! Any help much appreciated
     

    #1
  2. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 18, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 18, 2021 :
    In the past on 8 series some had issues on mesh networks, APs and certain routers.
    Some was solved with any of these steps router firmware upgrades, disable WiFi-6, enable WPA3 or temporary use other encryption level, disable Smart Connect, change channel. The same issues seemed to exist in similar cases on SD865 equipped Samsung. So in that case I can only speculate on some Qualcomm issues or combination of router/client flaws. On SD888 it may very well also be a certain troublesome combination. Regardless what or who that is behind this issue you can report this via the feedback tool.
    I had some major issues on my 7 Pro that only triggered on the network at work. I reported it and it was resolved.

    View attachment 1590642
     

    #2
    Caoimhín likes this.
  3. Dodgr
    Cupcake Apr 18, 2021

    Dodgr , via OnePlus 8 Pro , Apr 18, 2021 :
    I had the same issue with my 8 Pro. Worked fine on 2.4ghz but not 5ghz. I'm using a Netgear Wi-Fi 6 router and it was set to WPA2 mode for security.

    I fixed my problem by changing to WPA3 in the settings of my router. Give that a try if using Wi-Fi 6.
     

    #3
    Caoimhín likes this.
  4. grisuAMS
    Cupcake Apr 19, 2021

    grisuAMS , Apr 19, 2021 :
    Continued to try to figure it out, we are now running to WLAN setups, one 2.5 GHz = no issues, 5Ghz major issues. Both running from the same ubiquiti unify Dream machine. Strange that both the new Oneplus 9 pro show the same identical issues :-(
     

    #4
  5. darkarvan
    Cupcake Apr 19, 2021

    Last edited: Apr 20, 2021

    #5
  6. NaXal
    Gingerbread Apr 19, 2021

    NaXal , via OnePlus 8T , Apr 19, 2021 :
    Hello,

    There are few troubleshooting steps one needs do,

    1. Go to your WiFi Networks settings & check if the DHCP is working or not to assign the device right IP / Subnet / DNS & Getway.

    2. If those details are right, now download any ping testing apps & first Ping your Getway, which is normally your router. Check if pings are returning or not.

    3. Now ping any outside Website / IP like 8.8.8.8 to see if the pings are returning or not.

    In case you are stuck in step two, then you need to check our router settings, if any fire wall is blocking it or not. May be you need to manually set IP for these devices due some DHCP issues.

    Check & revert back as at which step your device is getting stuck?

    Thanks.
     

    #6
    grisuAMS likes this.