3
6T not able to cast to any chromecast devices

  1. mut
    Cupcake Jul 8, 2021

    mut , Jul 8, 2021 :
    Hi,
    I have recently ran into a problem casting to any device. I have 8 or so devices connected to google home app. I have used it/chromecast for many years.
    All of the sudden today I tried to cast to a speaker and the YT music app didn't even allow me to open the cast tab. So I tried the YT app and it brings a popup saying "Connect to a device" Then says "No device found"
    I have tried both wifi bands while trying to cast and same thing.
    Cast works on my older phone and chromebook.
    Is there something that I am missing on what is going on here?
    I contacted google and they say try oneplus, as other devices I have work fine.

    Anyone had same issue? Does anyone know what is causing this?

    Thank you in advance for any and all help

    J.

    Well I couldn't find any information on how to fix this. so, I saved everything and did full factory reset. Installed everything except system settings back using OnePlus switch.
    Phone now seems to be working properly again.
    Like I stated, I couldn't find any info on this problem, but factory reset did work.
    I hope this may help someone else of they run into same problem, or someone smarter than me can figure out why/what is causing this.
    Jeff
     
    Last edited: Jul 10, 2021

    #1
  2. Ceascii
    Cupcake Jul 9, 2021

    Ceascii , via OnePlus 6T , Jul 9, 2021 :
    Can confirm I'm also having the same issue. Troubleshooted and tested multiple devices, the issue is only on the 6T it seems.
     

    #2
    chogguk and mut like this.
  3. robangus
    Donut Jul 10, 2021

    robangus , Jul 10, 2021 :
    Also having this issue which i noticed last night. Sole reason i came here
     

    #3
    mut likes this.
  4. mut
    Cupcake Jul 10, 2021

    mut , via OnePlus 6T , Jul 10, 2021 :
    I also tried many different devices including old Chromebook and Nexus 4 and Nexus 5. 6T was only one having this problem.
     

    #4
    Ceascii likes this.
  5. robangus
    Donut Jul 10, 2021

    robangus , Jul 10, 2021 :
    I've tested on my OP3 that i had tucked away in a cupboard and it worked fine. Other household member able to control and use devices just fine. Very strange and annoying! Google support werent able to find any particular cause so assume its an issue with the 10.3.11 update.
     

    #5
  6. robangus
    Donut Jul 10, 2021

    robangus , Jul 10, 2021 :
    In the google home app... does your app crash when you tap on a chromecast? Its affecting my chromecast and speakers. Also cant cast from spotify to the speaker.
     

    #6
    chogguk likes this.
  7. chogguk
    Cupcake Jul 13, 2021

    chogguk , Jul 13, 2021 :
    Having the same issue with OnePlus 6.
    Did a factory reset on Sunday 11/07/21 and it fixed the issue.

    Now today the issue has come back, none of my Chromecast or speakers appear as available to cast to.

    When selecting one of the devices in the Google Home app, the app force closes.
    Tried reinstalling the Google Home app, problem still exists.

    If I change to a guest profile on the phone, then I can cast no problem. But when I go back to my original profile the casting does not work.
     

    #7
  8. Diegocampy
    Cupcake Jul 16, 2021


    #8
  9. pablofg1978
    Head Moderator Head Moderator Jul 16, 2021

    pablofg1978 , Jul 16, 2021 :
    Check this threads
    https://forums.oneplus.com/threads/no-cast-devices-discovered.1416960/
    https://forums.oneplus.com/threads/chromecast-issue.1463801/
    It seems to be a problem with google and android 10
     

    #9
    Diegocampy likes this.
  10. Diegocampy
    Cupcake Jul 17, 2021


    #10
  11. pablofg1978
    Head Moderator Head Moderator Jul 17, 2021

    pablofg1978 , Jul 17, 2021 :
    If the problem is what it was mentioned above (Related to android 10) then you can try installing the android 11 beta
     

    #11
    Diegocampy likes this.
  12. Diegocampy
    Cupcake Jul 31, 2021


    #12
  13. Diegocampy
    Cupcake Aug 1, 2021

    Diegocampy , Aug 1, 2021 :
    I have cleared the data and cache of the google play service and now, with the beta 2 with Android 11 I have solved the problem.
     

    #13
  14. Raza_Dawar
    Gingerbread Aug 1, 2021


    #14