0
ADB shows error 'no devices/emulators found'

  1. G_Jay_Nafade_LOwC
    Froyo Nov 23, 2016

    G_Jay_Nafade_LOwC , Nov 23, 2016 :
    I have recently tried using ADB/fastboot to install the community build. I am certain I have installed the correct ADB/fastboot drivers and also the universal ADB driver, furthermore I have also installed all of the oneplus drivers so let me describe to you what happens.
    1) I plug my phone into my PC- yes I have USB debugging enabled
    2) Run the ADB/fastboot command prompt and type in the 'adb devices' command
    3) The command prompt then recognises my phone and shows it as a 'device'
    4) I then reboot my phone into recovery and type in the same 'adb devices' command, this time it shows no devices
    5) I then use the 'adb sideload <filename>' command and it shows a message saying that it is loading the files
    6) After about a minute or so of waiting, the message 'error: no devices/emulators found' appears.
    Note that I am on windows 10, I have pretty much searched everywhere and scoured the forum to no avail. I hope you can help me as I really want to get the community build.
     

    #1
  2. jonitfcfan
    Jelly Bean Nov 23, 2016

    jonitfcfan , Nov 23, 2016 :
    I think you need to replace "adb" with "fastboot" if you're booted in recovery or fastboot/download mode (i.e. type "fastboot devices" instead).
     

    #2
    Tokolozi likes this.
  3. Bartnl
    Lollipop Nov 23, 2016

    Bartnl , Nov 23, 2016 :
    There is a glitch in Windows 10 Anniversary that causes this.
    Possible solution:
    https://forums.oneplus.net/threads/fastboot-and-adb-not-recognizing-device.471244/
    or
    https://forums.oneplus.net/search/10386325/?q=adb&o=date&c[title_only]=1&c[node]=200
     

    #3
  4. G_Jay_Nafade_LOwC
    Froyo Nov 23, 2016

    G_Jay_Nafade_LOwC , Nov 23, 2016 :
    I don't think so, 'adb devices' is more of a verification, the actual command to sideload sitll involves adb
     

    #4
  5. G_Jay_Nafade_LOwC
    Froyo Nov 23, 2016

    G_Jay_Nafade_LOwC , Nov 23, 2016 :
    hey, on the first link, the solution involves installing drivers and there is a download link for this which I have downloaded. However, there is no .exe file which will install these drivers, so I don't really know how to install them. Could you please help me out if you could.
     

    #5
  6. Bartnl
    Lollipop Nov 23, 2016

    Bartnl , Nov 23, 2016 :
    you need to install them through the device manager of windows
    open it, connect your phone and see what will be added in the list. click with right mouse button on that driver, click reinstall, click pick driver by hand and select the downloaded driver
     

    #6
  7. Buddin
    Froyo Nov 24, 2016


    #7
  8. CsRohit
    Froyo Nov 24, 2016


    #8
    moritzknbl likes this.
  9. JorgeManuelSilva91
    Ice Cream Sandwich Nov 24, 2016

    JorgeManuelSilva91 , Nov 24, 2016 :
    This might help. I've posted this some days ago in another topic:
     

    #9
  10. G_Jay_Nafade_LOwC
    Froyo Nov 24, 2016


    #10
  11. shalinsaini
    Froyo Nov 24, 2016

    shalinsaini , Nov 24, 2016 :
    go to control panel
    system
    device manager
    add legacy hardware
    select android set it up and you are ready to go
     

    #11
  12. G_Jay_Nafade_LOwC
    Froyo Nov 24, 2016

    G_Jay_Nafade_LOwC , Nov 24, 2016 :
    in my oneplus drivers folder, there is no Oneplus_android_winusb
     

    #12
  13. G_Jay_Nafade_LOwC
    Froyo Nov 24, 2016

    G_Jay_Nafade_LOwC , Nov 24, 2016 :
    Well there is, but it doesn't show up when browsing for files in the device manager, only folders show up
     

    #13
  14. G_Jay_Nafade_LOwC
    Froyo Nov 24, 2016

    G_Jay_Nafade_LOwC , Nov 24, 2016 :
    There is no android option
     

    #14
  15. JorgeManuelSilva91
    Ice Cream Sandwich Nov 24, 2016

    JorgeManuelSilva91 , Nov 24, 2016 :
    Windows 10 is broken, left center and right. Plain and simple.

    You need to enable F8 boot mode using the tips at:
    http://www.tenforums.com/tutorials/22455-f8-advanced-boot-options-enable-disable-windows-10-a.html
    Code:
    bcdedit /set {bootmgr} displaybootmenu yes
    bcdedit /set {current} bootmenupolicy Legacy
    After that, you need to press F8 right after BIOS/UEFI messages while you PC boots and immediately before Windows Logo shows up.

    Then pick "Disable Driver Signature Enforcement" and proceed as my post regarding drivers installation.
     

    #15
  16. G_Jay_Nafade_LOwC
    Froyo Nov 24, 2016

    G_Jay_Nafade_LOwC , Nov 24, 2016 :
    ok will do, thank you very much
     

    #16
  17. G_Jay_Nafade_LOwC
    Froyo Nov 25, 2016

    G_Jay_Nafade_LOwC , Nov 25, 2016 :
    Hi, when I go into the device manager, there is no 'Android' there when I have my phone plugged in.
    EDIT: Fixed it, thank you
     

    #17
  18. JorgeManuelSilva91
    Ice Cream Sandwich Nov 25, 2016


    #18
  19. G_Jay_Nafade_LOwC
    Froyo Nov 25, 2016

    G_Jay_Nafade_LOwC , Nov 25, 2016 :
    Sadly no, because it now says 'cannot read' the .zip file, and in device manager, there is no 'Android' showing up when I'm in sideload mode
    This is what I do:
    1) Plug in my OP3
    2) Go to device manager where under 'other devices' I see 'Android' with a yellow triangle
    3) I then right click and select 'Update Driver Software'
    4) Then click 'Browse my computer for driver sotheftware'
    5)When I browse I find the OneplusDrivers folder and then click next
    6)It then says 'windows could not find the driver software for your device'
    I'm sorry if I'm bothering you, but I really want the community build.
     
    Last edited: Nov 25, 2016

    #19
  20. JorgeManuelSilva91
    Ice Cream Sandwich Nov 25, 2016

    JorgeManuelSilva91 , Nov 25, 2016 :
    You need to always boot with "Disable Driver Signature Enforcement" when you are performing this kind of things. Windows 10 is a true pain in that regard.
     

    #20