[Submitted] After OTA update to 4.1.7 GPS is not working

  1. krah63
    Cupcake Aug 28, 2017

    krah63 , Aug 28, 2017 :
    update from 4.1.6 to 4.1.7 OTA
    switch on GPS (Localization)
    run any GPS using application: google maps, here maps, endomondo, GPS Reset Com, none of them can show teh position due to lack of data from GPS

  2. hclojacky
    Donut Aug 28, 2017

  3. derekd84
    Eclair Aug 28, 2017

    derekd84 , Aug 28, 2017 :
    I am having the same issue on my OP3T after completing the 4.1.7 update.
    The GPS either cannot lock at all or when it does work, it is very erratic and and laggy.
    I have tried with both Google Maps and Waze.

  4. anandvk
    Cupcake Aug 29, 2017

    anandvk , Aug 29, 2017 :
    I faced the same issue in Waze. It doesn't get gps and keeps asking me to go outside to get better signal.. when I am driving!

    jurisb likes this.
  5. meierzwo
    Cupcake Aug 29, 2017

    meierzwo , Aug 29, 2017 :
    Same on my 3T after the last OS Update.

    It's a problem with A-GPS data. Even if you update the Data, the 3T is working with outdated Data and is searching for the wrong Satellites. It doesn't do a real search for Satellites. I checked with a second Device. The 3T shows two outdated Satellites with poor reception. The second Device, (a old Nexus 5), shows this two also, but also all the other Satellites, the 3T didn't find. A long wait over 10 Minutes didn't change the Situation on the 3T. It's not a Hardware Issue , it's a Software Bug in the latest OS Release. Disabling the use of A-GPS Date fixes the Problem. Goto "Hardware -> Location -> Modus" and check Device Only. Only the GPS-Receiver is now used. I got a fast Fix with accurate Position.

    derekd84, Sabbir.Naim and rszalai like this.
  6. jurisb
    Donut Aug 30, 2017

    jurisb , Aug 30, 2017 :
    I can confirm this on OnePlus3T after OTA upgrade from 4.1.6 to 4.1.7. Waze is especialli slow in acquiring GPS lock, can take up to 5 minutes. Previously it was almost instant.

    Hotdoug likes this.
  7. rszalai
    Cupcake Aug 30, 2017

    Hotdoug and Sabbir.Naim like this.
  8. gregory.gjp
    Froyo Aug 30, 2017

    gregory.gjp , Aug 30, 2017 :
    Ok, so why on 4.1.6 it worked flawlessly? They "outdated" the GPS data on 4.1.7?

  9. derekd84
    Eclair Aug 31, 2017

    derekd84 , Aug 31, 2017 :
    Tried this out yesterday and this morning.
    First left it on high accuracy and waze would take forever to lock and fly around the map.
    Second changed to device only and it was an immediate lock.

    amod_thakur likes this.
  10. krah63
    Cupcake Sep 1, 2017

    krah63 , Sep 1, 2017 :
    I my case it was not A-GPS, wiht AGPS it was somehow working on device only navigation was not working at all. No satelites found at all. Factory reset did not help, downgrade to 4.1.6 did not help. Issue got resolved by Oneplus service via remote session and flash of new software.

  11. hclojacky
    Donut Sep 1, 2017

    hclojacky , Sep 1, 2017 :
    What new software you are flashing?
    Could you give us more details?

  12. 7226
    Cupcake Sep 1, 2017

  13. AlcaloideDoErgot
    Eclair Sep 2, 2017

    AlcaloideDoErgot , Sep 2, 2017 :
    I bought my 3t and it came with 4.0.3. I decided to wait a bit for more stables versions. I then hit the button when 4.1.7 came. The installation was fine using adb. But I started to have issues with Google Maps. I will try to change and see this particular solution people are saying: change to device only.
    Having other minor problems, but battery is definitely better, no doubt about that.

  14. G_Jérôme_Rieucros_oDKU
    Cupcake Sep 2, 2017

    7226 likes this.
  15. hclojacky
    Donut Sep 3, 2017

    hclojacky , Sep 3, 2017 :
    Hey guys, I think I have fixed this problem by doing this:
    1. Download the GPS status and toolbox app
    2. Get into the app and redownload the A-GPS data
    That's it!

    It works for me after doing this!! Now high accuracy mode is working again.

    roadrunner4spd and Arfam like this.
  16. roadrunner4spd
    Cupcake Sep 8, 2017

    roadrunner4spd , Sep 8, 2017 :
    same issue with GPS on two Oneplus 3T's in my house. GPS can not get a fox after phone screen is locked for a short period of time. Resetting AGPS Data is not a permanent fix for wither of these phones. Going back to 4.1.6 repaired the GPS on the phone I rolled back form the failed 4.1.7 update.

  17. jurisb
    Donut Sep 8, 2017

    jurisb , Sep 8, 2017 :
    I have been reluctant to roll back to 4.1.6. Will see how long I have patience :)

  18. roadrunner4spd
    Cupcake Sep 8, 2017

    roadrunner4spd , Sep 8, 2017 :
    ps... why is there no edit post button to fix typos? Says on bottom in help forum which is incorrect on Firefox, seamonkey and Chrome....

  19. roadrunner4spd
    Cupcake Sep 8, 2017

    roadrunner4spd , Sep 8, 2017 :
    4.1.7 is a failure due to this

    jurisb likes this.
  20. derekd84
    Eclair Sep 13, 2017

    derekd84 , Sep 13, 2017 :
    I rolled back to 4.1.6 last night and now everything is good.
    However I will say that the battery optimization in 4.1.7 is better than 4.1.6 in my usage.

    roadrunner4spd likes this.