1
Akku- und Google Play Services Probleme Android OS

  1. ɢноѕтΘпе
    Nougat Mar 21, 2015

    ɢноѕтΘпе , Mar 21, 2015 :
    Du musst unter Einstellungen -> Sicherheit -> Geräteadministratoren -> den Android Geräte-Manager ausschalten.
     

  2. script
    Moderator Moderator Mar 21, 2015

    script , Mar 21, 2015 :
    Will auch eins
     

    Wasbinich, ymicky, PanaS and 3 others like this.
  3. berlifan13
    Froyo Mar 21, 2015

    berlifan13 , Mar 21, 2015 :
    Auf die Gefahr das ich den "Ironiemodus" übersehen habe, geb ich noch einen....
     

    script likes this.
  4. script
    Moderator Moderator Mar 21, 2015

    script , Mar 21, 2015 :
    War voll Ironie-frei :)
     

  5. script
    Moderator Moderator Mar 21, 2015

  6. Rowios
    Gingerbread Mar 22, 2015

    Rowios , Mar 22, 2015 :
    Ich finde, als erstes sollte der Lösungsansatz, den @GhostOne hier bereits mehrfach genannt hat, ausprobiert werden. Dieser ist zudem sicherer, als Berechtigungen einer System-App zu beschneiden. Bei mir trat das Problem auch erstmals vor 2-3 Tagen mit dem Update der Google Play-Dienste auf v 7.0.97 auf. Gestern habe ich dann in den
    - Einstellungen unter "Sicherheit", "Geräteadministratoren" den "Android Geräte-Manager" ausgehakt.
    - Jetzt in die App-Info von den Google Play-Diensten gehen und dort auf "Deaktivieren", bestätigen und anschließend durch ein erneutes OK die App durch die Werksversion ersetzen.
    - Gerät neustarten
    - Man wird nun eine alte Version der Google Play-Dienste haben, die nach einer Zeit bzw durch späteren Neustart automatisch wieder auf die neueste 7er Version upgedated wird.

    Somit waren die Wakelocks behoben!
    Falls das nicht hilft, kann man sich immer noch der anderen Methode bedienen.
     

  7. VinzentVega
    Gingerbread Mar 22, 2015

    VinzentVega , Mar 22, 2015 :
    Ich habs jetzt mal ausprobiert. Auf einmal hab ich in 24h fast 50% Akkuleistung verloren. Vorher waren es so ca 18%.
    Zwingend beschneiden will ich nicht unbedingt, obwohl ich mich auch ernsthaft frage, warum Google jede Minuten meinen Standort checken muss....
     

  8. script
    Moderator Moderator Mar 22, 2015

    script , Mar 22, 2015 :
    Bei mir hat das Ersetzen der GP-Dienste nicht geholfen, erst nachdem ich den XDA-Tipp, den weltraumpenner gepostet hat, und der auch im Hauptforum besprochen wird, angewendet habe, war wieder alles gut.
    Ist aber fast egal: in ein paar Tagen kommen sowieso diverse Updates, dann wird alles gut (und manches....???)

    VG script
     

  9. Johannes1098
    KitKat Mar 22, 2015

    Johannes1098 , Mar 22, 2015 :
    Ja, hoffen wir mal dass dann alles gut wird.
    Wie gesagt: Die Hoffnung stirbt zuletzt ;)
     

  10. Gertsch
    Cupcake Mar 22, 2015

    Gertsch , Mar 22, 2015 :
    Bei mir hat sich das Problem mit den Services zwar erledigt, aber nun zieht der Mediaserver dick Strom....
    Screenshot_2015-03-22-22-13-13.png
     

  11. Patman75
    KitKat Mar 22, 2015

    Patman75 , Mar 22, 2015 :
    Hi,
    ist bei dir das Problem mit dem Mediaserver neu, oder hattest du das kürzlich schonmal bei AH gepostet?
     

  12. Gertsch
    Cupcake Mar 22, 2015


  13. supermancece
    Eclair Mar 23, 2015

    supermancece , Mar 23, 2015 :
    Ich hatte in der Nacht von gestern auf heute auch das Problem mit den Google Play Diensten, habe die Updates deinstalliert, die Dienste kurz deaktiviert und wieder aktiviert, nur sind jetzt keine Updates mehr dafür verfügbar?!

    Außerdem habe ich folgende Apps deaktiviert, um Akku zu sparen, kann das zu Systemproblemen führen?
    Screenshot_2015-03-23-08-33-33.png Screenshot_2015-03-23-08-33-43.png
     

    Patman75 likes this.
  14. ɢноѕтΘпе
    Nougat Mar 23, 2015


    supermancece likes this.
  15. chitypo
    Donut Mar 23, 2015

    Last edited: Mar 26, 2015

  16. Patman75
    KitKat Mar 23, 2015

    Patman75 , Mar 23, 2015 :
    @Gertsch
    Man findet glaub ich im Netz nicht wirklich was über den Mediaserververbrauch.
    Ich denk mal das kriegt sich von selbst wieder ein.
    Aber du könntest das Gerät mal neustarten, bzw etwa 10min überhaupt abgeschaltet lassen, dann Neustart.
    Oder Gerät mal paar Stunden abgeschaltet laden, vielleicht davor nutzen bis es selbstständig runterfährt (eine Restladung verbleibt im Akku um einer Tiefentladung vorzubeugen).
    Da der Drain offenbar erst nach dem Update der Playservices anging, könntest du da mal die Updates deinstallieren, Gerät rebooten, Updates der PS neu installieren.
    Cache und Daten der App könntest auch mal löschen, wird aber schätzungsweise nix bringen.

    Ich hab da nen themenähnlichen Artikel dazu gelesen wonach der interne Speicher ununterbrochen gescannt würde, von einer Anwendung oder nem Dienst.
    Deßhalb würde ich auch mal prüfen, welche Art von Apps installiert sind und ggf Anwendungen wie FB oder Tw, WA, Skype und dergleichen mal deinstallieren, im Recovery Cache Partitionen wipen und rebooten, und kucken ob sich der Mediaserverver einkriegt.

    Wie hast du die Playservices geupdatet?
    Automatisch per Playstore oder manuell die APK?

    PS
    Ich hoffe du deaktivierst nicht planlos rum wie der nächste Kollege laut Bildchen; dann würde mich nämlich nix mehr wundern.
     
    Last edited: Mar 23, 2015

  17. sYntiq
    Froyo Mar 23, 2015

    sYntiq , Mar 23, 2015 :
    Darum fragt der "Kollege" ja auch ob das zu Problemen führen kann.
    Was mich btw. auch interessieren würde. Würde auch gern diverse Apps deaktivieren die ich (vermute ich) eh nicht brauche, (Google Play Books, Google Play Kiosk, Google Play Music, Google+ zB.) weiß aber nicht ob ich das einfach so gefahrlos machen kann.
     

  18. Patman75
    KitKat Mar 23, 2015

    Patman75 , Mar 23, 2015 :
    Falsch.
    Der deaktiviert ohne Kenntnis, daraus ensteht ein Problem und nun sollen andere es lösen.

    Und ich trau mich wetten, wenn man bei allen Usern die über Probleme mit Android OS, System oder den Playservices klagen, prüfen könnte (oder die es wenigstens ehrlich eingestünden) was da herumgeschraubt wurde vom Nutzer selbst, mindestens die Hälfte davon selbst verschuldet ist.
     

    JelleZon and RoggaRolla like this.
  19. JelleZon
    OnePlus Accessory Tester Mar 23, 2015

    JelleZon , Mar 23, 2015 :
    Die genannten kannst du ohne Probleme deaktivieren.
     

  20. Rowios
    Gingerbread Mar 23, 2015

    Rowios , Mar 23, 2015 :
    Falls dir die brauchbaren Tipps von Patman75 auch nicht weiterhelfen, könntest du dir folgendes durchlesen:
    http://www.android-user.de/mediaser...-hohen-akkuverbrauch-so-schaffen-sie-abhilfe/
    Vielleicht bringt dich das auf die Spur

    Einerseits gebe ich dir Recht, es gibt genug die ohne Plan am System herumspielen und sich dadurch etwas kaputt machen. Aber in dem Fall, im Zusammenhang mit den Wakelocks durch die Google Play-Dienste, doch etwas weit hergeholt :D
    Die aktuellen Probleme um den Akkuverbrauch durch die Google Play-Dienste haben rein gar nichts mit dem Deaktiveren der abgebildeten System-Apps zu tun.
    Du hast bestimmt schon diesen Thread hierzu gesehen:
    https://forums.oneplus.net/threads/...-days-there-is-a-reason-heres-the-fix.284095/
    Nicht die User sind Schuld an diesem Bug, der vor allem seit der neuen Version 7.0.97 der Google Play-Dienste bei vielen CM-Nutzern auftritt, sondern Google selbst.
    Genauso wie sie mit 5.0 zum Teil Mist gebaut haben und jetzt so langsam mit 5.1 ausbügeln.

    @supermancece zumindest bei Drive, Galerie, Play Books, Kiosk, Movies, Music, Google+,
    Hangouts und SwiftKey weiß ich, dass du die ohne Bedenken deaktiviert lassen kannst.
    Für den Rest müsstest du dich nochmal informieren, vllt findest du im Thread von @weltraumpenner
    nützliche Infos
    https://forums.oneplus.net/threads/liste-welche-system-apps-koennen-entfernt-werden.175151/


    Wer ein gerootetes Smartphone hat und ein Zurücksetzen der Google Play-Dienste nichts bringt,
    kann sich als Alternative die App "Disable Service" aus dem Play Store installieren.
    Dort geht man zuerst auf den "System"-Tab und scrollt dann zu den Google Play-Diensten, tippt
    drauf und scrollt anschließend weit runter bis "System Update Service" und hakt es an.
    https://forums.oneplus.net/threads/...-days-there-is-a-reason-heres-the-fix.284095/
    Die Option übersteht aber keine Reboots, wie darin falsch beschrieben wird. Das heißt, wenn man sein Gerät neu startet, muss man nochmal in die App und den "System Update Service" anhaken.
    Habe das gestern auch ausprobiert und es funktioniert einwandfrei.

    Laut dieser Seite http://review.cyanogenmod.org/#/c/91021/ wurde das in CM12 bereits gefixt, allerdings wohl noch nicht in CM12s, weil ich erst neulich hier im CM12 Nightly-Thread gesehen habe, dass jemand auch Probleme mit den Google Play Diensten hatte
     

    Deactivated User and script like this.