3
Alarm not going off

  1. G_Fabian_Jano_BqHI
    Cupcake Jan 13, 2019

    G_Fabian_Jano_BqHI , Jan 13, 2019 :
    My alarm did not go off even though I set 20 of them, never had this issue before and I am very light sleeper. Almost missed a med school interview!!!!

    It seems to inconsistently work now, please look into it.
     

    #1
  2. jennyhoo
    Cupcake Jan 15, 2019

    jennyhoo , Jan 15, 2019 :
    This happens to me if my phone is not plugged in to power. Oneplus6T using Alarm Clock Plus. I think it is the deep doze/power saving state. Enen though I have already turned off Advanced Optimization battery settings.
     

    #2
  3. 6TBag
    Froyo Jan 15, 2019

    6TBag , Jan 15, 2019 :
    Maybe try a different alarm app? I use Alarm Clock Xtreme and only had one issue when I forgot to turn off battery optimization. It's been working fine ever since.
     

    #3
  4. Deactivated User
    Jan 15, 2019


    #4
  5. G_Fabian_Jano_BqHI
    Cupcake Jan 16, 2019


    #5
  6. Bluecat08
    Froyo Jan 16, 2019

    Bluecat08 , Jan 16, 2019 :
    Oh dang! I have not had this issue...yet (knock on wood). I heavily depend on my phone's alarm. That would be terrible for it not to function properly.
     

    #6
  7. S1575186890711
    Cupcake Feb 13, 2020

    S1575186890711 , via OnePlus 7 Pro , Feb 13, 2020 :
    I have also experienced this while using Google's alarm clock app (not the stock one plus alarm). This tells me it might be a settings/operating system issue. my alarm volume was up all the way. OxygenOS was updated to it's most recent version. The one thing I noticed was that the battery optimization was turned on for the alarm app, so I turned it off by going through Settings>Apps & Notifications>Special App Access> Battery Optimization then select your alarm application, and finally selecting "don't optimize"

    Hopefully, that solves the problem. I'll post back here if it does.
     

    #7

  8. #8