11

All capacitive buttons not working, on-screen navbar setting disabled

  1. anjelloe Cupcake Jan 7, 2019

    anjelloe, Jan 7, 2019 :
    My capacitive buttons have stopped working, and I believe it could be a software problem. This is because the home button works ONLY for my fingerprint, but doesn't work for anything else. Backlight is working when I adjust the volume too. ADDITIONALLY, the on-screen navigation bar setting is disabled/greyed out, and I cannot toggle it on or off. PLEASE HELP as I am forced to use virtual softkeys.
    View attachment 952248
     

    #1
  2. L1509667813405 Cupcake Jan 7, 2019

    L1509667813405, Jan 7, 2019 :
    same issue here as well, had to reset the device, but it fixed after resetting the device but it re-occurred again
    Also Sim 2 isn't working
     

    #2
    anjelloe likes this.
  3. Claudius.Helmich Cupcake Jan 7, 2019

    Claudius.Helmich, Jan 7, 2019 :
    Same problem here after updating to 9.0.0 on the OP5. After some days, the capacitative back and menu buttons simply stop working. Also , the option to switch to on-screen buttons is not selectable anymore. When booting to recovery, the buttons however work properly. Also, after a factory reset , the buttons were working , but stopped again (simply disappeared) after some days. After another factory reset, I switched to on-screen, which worked till now. But this shows that the issue is certainly firmware-related. @@OnePlus please help!
     

    #3
    cadatr and anjelloe like this.
  4. I1546259119538 Cupcake Jan 7, 2019

    I1546259119538, Jan 7, 2019 :
    Same problem here. Also my phone crashes 10+ times a day. Already done 2 resets and it doesn't seem to help.
     

    #4
    anjelloe likes this.
  5. J1515124308062 Cupcake Jan 8, 2019

    J1515124308062, Jan 8, 2019 :
    I have the same problem.. it happened to me after closing the prompt for game mode for an app.. happen to me twice already.. the first time i forget how i get it back to work.. reaallly need help ...every time i want to go to home screen after opening any app.. i hav to swipe down from the notification bar and go to setting > app and others > default app > one plus launcher... this is so fustrating
     

    #5
    anjelloe likes this.
  6. J1515124308062 Cupcake Jan 8, 2019

    J1515124308062, Jan 8, 2019 :
    what is a virtual softkey.. would to try that ..
     

    #6
    anjelloe likes this.
  7. anjelloe Cupcake Jan 8, 2019

    anjelloe, Jan 8, 2019 :
    "Virtual Softkeys (no root)" is an app you can get that creates an on-screen navigation bar for you. For me, only the square button works effectively, but that's enough to keep the phone usable. I wish they'd resolve this problem soon.
     

    #7
  8. Pjuh Cupcake Jan 8, 2019

    Pjuh, Jan 8, 2019 :
    I use EasyTouch, similar app idea!
     

    #8
    anjelloe and mehartlieb like this.
  9. mehartlieb Donut Jan 8, 2019

    mehartlieb, Jan 8, 2019 :
    Same here. The problem started yesterday without me getting any new software or the like. What to do? pls help. Have to restart the phone after every single opening of an app as i can not close it anymore due to the not working softkeys.
     

    #9
    anjelloe likes this.
  10. mehartlieb Donut Jan 8, 2019

    mehartlieb, Jan 8, 2019 :
    thanks. that makes it at least work for the moment.
     

    #10
    anjelloe likes this.
  11. anjelloe Cupcake Jan 8, 2019

    anjelloe, Jan 8, 2019 :
    Lets like this thread to make the OnePlus support team notice this problem and solve it!
     

    #11
    mehartlieb and Claudius.Helmich like this.
  12. ashcunak Cupcake Jan 8, 2019

    ashcunak, Jan 8, 2019 :
    Also have this issue on a OP5, were using XDA swipe gestures but cant get to the home screen with it, just recents menu type stuff.
     

    #12
  13. jachi86 Cupcake Jan 8, 2019


    #13
  14. V1547032071443 Cupcake Jan 9, 2019

    V1547032071443, Jan 9, 2019 :
    I had the same problem, but then I did the factory reset and now they work again. I hope they won't stop working again though.
     

    #14
  15. rollercoaster23 Cupcake Jan 9, 2019

    rollercoaster23, Jan 9, 2019 :
    I am having the same issue. Started for me last night. I am using easy touch and virtual softkeys to try and keep the phone functioning. Really don't wish to do a factory reset if possible.
     

    #15
    Aliki La Bercasio and anjelloe like this.
  16. Claudius.Helmich Cupcake Jan 9, 2019

    Claudius.Helmich, Jan 9, 2019 :
    It happened to me again after factory reset - I recommend switching to on-screen buttons until this is fixed. That works for some days for me already.
     

    #16
  17. iggirice Cupcake Jan 9, 2019

    iggirice, Jan 9, 2019 :
    I will relate an experience that may be helpful for some of you.

    My problem originated from the gaming mode automatically being turned on for some games, deactivating the capacitive buttons (default condition). If you go into setup and disable all gaming mode functions before taking gaming mode off via the notification panel, all the capacitive buttons will still be not active. Restarting the phone would not help. Resetting the phone would help as some of you had tried but the gaming mode default has not changed so it might happen again.

    If that is what happened. You can try this. It worked for me.
    - go into the gaming mode setup and turn on ‘disable capacitive button’ option and add a game to the list
    - open the game, the gaming mode should kick in
    - swipe down the notification panel and disable gaming mode there

    This should get you the buttons back. To solve it long term, go back again into gaming mode setup, turn off 'disable capacitive button' and remove all the games that would automatically trigger gaming mode.
     
    Last edited: Jan 9, 2019

    #17
  18. KajackGmail Cupcake Jan 9, 2019

    KajackGmail, Jan 9, 2019 :
    Thank you for this post. This solution worked for me. I am only curious why the game I played was in game mode because I did not set this mode for the game.
     

    #18
  19. iggirice Cupcake Jan 9, 2019

    iggirice, Jan 9, 2019 :
    Seems to be random. I did not select any game to be associated with gaming mode but one of them was put in the list somehow but not others that I also play.
     

    #19
  20. shilpa_dodeja93 Cupcake Jan 10, 2019

    shilpa_dodeja93, Jan 10, 2019 :
    thank you for providing solution. It definitely worked on my phone.
     

    #20
    denniskoetsier likes this.