0
Andriod Auto doesn't work with 7 Pro, USB setting kept being reset automatically

  1. RW528
    Cupcake Aug 3, 2021

    RW528 , Aug 3, 2021 :
    Can't connect my 7 pro to Toyota Corolla hybrid 2022. Have researched online and read several forum threads, tried: change cable, reboot the phone, go to developer option to enable the USB debug, change the USB preference to File transfer etc. But still, after plug in the phone, Andriod Auto will connect for like 2 seconds then disconnect, USB setting was reset to No Data transfer. Tried to change the setting but it won't work, system automatically changed it back to No data transfer again.
    While after unplug the phone from car, USB setting will go back to File Transfer as set.
    Super frustrating!
     

    #1
  2. Overzee
    The Showcase Reviewer Aug 4, 2021

    Overzee , Aug 4, 2021 :
    Which Android Auto build is running on your phone?
     

    #2
  3. L1631613012730
    Cupcake Sep 14, 2021

    L1631613012730 , Sep 14, 2021 :
    I'm also facing a similar issue with my oneplus 7t.
    Unable to connect to my new Harrier.
    Initially thought the issue is with the car. AA working fine with my car if I connect with Pixel

    AA build version 6.8.613354-release
    I have downgraded to 6.8.613323-release. no luck
     

    #3