4
Android 10 bluetooth issue on OnePlus 6 via OnePlus 6

  1. Manish_Tonse
    Donut Dec 7, 2019

    Manish_Tonse , via OnePlus 6 , Dec 7, 2019 :
    i recently updated my OnePlus 6 to android 10, and facing bluetooth connectivity issue since. the bluetooth connects seamlessly but the audio starts stuttering, as if there's an obstruction. but there isn't any. i tried keeping both speaker and phone together, but still doesn't work. and the issue goes worse when I'm using the phone or the phone is moving. i tried connecting my 2nd phoe(iphone6) which doesn't show any issue like this. kindly help, because i use OnePlus as a primary phone
     

    #1
  2. Manish_Tonse
    Donut Dec 7, 2019


    #2
    rarog likes this.
  3. F1575841062388
    Cupcake Dec 17, 2019


    #3
  4. mubasher
    Gingerbread Jan 4, 2020

    mubasher , Jan 4, 2020 :
    i too have the same problem while using it with my car. I am listening to music and suddenly audio starts breaking but when you turn on the screen it's normal until the screen goes off again.
     

    #4
  5. juana.mendes
    Cupcake Jan 6, 2020


    #5
  6. roger.estruch
    Cupcake Jan 8, 2020

    roger.estruch , Jan 8, 2020 :
    I have the same problem. The last updated is really horrible, a lot of problems. Wifi connection and bluetooth connexion. Waiting for a solution
     

    #6
  7. Caomhin
    KitKat Jan 8, 2020

    Caomhin , via OnePlus 6T , Jan 8, 2020 :
    Open Settings, System, Reset Options, Reset WiFi. This will reset both WiFi and Bluetooth.
     

    #7
  8. Ed Jones
    Froyo Jan 9, 2020

    Ed Jones , Jan 9, 2020 :
    I have done this so many times. It is a temporary fix and within 1-2 days my WIFI and Bluetooth go back to acting up.
    There needs to be a permanent fix instead of bandaids that need to be redone every day or so.
     

    #8
  9. Caomhin
    KitKat Jan 9, 2020

    Caomhin , via OnePlus 6T , Jan 9, 2020 :
    The only other option is a full factory reset.

    Do a full Erase/Delete Data button, factory reset. This will restore you to a fresh installation of 10.3.0. So you will need to backup your phone.

    Go to Settings, System, Reset Options, Erase All Data, click on the Delete All Data button, make sure you have backed up your phone first.


    View attachment 1228949
     

    #9
  10. stkelly
    Cupcake Jan 9, 2020

    stkelly , Jan 9, 2020 :
    Full factory reset did not work for my wife's OnePlus 6. It worked for 1 day, started skipping by her drive home the next day. I did a full factory reset including all data. OnePlus needs to fix this issue! Bluetooth worked perfectly fine before the Android 10 update.

    My OnePlus 6 occasionally skips after the 10 update but not nearly as severe as my wife's phone. It's the worst with our 2016 Ford Expedition. All other phones and prior to the Android 10 update there were 0 issues with bluetooth and the Expedition.
     

    #10
  11. Ed Jones
    Froyo Jan 10, 2020

    Ed Jones , Jan 10, 2020 :
    I have cleared the cache and have done resets way too many times. It is apparent that OnePlus has no clue as to how to actually fix the problems. We are only being given bandaids that do or do not work. When they work they are for a short period of time.
    This is clearly an indication of a company that puts features ahead of functionality.
     

    #11
    Thiago Martini likes this.
  12. Thiago Martini
    Cupcake Jan 10, 2020

    Thiago Martini , Jan 10, 2020 :
    Good to know that factory reset doesn't seem to fix the problem, i was going to do that here.

    Will try some way to roll back to oxygen 9... Never had such a problem with previous OP devices, and my current OP6 may be very well the last OP phone i'm going to own, due to the horrible treatment the company is giving to this update.
     

    #12
  13. Kytharsis
    Marshmallow Jan 10, 2020

    Kytharsis , Jan 10, 2020 :
    It ever occur to you that this is happening on all A10 builds, all 3 of them? :^)
     

    #13
    Caomhin likes this.
  14. Thiago Martini
    Cupcake Jan 10, 2020

    Thiago Martini , Jan 10, 2020 :
    Only tried 10.3.0... not only BT issues, but there are reports of several other problems on OP6/6T devices after the upgrate to OOS/Android 10. Apparently, even delaying the update, Oneplus could not solve all the issues on OOS 10 regarding these devices.

    I'm performing a roll back to OOS/Android 9 right now, and will wait until OP releases a DECENT and BUG-FREE update for the OOS10 to start using it on my OP6.
     

    #14
  15. Caomhin
    KitKat Jan 11, 2020

    Caomhin , via OnePlus 6T , Jan 11, 2020 :


    Thiago Martini

    Only tried 10.3.0... not only BT issues, but there are reports of several other problems on OP6/6T devices after the upgrate to OOS/Android 10. Apparently, even delaying the update, Oneplus could not solve all the issues on OOS 10 regarding these devices.

    I'm performing a roll back to OOS/Android 9 right now, and will wait until OP releases a DECENT and BUG-FREE update for the OOS10 to start using it on my OP6.​


    So long as the reset you do is a proper full Data Delete, then it should work fine.

    If you do a half arsed delete from the other 2 options, other than pressing the middle button Delete Data then it's never gonna fix issues.
     

    #15
  16. Y1579640604129
    Cupcake Jan 21, 2020

    Y1579640604129 , Jan 21, 2020 :
    Has anyone had success getting their bluetooth fully working again? @Thiago Martini did the rollback to 9 fix it?

    It's disappointing that the conclusion is that we have to do a full reset with data deletion just to try to get a smooth bluetooth experience :(

    This is happening to me as well on my 6T, it's super frustrating. I've checked it with multiple bluetooth headsets and get the same stuttering in and out on Skullcandy Method, Xiaomi buds, Anker buds, and Bose QC.

    I have to pick my phone up and wriggle it around to get the audio to resume. I didn't have any problems before, and it started right after the update.
     

    #16
  17. Y1579640604129
    Cupcake Jan 21, 2020

    Y1579640604129 , Jan 21, 2020 :

    Did the full data delete work for you, @Caomhin ? Is your bluetooth back to working smoothly ?
     

    #17
  18. Caomhin
    KitKat Jan 21, 2020

    Caomhin , via OnePlus 6T , Jan 21, 2020 :
    Yes, but the reason I reset the phone, was because I messed up in developer options in Settings.

    I did have an issue connecting once, but turns out the Bluetooth in the car failed and a visit to the garage and a software reset for Bluetooth in the car fixed that. Nothing to do with the phone.

    I have been through all of the Android 9 stable and Beta variants and up to now all of the stable and up to Beta 3, very few issues on any of them

    However I only connect to my soundbar, car radio for calls, I don't use headphones. But have no issues connecting.
     

    #18
  19. bandit8623
    Cupcake Jan 22, 2020

    bandit8623 , Jan 22, 2020 :
    i am having problems as well. all my Bluetooth devices work for the most part on the beta,but my 2012 nissan maxima.

    i have reset and removed and done everything. i can get it to stream music sometimes, but on startup it will not connect again. even whenj it is streaming when in Bluetooth setting its constantly saying connecting... connected. .. connecting.. connected. every 10 seconds. also my Bluetooth headset will not auto re- pair up without me saying pair. i have reset Bluetooth and wifi setting 3 times and no go..

    on android 9 no problems. all worked flawlessly.

    i am going to do a factory reset in the next 30 min to see if it fixes.

    what a pain since i use google 2 authentication . have to turn them all off before i reset...

    stay tuned

    Factory did not fix. Latest update not working. Sent in logs
     
    Last edited: Feb 6, 2020

    #19
  20. bandit8623
    Cupcake Jan 22, 2020

    bandit8623 , Jan 22, 2020 :
    android 10 broken.. i factory defaulted to base beta 4. left nothing behind and my Bluetooth will not reconnect to my car. even when i do get it connected at first the bluetooth screen goes from active to connecting constantly.... restart car will not reconnect..

    ill need to go back to 9..

    the other prob with this build is my sound on internal speakers and on Bluetooth is constantly fading in and out.
     

    #20