8
Android 10 wifi failed to connect - fix

  1. StarGrapper
    Eclair Nov 3, 2019

    StarGrapper , Nov 3, 2019 :
    Hi gents,
    I had the issue where some routers are not working with Android 10 update and can't connect to wifi.

    Thanks to (mischa1981) he found a solution and I thought to share with everyone.

    I tried resetting everything. my phone, my router and several times. nothing worked except one simple solution.

    - Go to your router settings
    - Change password type from WPA2 to WPA/WPA2.
    - Save


    Before you look at your phone ( if you have connection already saved) you'll find it connected.

    I hope it helps everyone facing this problem until OP update with a fix.

    Cheers,
     

    #1
    alimajeed, v1adimir, geaf35 and 5 others like this.
  2. paedz718
    Cupcake Nov 3, 2019

    paedz718 , Nov 3, 2019 :
    Thank you!! was racking my brain. This fix on my router worked. Can now connect to my 5G wifi network. All other devices in my apt. had no issue.
     

    #2
  3. G_Frederik_Sanders_sBfZ
    Cupcake Nov 5, 2019


    #3
  4. msambit
    Cupcake Dec 25, 2019


    #4
  5. majobu
    Eclair Jan 1, 2020

    majobu , Jan 1, 2020 :
    Will there be a OnePlus fix soon? I need this working, because of I can't change the correspondig option in my car from BMW. OP6 always tries to reconnect to the Wifi from the car. I need the connection for the apps and remote updates for the car. So please help, OnePlus.
    Regards,
    Marcus
     

    #5
    Andresih likes this.
  6. chiragpatidar7
    Cupcake Jan 4, 2020

    chiragpatidar7 , Jan 4, 2020 :
    from where to change router settings???
    I have my hostel wifi not working just after the Android 10 update..... it is showing ip address failure...I even tried manually entering valid ip address (in advanced settings) also tried every modification possible but still of no use. ur suggestion seems valid but I don't know how to do it...can u plz elaborate on detail....cuz I don't have to enter password for my hostel wifi...I got my Mac address registered to administer and then it automatically connects recognizing my Mac address.....plz help...urgent help needed....
     

    #6
    ToRusso00 likes this.
  7. R1569260948063
    Cupcake Jan 8, 2020

    R1569260948063 , Jan 8, 2020 :
    Hi guys, I have a OnePlus6T AND I have problems with internet sharing after upgrade to android 10. I hace read the post of putting security ti WPA2-personal, bit ir dies not work un this case. The Nobile only has WPA2-personal AND mine, there are no More. Otherwise StarGrapper datos yo go go the configuración of the routers. Where is this opción un the OnePlus6T? Greetings to allá, I hope you can help
     

    #7
  8. geaf35
    Cupcake Jan 20, 2020

    geaf35 , Jan 20, 2020 :
    Hi mate,
    Google the wifi router name you have and based on which you'll get the settings configuration in detail. I too tried the same & it worked for me. Coz depending on the router name the ip address changes along with password too.
     

    #8
  9. geaf35
    Cupcake Jan 20, 2020

    geaf35 , Jan 20, 2020 :
    If you use wifi, the settings has to be changed in the wifi router admin page in any browser and not on your mobile settings. Google it to get proper ip address of your router.
     

    #9
  10. v1adimir
    Eclair Feb 3, 2020

    v1adimir , Feb 3, 2020 :
    Right, just for example, if it helps, my cable operator has their router address set to (a local IP):

    Code:
    192.168.0.1
    (Chances are, yours may be different.)
     

    #10
    geaf35 likes this.
  11. I1590714407658
    Cupcake May 29, 2020

    I1590714407658 , May 29, 2020 :
    Honestly most of these issues are solved by doing the "Quick Configuration" that comes with most routers, most specifically with TPLink ones. What's the brand/model of your router? It'd be faster to tell you how to do it, having that information.

    Normally you'd want to set it up so that the Mac Adress isn't necessarily cloned, since that might work with computers, but cause issues with cellphones.
     

    #11
  12. Amarnath_Acharya
    Cupcake Sep 10, 2020


    #12
  13. Praty_28
    KitKat Sep 10, 2020

    Praty_28 , Sep 10, 2020 :
    Wifi drop issue is probably not related to your router, I have this issue since 3 years and it hasn't been fixed till now on my 3T and I have tried several different routers
     

    #13
  14. Amarnath_Acharya
    Cupcake Sep 11, 2020

    Amarnath_Acharya , via OnePlus 8 Pro , Sep 11, 2020 :


    I1590714407658

    Honestly most of these issues are solved by doing the "Quick Configuration" that comes with most routers, most specifically with TPLink ones. What's the brand/model of your router? It'd be faster to tell you how to do it, having that information.

    Normally you'd want to set it up so that the Mac Adress isn't necessarily cloned, since that might work with computers, but cause issues with cellphones.​


    with the below pic can u see why am I getting wifi disconnects regularly? View attachment 1429433
     

    #14
  15. U1601042260213
    Cupcake Sep 25, 2020


    #15
  16. W1601288673869
    Cupcake Sep 28, 2020

    Last edited: Sep 29, 2020

    #16