51
[Answered] Android Auto does not work

Thread Status:
Not open for further replies.
  1. shravanm18
    Froyo Dec 15, 2016

    shravanm18 , Dec 15, 2016 :
    Car: VW 2016 GTI
    - BT is pair with car
    - Connect phone to car USB (tried this with Dash cable, OP3 cable, OP2 cable, and 3rd party cable)
    Actual Behavior:
    - Behaviors vary but most times i get the "USB device not supported error"
    - When I connect the cable sometimes the car will try to connect directly to MirrorLink inspite of setting Android Auto as my default
    - Sometimes the Android Auto icon will appear in notification tray but it won't start on my car entertainment system or my phone
     

    #1
  2. Chino86
    Eclair Dec 25, 2016

    Chino86 , Dec 25, 2016 :
    I have this bug also with my new OnePlus 3T. Exact same behaviour in my VW Polo 2015. Please fix!
     

    #2
    jegomosc and Ffvorax like this.
  3. Diarte
    Cupcake Dec 26, 2016


    #3
    jegomosc and Ffvorax like this.
  4. Zsolt Dargó
    Donut Dec 27, 2016

    Zsolt Dargó , Dec 27, 2016 :
    Hi there. If I was lucky and Android Auto started, after a few minutes the phone disconnect. I tried with original cabel, different USB modes on phone.
     

    #4
    querolus and jegomosc like this.
  5. rfleischhauer
    Cupcake Dec 28, 2016

    rfleischhauer , Dec 28, 2016 :
    Same Issue here with my Seat Leon 2016.

    Tried the original cable and a third-party one. The USB setting was set to MTP
     

    #5
    jegomosc likes this.
  6. shravanm18
    Froyo Dec 29, 2016

    shravanm18 , Dec 29, 2016 :
    Please mention the car that you are using. Maybe it is a bug in the type in-car entertainment system people are using.
     

    #6
  7. inffy
    KitKat Dec 29, 2016

    inffy , Dec 29, 2016 :
    Didn't work with the factory installed version on my Skoda Octavia year 2016 model but has worked after the 3.2.8 OTA.
     

    #7
  8. Zsolt Dargó
    Donut Dec 30, 2016

    Zsolt Dargó , Dec 30, 2016 :
    WV Passat 2015.

    The Android Auto works without any problem with my Samsung, Alcatel (micro usb) and Huawei (USB type c) devices. Only my Oneplus 3T is not working.
     

    #8
  9. Yaweestoater
    Donut Dec 31, 2016

    Yaweestoater , Dec 31, 2016 :
    When my 3T is plugged in initially, my 2016 Seat Leon (tech pack) says USB DEVICE NOT RECOGNISED, but then boots up android auto anyway. Android Auto will then work fine for approx 10-15 mins before it auto disconnects and I get a red Android Auto error 12 screen on my phone. Car software worked fine with my previous phone. I notice that if it is connected and I am using the phone for a call it will generally stay connected longer and then disconnect shortly after my call ends. Is anyone at Oneplus working on this or is it an Android Auto issue? Thanks.
     

    #9
  10. Chino86
    Eclair Dec 31, 2016

    Chino86 , Dec 31, 2016 :
    Just a follow up after the 4.0 update on my 3T. Sadly still doesn't work... really gutting. I did try it on my flatmate's new Seat Ibiza though and surprisingly it did so I'm guessing it's my 2015 VW that can't speak properly to the phone... possibly USB drivers. Guess I'll try speaking to the dealership but I'm not holding out hope sadly...
     

    #10
    uitgeslapen1 likes this.
  11. Slinkwyde
    Cupcake Jan 1, 2017

    Slinkwyde , Jan 1, 2017 :
    I have a 3T on order, but it hasn't shipped yet.

    So far, everyone that's posted about having problems with AA on the 3T seems to be talking about issues with connecting their 3T to their car's infotainment system over USB. In November, Google added the ability for Android Auto to also work directly on the phone screen itself (without needing a compatible car or aftermarket head unit). Do people also have problems with that on the 3T?
     

    #11
    Ffvorax likes this.
  12. Chino86
    Eclair Jan 1, 2017

    Chino86 , Jan 1, 2017 :
    Hey Slinkwyde. Can confirm that AA works on the phone screen itself no problem! This bug is indeed specifically to get the Car system and Phone communicating correctly over USB.
     

    #12
    Ffvorax and Slinkwyde like this.
  13. G_Steve_Turner_GYMh
    Cupcake Jan 1, 2017

    G_Steve_Turner_GYMh , Jan 1, 2017 :
    Hi. Android Auto works for me on my 3T and 2016 Vauxhall Corsa, however the connection drops after about 45 mins. Now I obviously can't to much looking into what happens next when driving, but even unplugging the USB cable and plugging it again then results in an error where the connection is made again, however drops within seconds. Seems to be absolutely fine the next time I use it though, when the whole situation starts again.

    Fine for short drives, but pretty annoying for any longer driving trips!
     

    #13
  14. inffy
    KitKat Jan 2, 2017

    inffy , Jan 2, 2017 :
    I actually had a disconnect today with android auto after few minutes of listening of Spotify. Happened about three times in a row. My car is Skoda Octavia my2016

    Can you test something. Go to settings - developer settings and find a "Select USB Configuration" -> change it to MIDI (the settings wont change first). Back out of developer settings and go back and check if the setting is now having a "MIDI" (was charging).

    After that test AA again. I just did that and after that again no problems with AA
     

    #14
  15. sdl_blue
    Cupcake Jan 3, 2017

    sdl_blue , Jan 3, 2017 :
    I'm with the same issue. After connecting the 3T to the car (Skoda Superb 2016) I get the "USB device not supported" error.
    The described workaround never really worked for me (OOS 3.5.3 up to 4.0). Even though I can use AA for about a Minute, sometimes even less, the infotainment just replies with the error.
     

    #15
  16. shravanm18
    Froyo Jan 4, 2017


    #16
    Ffvorax likes this.
  17. shravanm18
    Froyo Jan 4, 2017

    shravanm18 , Jan 4, 2017 :
    Tried the workaround. No luck.
     

    #17
  18. G_Olly_Sullivan_Iayb
    Cupcake Jan 4, 2017

    G_Olly_Sullivan_Iayb , Jan 4, 2017 :
    Just replaced my ageing Nexus 5 with a 3T (OOS 3.5.4). After seeing this thread I did a quick check in my 2016 VW GTI and it worked fine for the 10 mins I had to test - connected without issue and was able to use Google Music and voice control to do some navigation. Will do further tests when I get a chance.

    Looking at this thread, might this be a VW Group issue (i.e VW, Seat, Skoda)?

    For comparison with other VW owners, and in case it's a software version issue, my car's system info is:
    Device part number: 3Q0035874B
    Hardware: 840
    Software: 0743
     

    #18
  19. kmajewski
    Gingerbread Jan 5, 2017

    kmajewski , Jan 5, 2017 :
    I'm facing the same issue on OP3T. OOS 4.0. Opel Astra. I'm considering returning this device.
     

    #19
  20. kmajewski
    Gingerbread Jan 5, 2017

    kmajewski , Jan 5, 2017 :
    I got AA to connect, but it randomly disconnects after few minutes. I noticed that the signal indicator (in car display) for most of a time doesn't show connection type (LTE/H etc.)
    Opel Astra MY2017
     

    #20
    mani jang shar and katy.barraud like this.