4
Android Auto isn't working via OnePlus 7 Pro

  1. Napat.W
    Donut Jun 26, 2020

    Napat.W , via OnePlus 7 Pro , Jun 26, 2020 :
    Android Auto does not appear after plugging the USB cable into the Head Unit. It flashes a few times to connect to car and then goes off. Try with other brands of phones. Yes, normally except OnePlus.
     

    #1
  2. LarsDekkers
    Gingerbread Jun 26, 2020


    #2
  3. Napat.W
    Donut Jun 27, 2020


    #3
  4. LarsDekkers
    Gingerbread Jun 27, 2020

    LarsDekkers , Jun 27, 2020 :
    And since when did it stop working? Or has it never worked? And if so, do you have the latest updates installed on the phone?
     

    #4
  5. dwong
    Ice Cream Sandwich Jun 27, 2020

    dwong , via OnePlus 8 Pro , Jun 27, 2020 :
    I'm facing the same issue also on a 8pro, Been working previously, then stopped working since few days ago, AA flash when plugged in, then gone after that, but HU working normal for my other phones, a note 9 n p20 pro, all on Android 10
     

    #5
    F1591876089582 likes this.
  6. lovepiggy
    Cupcake Jun 27, 2020

    lovepiggy , via OnePlus 8 Pro , Jun 27, 2020 :
    I plug it in , it starts and give you that sence of "wohoo it works" then after 2 or 3 mins the touch screen on the radio just stops working....... So you have to unplug it and plug it back in ... My galaxy s8 ultra works fine but not my oneplus 8 pro, come on oneplus whats going on, surely hands free android auto and having to mess about with a phone while driving defeats the object.
    think i might back this and go back to my SAMSUNG
     

    #6
  7. W1558561931672
    Cupcake Jun 28, 2020

    W1558561931672 , Jun 28, 2020 :
    I just purchased a new vehicle with Android Auto. After a complete failure, lots of research I found that my old USB cable was not transferring data. I used the new USB cable that came with the vehicle and I was so excited - AA started up, asked me all the intro questions about permissions, etc and I thought I was done. After the initialization AA on the phone connects to the head unit for about 2 seconds and then cuts off on the head unit. The phone says it is connected but it is not. I have cleared cache and data, removed the vehicle from the AA app, deleted and re-installed the app, power cycled the phone and it behaves the same everytime. I tried USB debug in the developer options but the resulting file was huge and was of no help. This is so frustrating to have an otherwise great phone but not having Android Auto working. By the way -the cable that came with the 7 pro acts just the same as the vehicle USB - initial connection but then quits. I could guess all day - I'm thinking some permission problem but that is just a guess. I'm out of ideas. Any suggestions other than a factory reset on the phone? I'll do without AA before going thru that ordeal.
     

    #7
    Napat.W likes this.
  8. Napat.W
    Donut Jun 28, 2020

    Napat.W , via OnePlus 7 Pro , Jun 28, 2020 :
    Before it's was working fine, problem occurs after updated to 10.3.3
     

    #8
  9. Napat.W
    Donut Jun 28, 2020

    Napat.W , via OnePlus 7 Pro , Jun 28, 2020 :
    Same as me trying with Samsung A71 it's working flawlessly but not with the OnePlus.
     

    #9
    lovepiggy likes this.
  10. lovepiggy
    Cupcake Jun 28, 2020


    #10
  11. apis10
    Eclair Jun 29, 2020


    #11
    micber likes this.
  12. apis10
    Eclair Jun 29, 2020


    #12
    micber likes this.
  13. Gebard
    Cupcake Jun 29, 2020


    #13
  14. W1558561931672
    Cupcake Jun 29, 2020

    W1558561931672 , Jun 29, 2020 :
    My Oneplus 7 Pro is an unlocked phone with Verizon service. I stopped by a Verizon store this afternoon and got lucky and worked with a very nice young Verizon representative. His Samsung S10E worked perfectly with my Toyota Tundra. My 7 Pro continues to fail. He even went and pulled the Verizon OnePlus 8-5g off the demo wall and we tried it. It failed the same as my 7 Pro. Now I love my 7 pro - it is the best cell phone I have ever owned, BUT I want Android Auto to work. The problem is not with my Tundra. It is not with my USB cable. OnePlus - you guys need to fix the problem. Obviously lots of people are having the issue. You need a test subject? Contact me, I am retired and have the time. PLEASE get this problem fixed!!!!
     

    #14
    HazeTaze and Napat.W like this.
  15. HazeTaze
    Cupcake Jun 30, 2020

    HazeTaze , via OnePlus 7T Pro , Jun 30, 2020 :
    I also have been getting the same problem lately. It seems like an AA update must have broke something with oneplus.

    For The 2min working then no touch. Try dissable screensaver mode in oneplus display setting and it should fix The problem.
     

    #15
  16. apis10
    Eclair Jun 30, 2020

    apis10 , via OnePlus 7 Pro , Jun 30, 2020 :
    I have made contact with OP customer support. The issue has been escalated now. Please more of you guys try to get in contact with them to push for a solution
     

    #16
  17. JNiemi
    Gingerbread Jun 30, 2020

    JNiemi , Jun 30, 2020 :
    I did get this message "Check if the mobile device is released" and nothing happened on phone or car screen, after update 10.0.6.GM21BA
    I got it working after 10.0.6 EU update, all I did was update AA from APKMIRROR with version 5.4.502264, install -> boot -> test and it´s working.

    Phone is OnePlus 7 Pro
     

    #17
  18. lovepiggy
    Cupcake Jun 30, 2020


    #18
  19. W1558561931672
    Cupcake Jul 1, 2020

    W1558561931672 , Jul 1, 2020 :
    I have had version 5.4.502264 installed all along and it continues to fail. I also contacted OP customer support today - twice. The first idea to fix was of no help. Finally they moved me to secondary support with a promise that within the hour I would be contacted, they would monitor my phone while we tested and debugged. Woohoo was I excited. Nine hours later and I haven't heard a thing from OP secondary support. I'm now very angry and will shortly have a used OP 7 Pro for sale. Sigh.....
     

    #19
    lovepiggy likes this.
  20. apis10
    Eclair Jul 1, 2020

    apis10 , Jul 1, 2020 :
    So I managed to uninstall update on play store.
    I had to dig really hard to find the app on play store since it's now more of a system app rather than standalone.
    Then I downloaded the previous version from apkmirror 5.3.501634
    And it worked!
    🥵 At some point I even thought it was beach sand that caused it!
     

    #20