14
Android Auto isn't working

  1. anandarup.roy
    Cupcake Aug 30, 2020

    anandarup.roy , via OnePlus Nord , Aug 30, 2020 :
    I have also faced similar issues being discussed here.

    I have a Sony XAV AX-5000 in my car and my OnePlus 3T's Android Auto worked fine with the infotainment system in the car.

    I plugged in the new OnePlus Nord into the Sony XAV AX-5000 and Android Auto started auto configuration in the phone; but after a few steps (on the Google Assistant screen), the App kept crashing on the phone. Tried it multiple times with the same result.

    Tried to clear cache, uninstalled and re-installed, but the result is the same. Also did a factory reset of the infotainment system and tried with 2 separate USB cables. Seems very similar to the issue reported in this thread.
     

    #41
    W1597397961210 likes this.
  2. Mikey_1273
    Gingerbread Aug 30, 2020

    Mikey_1273 , via OnePlus 7 Pro , Aug 30, 2020 :
    The issue here is I keep getting a notification that and Android auto update is available and to connect the vehicle cable. I connect my 7pro to my 2020 Tacoma and I can't find where to go to install it. It's been popping up with that notification for two days now. I've plugged in every time I get in the truck and it doesn't seem to install on its own.
    Google maps is working with Android auto and that's all I use on it so far. I only had the truck a month.
     

    #42
  3. AndreasY
    Donut Oct 16, 2020

    AndreasY , Oct 16, 2020 :
    The answer is simple but disappointing. Oneplus is all about cheap high-spec hardware but when it comes to hw quality it's nothing more than other cheap imitation Chinese products. Yes, it's a fact that AA has never worked properly on any version. It may work for a while but only once and then you need restart, car restart, patience, etc. Yes it worked fine on previous samsung phones. The same apllies to its nfc chip where bank apps don't work when they worked on previous phones. The same apllies to many other aspects of OP and that's the reason i consider it a failure
     

    #43
  4. Artemus
    Moderator, Community Hero 2020 Moderator Oct 16, 2020

    Artemus , Oct 16, 2020 :
    The answer is even simpler than that: Android Auto flat-out sucks.
     

    #44
  5. A1607817608634
    Cupcake Dec 13, 2020


    #45
  6. Kaustubh8121
    Cupcake Dec 13, 2020


    #46
  7. E1558912633684
    Gingerbread Dec 13, 2020

    E1558912633684 , via OnePlus 7 Pro , Dec 13, 2020 :
    Strange.. AA always worked for me, never encountered a problem.

    Easy fixes that sometimes help when AA is not working:
    - Try a different cable. I use an original OP-cable;
    - Turn on USB-debugging on the phone.
     

    #47
  8. A1607817608634
    Cupcake Dec 13, 2020

    A1607817608634 , Dec 13, 2020 :
    Tried them both and unfortunately they didn't work
    It feels like a software issue as it tries to open android auto and it looks like it immediately crashes
    On what version of google play services are you on? I read somewhere that it may be related
     

    #48
  9. O. Priya
    Ice Cream Sandwich Dec 13, 2020


    #49
  10. HUNTERPRINCE
    Eclair Dec 14, 2020


    #50
  11. E1558912633684
    Gingerbread Dec 15, 2020

    E1558912633684 , via OnePlus 7 Pro , Dec 15, 2020 :
    And there isn't an update for your car? I had to update the system of the car to get AA working when I just bought my car.
    Google play services: I'm on 20.47.13.
     

    #51
  12. A1607817608634
    Cupcake Dec 17, 2020

    A1607817608634 , Dec 17, 2020 :
    Latest version, all other phones I checked do work on this system
    I have some logs from USB debugging and force logging on AA
    Maybe someone could get a better idea on what's wrong
    Code:
    12-16 16:53:08.399 10422 12483 16046 D GH.ConnBroadcast: ConnectivityStageReached: stage=Optional.of(2), at 215986
    12-16 16:53:08.399 10422 12483 18669 D GH.ConnLoggerV2: Session b622c0ec-8efc-4d87-b449-5c73dff4a5cd, event 27, detail 2, FIRST_ACTIVITY_STATE, at 215986
    12-16 16:53:08.399 10422 12483 18669 D GH.ConnLoggerV2: Event type 1008 car connected false bluetooth connected false and rssi 0 delay 10 ms
    12-16 16:53:08.404 10422 12483 18669 D GH.TelemetryManager: Logged 1 Clearcut events. Failed: 0. Skipped: 0.
    12-16 16:53:08.404 10422 12483 18669 D GH.Telemetry: Logged 1 events.
    12-16 16:53:08.488  1000   858  2956 E sensors-hal: ssc_conn_event_cb:490, event[0] msg_id=776, ts=4233377792
    12-16 16:53:08.488  1000   858  2956 E sensors-hal: handle_sns_client_event:65, device_orient_event: ts=216068342267, type=0
    12-16 16:53:08.534  root   900  3664 E ANDR-PERF-LM: VmRssMeter:: start() 298: Could not find pid, can not collect vmrss data
    12-16 16:53:08.535  root   900  3665 E ANDR-PERF-LM: VmRssMeter:: start() 298: Could not find pid, can not collect vmrss data
    12-16 16:53:08.535  root   900  3665 E ANDR-PERF-LM: AdaptiveLaunch: writeToDataBase() 63: Meter aborted or could not get meter data for this run
    12-16 16:53:08.641  1000   858  2956 E sensors-hal: ssc_conn_event_cb:490, event[0] msg_id=776, ts=4236496504
    12-16 16:53:08.641  1000   858  2956 E sensors-hal: handle_sns_client_event:65, device_orient_event: ts=216230775184, type=4
    12-16 16:53:08.950 shell 18699 18701 I adbd    : USB event: FUNCTIONFS_SUSPEND
    12-16 16:53:08.956 shell 18699 18702 I adbd    : UsbFfs: connection terminated: read 0 failed with error Cannot send after transport endpoint shutdown
    12-16 16:53:08.956 shell 18699 18699 I adbd    : UsbFfs: already offline
    12-16 16:53:08.956 shell 18699 18699 I adbd    : destroying transport UsbFfs
    12-16 16:53:08.956 shell 18699 18699 I adbd    : UsbFfsConnection being destroyed
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL: IO exception, dataReceived=true
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL: java.io.IOException: read failed: EIO (I/O error)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.IoBridge.read(IoBridge.java:523)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at java.io.FileInputStream.read(FileInputStream.java:313)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at lbr.run(SourceFile:8)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL: Caused by: android.system.ErrnoException: read failed: EIO (I/O error)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.Linux.readBytes(Native Method)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.Linux.read(Linux.java:190)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.ForwardingOs.read(ForwardingOs.java:177)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.BlockGuardOs.read(BlockGuardOs.java:303)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.ForwardingOs.read(ForwardingOs.java:177)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     at libcore.io.IoBridge.read(IoBridge.java:513)
    12-16 16:53:08.956 10422  7779 18723 W CAR.GAL.GAL:     ... 2 more
    12-16 16:53:08.957 10422  7779  7779 W GH.CarConnSession: Critical protocol error 3 (52): io error
    12-16 16:53:08.957 10017 17657 17719 W CAR.STARTUP: Protocol error 3 (52): io error [CONTEXT service_id=13 ]
    12-16 16:53:08.957  1000   862  2080 E [email protected]: uevent received SUBSYSTEM=dual_role_usb
    12-16 16:53:08.957  1000   862  2080 I [email protected]: otg_default
    12-16 16:53:08.957  1000  1500  2007 V UsbDeviceManager: USB UEVENT: {SUBSYSTEM=android_usb, SEQNUM=8159, ACTION=change, USB_STATE=DISCONNECTED, DEVPATH=/devices/virtual/android_usb/android0}
    12-16 16:53:08.957  1000   862  2080 I [email protected]: canChangeMode: 1 canChagedata: 0 canChangePower:0
    12-16 16:53:08.957 10422  7779  7779 I GH.CarConnSession: Tearing down
    12-16 16:53:08.958 10017 17657 18715 E CAR.SETUP.SERVICE: ProjectionErrorCode = 3, ProjectionErrorDetail = 52, io error [CONTEXT service_id=13 ]
    12-16 16:53:08.958 shell 18699 18701 E adbd    : failed to send interruption signal to worker: No such process
    12-16 16:53:08.959 10422  7779  7779 W CAR.SERVICE: Critical error 3 detail: 52 msg: io error
    12-16 16:53:08.959 10422  7779 12518 I GH.CarConnSessMgr: Revoking active session
    12-16 16:53:08.960  1000  1500  9401 D UsbPortManager: is_vbus_connected false
    12-16 16:53:08.960  1000  1500  9401 D UsbPortManager: Start to listen usb event, vbus_connected = false
    12-16 16:53:08.960 10017 17657 18715 I CAR.SETUP.SERVICE: tearDown [CONTEXT service_id=13 ]
    12-16 16:53:08.960  1000  1500  9401 I UsbPortManager: ClientCallback V1_0: otg_default
    12-16 16:53:08.960  1000  1500  1527 I UsbPortManager: USB port changed: port=UsbPort{id=otg_default, supportedModes=dualsupportedContaminantProtectionModes=0supportsEnableContaminantPresenceProtection=truesupportsEnableContaminantPresenceDetection=true, status=UsbPortStatus{connected=false, currentMode=none, currentPowerRole=no-power, currentDataRole=no-data, supportedRoleCombinations=[no-power:no-data], contaminantDetectionStatus=2, contaminantProtectionStatus=0}, canChangeMode=true, canChangePowerRole=false, canChangeDataRole=false, connectedAtMillis=0, lastConnectDurationMillis=8752
    12-16 16:53:08.960  1000  1500  1500 I UsbDeviceManager: updateHostState UsbPort{id=otg_default, supportedModes=dualsupportedContaminantProtectionModes=0supportsEnableContaminantPresenceProtection=truesupportsEnableContaminantPresenceDetection=true status=UsbPortStatus{connected=false, currentMode=none, currentPowerRole=no-power, currentDataRole=no-data, supportedRoleCombinations=[no-power:no-data], contaminantDetectionStatus=2, contaminantProtectionStatus=0}
    12-16 16:53:08.964 10017 17657 18715 I CAR.STARTUP: Tearing down car connection [CONTEXT service_id=13 ]
    12-16 16:53:08.965 10422  7779  7861 I GH.CAR  : Stopping session: -2737644853122593048
    12-16 16:53:08.965 10422  7779 12518 I GH.CarConnSessMgr: Teardown called for session -2737644853122593048, current session is null
    12-16 16:53:08.966  1000   914  2226 I /vendor/bin/hw/[email protected]: unbindService is called for service : com.google.android.projection.gearhead/com.google.android.apps.auto.carservice.service.impl.GearheadCarStartupService and for client com.google.android.gms:car
    12-16 16:53:08.966  1000   914  2226 I /vendor/bin/hw/[email protected]: size of service connections for service: com.google.android.projection.gearhead/com.google.android.apps.auto.carservice.service.impl.GearheadCarStartupServiceafter removal is 2
    12-16 16:53:08.966  1000   914  2226 I /vendor/bin/hw/[email protected]: size of client connections for client: com.google.android.gms:carafter removal is 1
    12-16 16:53:08.967 10422 12483 16046 D GH.ConnBroadcast: CarSetupService: state=SET_STATE_NOT_CONNECTED, at 216560
    12-16 16:53:08.967 10422 12483 18669 D GH.ConnLoggerV2: Session b622c0ec-8efc-4d87-b449-5c73dff4a5cd, event 28, detail null, CAR_SETUP_SERVICE_SET_STATE_NOT_CONNECTED, at 216560
    12-16 16:53:08.968 10422 12483 18669 D GH.ConnLoggerV2: Event type 3103 car connected false bluetooth connected false and rssi 0 delay 4 ms
    12-16 16:53:08.975  1000   914  2226 I /vendor/bin/hw/[email protected]: destroyService is called for service : com.google.android.gms/.carsetup.CarSetupService
    12-16 16:53:08.976 10046  4342  4342 D NotificationListener: onNotificationRemoved# hash: 140936346
    12-16 16:53:08.976 10046  4342  4342 D NotificationListener: onNotificationRemoved# sbn: 85099586, package = com.google.android.gms
    12-16 16:53:08.979 10422 12483 18669 D GH.TelemetryManager: Logged 1 Clearcut events. Failed: 0. Skipped: 0.
    12-16 16:53:08.979 10422 12483 18669 D GH.Telemetry: Logged 1 events.
    12-16 16:53:08.981 10017 17657 17657 I CAR.SERVICE: Port status changed for UsbPort{id=otg_default, supportedModes=dualsupportedContaminantProtectionModes=0supportsEnableContaminantPresenceProtection=truesupportsEnableContaminantPresenceDetection=true: UsbPortStatus{connected=false, currentDataRole=0, currentPowerRole=0, supportedRoleCombinations=1, currentMode=0} [CONTEXT service_id=13 ]
    12-16 16:53:08.981 10017 17657 17657 I CAR.SETUP.SERVICE: tearDown [CONTEXT service_id=13 ]
    Seems as if the USB disconnects for some reason, and it's not the cable or the port as the connection is rock solid when charging or transferring files so I really don't know
     

    #52
  13. _Bharat_
    Gingerbread Dec 17, 2020


    #53
  14. E1558912633684
    Gingerbread Dec 17, 2020

    E1558912633684 , via OnePlus 7 Pro , Dec 17, 2020 :
    Do you have Developer Settings enabled? Maybe tweaking these settings helps?
    Also, sometimes an older version of AA does work.. So you could try some older versions maybe (Apkmirror)
     

    #54
  15. Hitzilla4
    Gingerbread Dec 17, 2020

  16. A1607817608634
    Cupcake Dec 17, 2020

    A1607817608634 , Dec 17, 2020 :
    The cable is working with any other phone I checked

    Tried multiple old versions but it asks me to update when I connect to android auto,
    And in the background it shows the same issues, any idea how to bypass the android auto update banner it shows?
     

    #56
  17. E1558912633684
    Gingerbread Dec 20, 2020

    E1558912633684 , via OnePlus 7 Pro , Dec 20, 2020 :
    Hmm.. I'm running out of ideas I'm afraid.. Maybe you could ask a dealer for help? I've read some things about developer options in the system of your car, where AA must be activated first..
     

    #57
  18. arunkiran.brb
    Donut Dec 27, 2020


    #58
  19. E1558912633684
    Gingerbread Dec 27, 2020


    #59
  20. Nhullam
    Donut Dec 28, 2020

    Nhullam , Dec 28, 2020 :
    yes, my father is having an issue with the OnePlus Nord, Oxygen version10.5.9. I have in my decide the 10.0.10 and works perfectly.

    please update it!!
     

    #60