1
Android auto no longer works after oxygen os 11. via OnePlus 7 Pro

  1. patstar5
    Jelly Bean Mar 26, 2021

    patstar5 , via OnePlus 7 Pro , Mar 26, 2021 :
    I updated my oneplus 7 pro to oxygen os 11 yesterday and now I can't get android auto working in car. I have a Buick lacrosse. It worked fine beforehand. I've tried Uninstalling and reinstalling app. Hasn't made difference.
     

    #1
    f.fontana70 likes this.
  2. f.fontana70
    Cupcake Apr 2, 2021

    f.fontana70 , via OnePlus 7 Pro , Apr 2, 2021 :
    I can only echo what you just said. I have a Volvo V90. No issue at all before OS update. My device (7 Pro) just doesn't get recognised as an Android device when connected via wire. I also tried to update Android Auto app but hasn't made any difference.
    Can OnePlus fix asap?
     
    Last edited: Apr 2, 2021

    #2
    GGU59163 likes this.
  3. Theo6294
    Froyo Apr 2, 2021

    Theo6294 , Apr 2, 2021 :
    Hello everybody !

    I have the same problem. One Plus 7 Pro with OOS 11 and Android Auto on my Renault Clio IV . :(

    Please fix that OnePlus team. :(
     

    #3
    f.fontana70 likes this.
  4. G_Martin_Schayna_ONqN
    Cupcake Apr 10, 2021

    G_Martin_Schayna_ONqN , Apr 10, 2021 :
    In my case it takes over one minute to start connecting after plugging to USB. Then everything works as before update. Maybe it'll be your case too. But I agree, it's not acceptable, I hope it'll be fixed soon.
     

    #4
    f.fontana70 likes this.
  5. JNiemi
    Honeycomb Apr 10, 2021

    JNiemi , Apr 10, 2021 :
    I did update OS11 and first try android auto were not working. What I did to get it working;

    - Clean temporary files of AA
    - Restart phone
    - Remove phone sync from car
    - First sync it with BT with car
    - Then plugged with orginal USB cable to car

    It took ~1-2 minutes to establish connection with car but I got it working and it have worked since.
     

    #5
    Biitula likes this.
  6. f.fontana70
    Cupcake Apr 11, 2021

    f.fontana70 , via OnePlus 7 Pro , Apr 11, 2021 :
    I will try if that works. Thank you
     

    #6
  7. JNiemi
    Honeycomb Apr 12, 2021

    JNiemi , Apr 12, 2021 :
    I forget to say that after you have connected to car change USB status from only load to file transfer.
     

    #7
    f.fontana70 likes this.
  8. f.fontana70
    Cupcake Apr 16, 2021


    #8
    JNiemi likes this.
  9. N1619065509320
    Cupcake Apr 22, 2021

    N1619065509320 , Apr 22, 2021 :
    It doesn't work for me. When I connect it to my Honda Accord, i can't switch it from no data transfer to file transfer. How does that work for you?
    Thanks
     

    #9
  10. Trueffel
    Eclair Apr 22, 2021

    Trueffel , via OnePlus 8 , Apr 22, 2021 :
    Same here on op8. It worked a few months ago.. sometimes. Sometimes Android Auto Just wont start again after it crashed/disconnected. Had to uninstall Android Auto to get it working again.

    And now. Nothing helps anymore. My Phone Just Starts chargeing and i cant Change the usb settings to Set it to datatransfer.
     

    #10
    N1619065509320 likes this.
  11. N1619065509320
    Cupcake Apr 23, 2021

    N1619065509320 , Apr 23, 2021 :
    Me too. It doesn't allow me to change it to data transfer
     

    #11
  12. JNiemi
    Honeycomb May 5, 2021 at 4:18 PM

    JNiemi , May 5, 2021 at 4:18 PM :
    I can change it from load only to file transfer;
    1. Plug your phone to car
    2. Open notifications (pull from top to down) in home screen
    3. There is tiny notification that USB Charge only, press that and it should open different options, like file transfer, use only modem, PTP, Charge only etc...
     

    #12