[Answered] Android Auto not working with OnePlus 3

Thread Status:
Not open for further replies.
  1. dipesharora
    Eclair Nov 26, 2016

    dipesharora , Nov 26, 2016 :
    Android Auto on my OnePlus 3 will not work. I used the workaround suggested by someone on the forum to select MIDI in USB configuration after which it works but I have to do that everytime. On my sister's OnePlus 3, this works even if set to USB charging.
    Also, when I flashed CM14.1 nightlies on my phone, it worked with USB charging also. So, my guess is that the issue is with Oxygen OS and not the device or the car. I am currently running Oxygen OS 3.2.8 and have a Honda Accord 2016.

    inffy likes this.
  2. ranjithr43
    KitKat Dec 1, 2016

    ranjithr43 , Dec 1, 2016 :
    It seems to be working fine for me on my Honda Civic 2016. Try uninstalling and reinstalling the app and allow access when prompted.

  3. inffy
    KitKat Jan 2, 2017

    inffy , Jan 2, 2017 :
    I actually had a disconnect today with android auto after few minutes of listening of Spotify. Happened about three times in a row. My car is Skoda Octavia my2016

    Can you test something. Go to settings - developer settings and find a "Select USB Configuration" -> change it to MIDI (the settings wont change first). Back out of developer settings and go back and check if the setting is now having a "MIDI" (was charging).

    After that test AA again. I just did that and after that again no problems with AA

  4. dipesharora
    Eclair Jan 2, 2017

    dipesharora , Jan 2, 2017 :
    I already tried that. I changed the settings in Developer Mode to MIDI but to my surprise, it does not retain the setting and I have to keep changing that in Developer options. And as I mentioned, this is happening on my phone with Oxygen OS, even with the new Nougat based Oxygen OS 4. My sister's got the same OnePlus 3 and it works fine on her phone. Also, if I install CyanogenMod, it works. Hence, the conclusion that there is something wrong in the Oxygen ROM.

  5. inffy
    KitKat Jan 2, 2017

    inffy , Jan 2, 2017 :
    Yeah seems so. I noticed too that the setting doesn't stay on and it changes to the normal charging.

    But after i did that my AA connection has worked.

    I'll write this up on our bug sheet too.

  6. dipesharora
    Eclair Jan 2, 2017

    dipesharora , Jan 2, 2017 :
    Any ETA on when can we expect the fix to be available. I heavily rely on AA for Navigation or Playing Music through Google Play Music and it is very annoying to change the setting to MIDI everytime.

  7. inffy
    KitKat Jan 2, 2017

    inffy , Jan 2, 2017 :
    Sorry no idea on what kind of ETA we are talking as I have no part in the development. But I hope the devs can get something for a next Open Beta release to test

  8. dipesharora
    Eclair Jan 2, 2017

    dipesharora , Jan 2, 2017 :
    I understand. But keep us posted when you hear back from your Dev team. My agony is that the issue was reported almost more than a month ago and it is still to be reviewed by Devs.

  9. Gesila A.
    Gingerbread Jun 27, 2018

    Gesila A. , Jun 27, 2018 :
    Hello @dipesharora,

    Good day!

    This is from OnePlus Bug Hunters. How are you? If you are still experiencing this issue, we highly recommend that you update your phone to its latest build. If the issue will persist, please create a new bug report with the updated information so that we can re-look into it. This thread will now be closed and marked as "Fixed".

    Thank you and have a nice day.