4
Android Auto Oneplus 6

  1. ldkeyne
    Cupcake May 31, 2018

    ldkeyne , May 31, 2018 :
    Is there someone who has been able to connect the Oneplus 6 to Android Auto? If so, how did you do it?

    I can connect via Bluetooth but using the Android Auto App hasn't worked yet...
     

    #1
  2. 404.php
    Honeycomb May 31, 2018

    404.php , May 31, 2018 :
    It should prompt you to set it up once you connect yours phone to your car via USB. If it doesn't, file another Android Auto bug report to OnePlus. Also, contact your car manufacturer to see if there's a software update on the head unit that you need to install.
     

    #2
    ldkeyne likes this.
  3. Rob_DE
    Cupcake May 31, 2018

    Rob_DE , May 31, 2018 :
    My OP6 is working fine with Android Auto on a 2017 Kia Optima. In fact, it is much faster than my previous phones.
     

    #3
    ldkeyne likes this.
  4. angelacr
    Eclair May 31, 2018

    angelacr , May 31, 2018 :
    Works just fine! Using a unofficial AA port to a Mazda. Even tried wireless today. Still a bit buggy and a pain to set up.

    One note: the recent Huawei P20 Pro draws the AA screen with errors and was buggy until Huawei made an update.

    Oneplus performed perfectly. Voice commands, navigation and Play Music all work nicely.
     

    #4
  5. gilroyneil
    Eclair May 31, 2018


    #5
  6. Rob_DE
    Cupcake May 31, 2018

    Rob_DE , May 31, 2018 :
    Just tested in a friend's ford fusion - no probs. I did not change my notch display on either vehicle (it's set to show notch)
     

    #6
  7. wsrobert
    Froyo May 31, 2018

    wsrobert , May 31, 2018 :
    For those who've had success with AA and the OP6, have you tried making a call yet?

    I'm using the OP6 in my Volvo XC60 and for the most part it functions just fine. Though it will not place a call through the AA interface. I'll initiate a call via google assistant, the phone screen will light up on the dialer, but the call does not go through.
     

    #7
  8. greeser
    Eclair May 31, 2018

    greeser , May 31, 2018 :
    I used it with my Kia stock head unit and it works great. But I have to use an Anker USB-C Cable, the OnePlus Cable doesn't work for me.
     

    #8
  9. sumera1402
    Cupcake May 31, 2018


    #9
  10. Ralf_Uhrig
    Cupcake May 31, 2018

    Ralf_Uhrig , May 31, 2018 :
    Also here: Issues, when Notch-Display is disabled: The Android-Auto-Display is cropped and Touch doesn't work properly. Enabling the Notch again solved this Problem. >>>> To OnePlus: please fix this in the next Update, Thank You. In all other Aspects: an awesome Devise, blazing fast!!! :)

    Update 2018/06/20: Tried again today with The latest Firmware: Works now without problems, also with the notch "disabled". Thx!
     
    Last edited: Jun 20, 2018

    #10
    MarkMessinger likes this.
  11. 404.php
    Honeycomb Jun 1, 2018

    404.php , Jun 1, 2018 :
    Yes, but the volume seems low. I'm not sure if it's the basket like caller or the phone.
     

    #11
  12. madpete76
    Cupcake Jun 1, 2018

    madpete76 , Jun 1, 2018 :
    Mine randomly wouldn't connect, but I had a 5T too and that was exactly the same... both solved though by enabling USB debugging, after that it works flawlessly.
     

    #12
  13. ldkeyne
    Cupcake Jun 1, 2018

    ldkeyne , Jun 1, 2018 :
    It works now :)) thanks everyone! Just needed to connect the USB C for setup after a clean install of the application.
     

    #13
  14. Rob_DE
    Cupcake Jun 1, 2018

    Rob_DE , Jun 1, 2018 :
    What year Kia? My 2017 Kia is working fine with the OnePlus cable that came with the OnePlus car charger I bought direct from OP
     

    #14
  15. Rob_DE
    Cupcake Jun 1, 2018

    Rob_DE , Jun 1, 2018 :
    I haven't had this prob with my OP6 and AA on Kia Optima head unit. The only prob I have is when I reply to a text, Google says "What's the message?" then allows me to talk...but the microphone picks up the word "message" from Google speaking, so my texts all start with the word "Message" when I'm responding via AA! lol
     

    #15
  16. greeser
    Eclair Jun 1, 2018

    greeser , Jun 1, 2018 :
    2018 Kia with the cable which is delivered with the OP6
     

    #16
  17. ShoutHouse
    Cupcake Jun 6, 2018

    ShoutHouse , Jun 6, 2018 :
    Heya. Mine won't work right off the bat with Android Auto in my Chevrolet Trax 2017.

    Here is how to get it to work.
    1. Turn on usb debugging
    2. Plug the phone in.
    3. Turn off usb debugging

    It should now see it. For some reason when I plug it in, the phone disconnects and reconnects constantly. Randomly it might sometimes stay connected and open AA, but this method works every time.
     

    #17
    OnePlusBrice likes this.
  18. tridnguyen
    Cupcake Jun 14, 2018

    tridnguyen , Jun 14, 2018 :
    I had a OnePlus 3T before, and it works fine with my 2016 Honda Accord. However, my new OnePlus 6 doesn't when I connect.

    After browsing around the internet, I found this post, which is the only one that mentions the issue and a solution https://www.reddit.com/r/oneplus/comments/8mv5db/one_plus_6_android_auto_2016_honda_accord/

    I have to manually switch USB mode to MIDI every time I connect in order to enable Android Auto.

    I wonder if anyone else has seen this. I hope that this is a bug that will be resolved soon.
     

    #18
    dam76 and ranyrix like this.
  19. ShoutHouse
    Cupcake Jun 25, 2018

    ShoutHouse , Jun 25, 2018 :
    @tridnguyen
    Yea, I have given them a bug report but they tried to blame the issue on the previous version and told me to update. It took them too long to take a look at the report and the update came out in the meantime.

    Still, the issue persists. Switching to MIDI or using the USB Debugging trick is working. Which, to me, explains a lot. I'm sure they'll get it fixed.


    Edit: Issue has been fixed.
     
    Last edited: Sep 26, 2018

    #19
  20. tridnguyen
    Cupcake Nov 6, 2018

    tridnguyen , Nov 6, 2018 :
    Hmm, this hasn't been fixed for me. I just switched to the OnePlus 6T, and the same thing happens.
     

    #20
    MartinT77 likes this.