16
Android Auto Oneplus 9 Pro

  1. aerichards
    Eclair Mar 29, 2021

    aerichards , Mar 29, 2021 :
    Has anyone been able to get Android Auto working on the Oneplus 9 Pro? I have 4 different vehicles and it doesn't work on any of them - a 2018 Subaru Crosstrek, a 2016 Chevrolet Tahoe, a 2019 GMC Sierra 1500, and a aftermarket Kenwood unit. I doubt it but is it linked to the Certified Play Store thing? For a brand new $1000+ phone, there seem to be quite a few issues right out of the box.
     

    #1
  2. AstersJr
    The Lab Reviewer - OnePlus Buds Pro Mar 30, 2021

    AstersJr , via OnePlus Community App , Mar 30, 2021 :
    I haven't purchased yet but will be watching this thread with interest as Android Auto is a must have imo. Do you usually connect to your cars with a wire or wirelessly? And have you tried both methods with the OP9 Pro?
     

    #2
  3. bjevers
    Donut Mar 30, 2021

    bjevers , Mar 30, 2021 :
    I could only get it to work in my 2020 Ram 1500 using the cable provided with the phone. Luckily, my truck has USB C inputs.
     

    #3
  4. Swejuggalo
    OnePlus 9 Series Expert Community Expert Mar 30, 2021


    #4
    Caoimhín likes this.
  5. dpgx81
    Honeycomb Mar 30, 2021

    dpgx81 , Mar 30, 2021 :
    Used mine yesterday no issues so far. Certain functions like other Android phones don't work with my cars touch pad (appears to only work with ios devices so far), but the touch screen works perfectly. 2021 Mercedes-Benz GLB250.
     

    #5
  6. BrettCF02
    Froyo Mar 30, 2021

    BrettCF02 , Mar 30, 2021 :
    Having the same issue AA won't connect - goes into a loop - Car: 2020 Lexus RC. Was working fine with my OP 7T running Android 10. :-(. very annoying. Is the issue with OP, AA or Android 11?
     

    #6
  7. dwboston
    Froyo Mar 31, 2021

    dwboston , Mar 31, 2021 :
    AA works fine with the 9 Pro and my car - 2019 Range Rover Sport. Connected via a Google-branded USB cable. I had lots of issues with other cables with my previous OP 7 Pro, but once I found the Google branded cable it's worked pretty flawlessly. The 9 Pro connected right away (seemed quicker than the 7 Pro as well at launching AA) and all functions worked as expected.
     

    #7
  8. mixedmessages
    Gingerbread Mar 31, 2021


    #8
  9. BrettCF02
    Froyo Mar 31, 2021

    BrettCF02 , Mar 31, 2021 :
    Ok mines working now. Very weird fix - basically I connected the phone via USB (Cable is Type C and UBS 3 - came with OP 7T - new OP 9 Pro has Type C on both ends, hence had to use 7T cable). Started Lexus info-system - phone goes into a loop trying to connect, Android Auto app opens/closes - had to be quick to click next, connect etc. went around that loop about 5 times and then boom it connected and seems to be working fine.
    Additional note: I noticed if I connect the phone via USB first and then start the car it connects without issue 98% of the time..
     
    Last edited: Apr 13, 2021

    #9
    prestonjb likes this.
  10. dmdukes
    Eclair Mar 31, 2021

    dmdukes , Mar 31, 2021 :
    I think it's the update that came in last night. I am having issues as well, tried 3 different cables. My OP6t works fine, but the 9 pro ($1000+ phone!) doesn't. This IS a serious issue.
     
    Last edited: Mar 31, 2021

    #10
  11. Jake0808
    Cupcake Mar 31, 2021

    Jake0808 , Mar 31, 2021 :
    Mines exactly the same was fine with the 7T but now I have a 9 pro the android auto just constantly connects disconnects and connects again in a loop. One plus need to be aware of this!
     
    Last edited: Apr 1, 2021

    #11
  12. mixedmessages
    Gingerbread Mar 31, 2021

    mixedmessages , Mar 31, 2021 :
    I spoke with support today and they advised me to turn on USB Debugging in the Developer Options.

    Problem solved.

    EDIT - STILL AN ISSUE AFTER TURNING OFF THE CAR
     
    Last edited: Apr 25, 2021

    #12
    Fmanfer likes this.
  13. yarekg
    Donut Apr 1, 2021

    yarekg , Apr 1, 2021 :
    I had to put PTP on usb defaut when connected and solved my problem
     

    #13
  14. AL1963
    Cupcake Apr 1, 2021

    AL1963 , Apr 1, 2021 :
    please could you explain what PTP is and how to change its settings ?
     

    #14
    L1621003859524 likes this.
  15. FiJa
    Cupcake Apr 1, 2021

    FiJa , Apr 1, 2021 :
    Ford focus 2018 with sync 3 also doesn't work/detect aa😐
     

    #15
  16. dmdukes
    Eclair Apr 1, 2021

    dmdukes , Apr 1, 2021 :
    If it's what I am thining, you turn on developer options, then search "USB" and there is a "USB defaults" option inside of developer options. Testing now! Just turning on developer did not work for me. PTP nor MTP nor File sharing USB mode did not work.

    Anyone who gets it to work, did you do the newest update the one ~350 MB?
     
    Last edited: Apr 1, 2021

    #16
  17. AstersJr
    The Lab Reviewer - OnePlus Buds Pro Apr 1, 2021

    AstersJr , via OnePlus Community App , Apr 1, 2021 :
    When I got my 2017 Mazda 3 enabled for Android Auto it wasn't working but when I purchased a new cable it worked ok. They seem to be very temperamental with cables types so perhaps try a different one if you have it.
     

    #17
    U1621737974641 likes this.
  18. AL1963
    Cupcake Apr 1, 2021

    AL1963 , Apr 1, 2021 :
    PTP and USB debugging did not work for me, Android auto starts the fails over then re cycles, tried all the other USB modes none fixed the problem please OnePlus can you look at this asap ?
     

    #18
  19. Bibz32
    Eclair Apr 3, 2021

    Bibz32 , Apr 3, 2021 :
    I have a 2019 Mazda CX9 Signature, I've had probably 10 different phones that I've used Android Auto in with no problem.

    I absolutely could not get it to work with the OP 9 Pro today.

    I'm really getting tired of these bugs. I know Auto has had some issues across brands, but I plugged in a Pixel 5 and a Galaxy S21 after I got so frustrated with the OP 9 Pro, and they worked just fine. (And yes I have too many phones. Il already hear about it from a wife all the time.)

    My disappointment with OnePlus is at an all-time high.

    I wonder what Pei is going to do with the Essential phone patents? 🤔
     

    #19
  20. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 3, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 3, 2021 :
    Something tells me I need a Android Auto equipped car... 😉
    I got to test it on a rental on 8 Pro once though and that worked well. My car needs service... Maybe I get a car to borrow during that time with it for me to play with 😉 🚗

    Hope we get a few bug reports that leads to a solution.
     

    #20
    Caoimhín likes this.