0
Network/Connectivity

android auto problems with mic and messaging

  1. france42 Honeycomb Nov 6, 2018

    france42, Nov 6, 2018 :
    i've been troubleshooting for at least three long days and have yet to arrive at a solution.

    1. when i say "ok google," i rarely get a beep response. mostly ok on the first attempt and then have to resort to the button or mic icon on my head unit to connect with asst.

    2. whatsapp will NOT send. half the time i can't even get through the process. stops after first or at best second level and then i get those three google asst bubbles that usually means impending doom!

    3. most questions i ask asst. are answered, but when i play quizzes or use other asst. services, it cuts out before the end result. very frustrating.

    i've tried the following fixes (to no avail):
    enabled usb debugging: no difference
    enabled midi and/or file transfer on default usb config
    fiddled with mic on head unit
    emptied cache and data for each app that i use with AA.
    uninstalled and reinstalled all AA associated apps.
    changed default asst. voices.
    retrained asst. voices.
    disabled notification gestures for the default button configuration.

    navigation works fine almost always. hardly ever have to repeat. i've also reconnected my oneplus one (still ticking like a timex watch!) and have no problems with AA at all.

    anyone wanna tackle this with me? anyone else experiencing the same or similar issues? i love both Oneplus and AA and would really like it to work as well as it did "before" (seems like the problems arrived simultaneously with the Pie update).
     

    #1
  2. france42 Honeycomb Nov 7, 2018

    france42, Nov 7, 2018 :
    update: i reverted to oxygenos version5.1.11 and android auto is sending messages again, hearing me more often and generally much more efficient. so i guess the problem is with the pie update. is oneplus working on this to get it up to speed?
     

    #2
  3. Kytharsis Marshmallow Nov 7, 2018

    Kytharsis, Nov 7, 2018 :
    It's... not up to OnePlus to optimize a Google app, it's Google's. ;)
     

    #3
  4. france42 Honeycomb Nov 7, 2018

    france42, Nov 7, 2018 :
    I spoke to oneplus who is aware of the glitches on Android Auto since the pie update. They say they're working on it and it'll get addressed in an update. The glitches are due to the pie update and not the Android Auto app. I'm gonna hang on to oreo in the meantime. Everything works well there.
     

    #4
  5. france42 Honeycomb Nov 7, 2018

    france42, Nov 7, 2018 :


    Kytharsis

    It's... not up to OnePlus to optimize a Google app, it's Google's.​


    Yes I realize that. But the problem is not with the Google app it's with the oneplus pie update and its performance with AA.
     

    #5
  6. france42 Honeycomb Jan 12, 2019

    france42, Jan 12, 2019 :
     

    #6
  7. france42 Honeycomb Jan 12, 2019

    france42, Jan 12, 2019 :
    still no workarounds, no updates addressing this, no support?

    i have recently learned (by my own experience), that oneplus is sending OTAs that automatically update my phone, and after update i can no longer rollback to oreo!

    and unfortunately the latest update makes android auto even less responsive than before! I can neither reach any media apps (i get a black screen), get a response via voice, send a whats app msg (which my whole family uses to communicate, sans moi!). luckily i can still use navigation and send an occasionally text or hangout msg. i feel like i'm complaining in an echo chamber!

    is anybody else hitting the brick walls as i am? and please, don't tell me what i can't do, how wrong i am, or to blame google! if you have something CONSTRUCTIVE to say, let's network. if you don't, please don't troll!

    thanks!
     

    #7
  8. Kerngehirn3 Honeycomb Jan 12, 2019


    #8
  9. france42 Honeycomb Jan 12, 2019

    france42, Jan 12, 2019 :
    yeah, i've tried to start it over and over again. it doesn't crash. on my screen i see my last rec'd msgs., the weather, who called me recently, and my last media app that i listened to. i can connect to nav via mic icon. i can get answers to questions, i can leave reminders (but not by saying "ok google" - i have to click the mic icon).

    also, i forgot to mention in my previous posts that when connected via bluetooth audio to my head unit (sony xav-ax100) it works flawlessly! but i need it to work through my head unit not just the audio. thanks for your response in any case! i appreciate it!
     

    #9
  10. france42 Honeycomb Jan 12, 2019

    france42, Jan 12, 2019 :
    whilst looking for a solution on these android auto threads i came across a post from cully1968, who suggested disabling "face unlock" to gain better access to media apps. i tried it, and not only did it work for me to facilitate connection to media apps, but i've also regained voice command (ok google)! so if anyone is having these problems and also uses "face unlock," this may be a possible workaround!

    I'm still not able to send messages via whats app, and i get no audio alerts when i either receive messages or phone calls. still searching....
     

    #10