2
OxygenOS Android Auto stopped working

  1. paramsinghvc
    Cupcake Aug 17, 2019

    paramsinghvc , Aug 17, 2019 :
    After a recent Android Pie patch update on my OnePlus 6, android auto stopped working with my Hyundai Verna 2019 model. I have tried the following steps

    1. Turned off the previously turned on Developer options and USB debugging. Although, it was working earlier with these enabled.
    2. Rebooting and re-installing Android Auto app, all permissions are given.
    3. Connecting the car through Bluetooth first and then connecting Android Auto through wire. Bluetooth works fine though.
    4. Tried connecting another Android phone and it works. Apple carplay also works fine.
    5. Tried with another wire as well. I have tried with Oneplus 6 official charging wire and it doesn't work.

    When I connect the USB cable, it says on the car infotainment system that "USB is reading device" and then it says "Phone is not responding".

    Also, when I try to change the option under "Use USB for" under "USB Preferences" from "No data transfer" to "File transfer" or any other option in that list, it selects it but after a second, it goes back to "No data transfer" which is why probably Android Auto is also not connecting.

    Mobile: OnePlus 6 (A6000)
    Android Version: 9
    OxygenOS version: 9.0.8
    Build Number: ONEPLUS A6000_22_190801
    Car: Hyundai Verna SXO 2019

    Please help.
     

    #1
    strakszys and dam76 like this.
  2. dam76
    Eclair Aug 25, 2019

    dam76 , Aug 25, 2019 :
    I just installed the app, and it crashes instantly, before even connecting it to any car
     

    #2
  3. mr_toni_kun
    Eclair Aug 25, 2019


    #3
  4. MR.NAVID
    Cupcake Sep 16, 2019

    MR.NAVID , Sep 16, 2019 :
    Is there any update on this issue? Today i faced the similar problem with VW passat 2018 model.
    The mobile connected just for a second but again moved back to main screen and the car screen was still showing no connection with the mobile. I tried all the available USB connection options on the mobile.
    Mobile mode: A6003
    Build num: A6003_22_190801
    Oxygen os: 9.0.8
     

    #4
  5. WebBuddha
    Cupcake Sep 17, 2019

    WebBuddha , Sep 17, 2019 :
    Did you tried an high quality usb cable? Most connectivity problems are cable related.
     

    #5
  6. Charalambos1997
    Cupcake Sep 17, 2019

    Charalambos1997 , Sep 17, 2019 :
    I have the same problem. My solution was to install a previous version of android auto (4.4.592343) and now it works. I think its the new update and something isn't compatible with the OxygenOS.
     

    #6
  7. MR.NAVID
    Cupcake Sep 21, 2019

    MR.NAVID , Sep 21, 2019 :
    Yes, i have tried with original cable but the problem remains.
    I have also tried different USB preferences in developer mode and the problem still not resolve.
     

    #7
  8. MR.NAVID
    Cupcake Sep 21, 2019

    MR.NAVID , Sep 21, 2019 :
    From where did you get the previous version? Can you share the link?
     

    #8
  9. Charalambos1997
    Cupcake Sep 21, 2019


    #9
  10. MR.NAVID
    Cupcake Sep 22, 2019

    MR.NAVID , Sep 22, 2019 :
    I resolved the issue by downloading the Andriod Auto from https://www.apkmirror.com/apk/google-inc/android-auto/
    In my case andriod auto is not yet available in Sweden so i downlaoded the latest version of it from link above. And, offcourse, after granting permissions to app it now works perfectly with my VW passat 2018 model.
    Even non-original Deltaco usb-c is working with mobile and AA.

    So if AA is available in your country may be try switching to previous version of it as suggested by Charalambos1997 in his comment above.
     
    Last edited: Sep 23, 2019

    #10
  11. xconan
    Eclair Oct 2, 2019

    xconan , Oct 2, 2019 :
    I can't even connect to Android Auto on the 2018 Honda Accord. It doesn't even recognize that there is even a connection there at all. Neither does OP6. However, it does recognize an iPhone. Please resolve issue with the 2018 Honda Accords.

    As a suggestion since a lot of people drive and use Android Auto, there should be a dedicated thread just to Android Auto with a survey or poll for make model and year of vehicle as well as version of Oneplus and Oxygen OS ver. whether is working or not and what the issues are. At least this way it's easier for users to find what cars are compatible and not or how to fix. Thanks.
     
    Last edited: Oct 2, 2019

    #11
  12. mbruurs
    Donut Oct 6, 2019

    mbruurs , Oct 6, 2019 :
    are you using parallel spaces? Turn this off. I had the same.
     

    #12