Android Pay cannot be used

  1. theludz
    Eclair Sep 12, 2015

    theludz , Sep 12, 2015 :
    I just updated Google Wallet, which installed a new, replacement App called Android Pay. It requires me to setup a Credit/Debit card to use the app.

    When I add a card, I get the message "Android Pay cannot be used" followed by "Google is unable to verify that your device or the software running on it is Android compatible".

    Is this happening to anyone else running COS 12.1 on a rooted OP1?

    The annoying part is I don't even want to use Android Pay. I was only using Wallet to store all my damn Loyalty Cards.

  2. StaminaOP
    Honeycomb Sep 12, 2015

    StaminaOP , Sep 12, 2015 :
    Android Pay only works with if your running 4.4 or higher and since your phone is rooted that may cause it to not verify in a sense.

  3. d-a-n
    Ice Cream Sandwich Sep 12, 2015

    d-a-n , Sep 12, 2015 :
    Yep have read the same reports, I believe if it's rooted, it won't work.

    silvagroup and lostLambda like this.
  4. Zeals
    Gingerbread Sep 12, 2015

    Zeals , Sep 12, 2015 :
    Historically once you root a device NFC things don't work because it affects the secure elements therefore they disable it as a precaution.

    veratoloz2005 and Ceasedd like this.
  5. JOE3PO
    Donut Sep 13, 2015

    JOE3PO , Sep 13, 2015 :
    I was having the same problem on my OPO Cm 12.1 rooted & running xposed.

    To get it working I disabled SU and uninstalled xposed. Then I was able to add my cards.

    Everything is still working after I re-enable SU and reinstalled xposed.

    tEf0o and MustBeTrippin like this.
  6. theludz
    Eclair Sep 14, 2015

    theludz , Sep 14, 2015 :
    I uninstalled root and xposed and I still can't get Android Pay to work. What versions of Pay and Play Services do you have installed?

  7. JOE3PO
    Donut Sep 14, 2015

    JOE3PO , Sep 14, 2015 :
    I'm using GPS 8.1.14 (2244331-238) & Android Pay 1.0.102576552

    Hope you get it working.

  8. Primaris
    Donut Sep 15, 2015

    Primaris , Sep 15, 2015 :
    Not rooted, but encrypted, 4.4.4, One+ One and Android Pay does not work. I get the same error when I try to add a card; "Google is unable to verify that your device or the software running on it is Android compatible".

    slumos likes this.
  9. blaw2
    Froyo Sep 16, 2015

    blaw2 , Sep 16, 2015 :
    I get same error trying to set up Android Pay. Never rooted, never encrypted my opo. Have only ever done the OTA updates.

    Android 5.1.1, Cyanogen OS 12.1-YOG4PAS1N0.

    slumos, Heyzues91 and HarinderG like this.
  10. ajmorley28
    Gingerbread Sep 17, 2015

    ajmorley28 , Sep 17, 2015 :
    dont like what i'm hearing so far i would like to at least try android pay but i'm running a rooted opo and not sure if mine will work either. i haven't gotten the update yet but hope mine works

  11. shirilover
    Froyo Sep 17, 2015

    shirilover , Sep 17, 2015 :
    I got the update this evening. The two things I needed to do were:
    1. Uncheck 'enable superuser' in SuperSU
    2. reset DPI to default
    Afterwards, I was able to complete the adding process, though I have not tried tap and pay yet.

    Pahapoika91, sssobel, vijayd and 3 others like this.
  12. blaw2
    Froyo Sep 17, 2015

    blaw2 , Sep 17, 2015 :
    Thanks shirilover!! Changing the DPI back to default was what did the trick for me. I don't have root, hence no SuperSU, so I can confirm that the DPI setting definitely affects the Android Pay app.

    Once I changed the DPI back to default of 480, I was able to add my credit card. I then changed the DPI back to 400 and Android Pay still seems to work but the real test is when I go to pay for something.

    sssobel, vijayd and Ccollado like this.
  13. Waterpater
    Froyo Sep 17, 2015

    Waterpater , Sep 17, 2015 :
    Keep us updated!

  14. mielo5280
    Froyo Sep 17, 2015

    mielo5280 , Sep 17, 2015 :
    I am using slimroms lollipop 5.1.1 rooted not using xposed and still can't get it to work. I am now resetting my dpi to default and removing supersu. I'll report back if I get it working.

  15. mielo5280
    Froyo Sep 17, 2015

    mielo5280 , Sep 17, 2015 :
    Just removed supersu, set dpi to default and still not working. still gives me the "google is unable to verify that your device or the software running on it is android compatible" what do I do now. I don't want to have to flash another rom right now, just flashed the one I'm on

    TileGuyJesse likes this.
  16. Me1256
    KitKat Sep 17, 2015

    Me1256 , Sep 17, 2015 :
    You can't use android pay if your ROM is rooted. You have to disable SuperSU, or use rootcloak with exposed..

    CasperTFG likes this.
  17. blaw2
    Froyo Sep 17, 2015

    blaw2 , Sep 17, 2015 :
    Just to clarify... did you remove SuperSU the app? From posts I've seen, you have to uncheck "Enable superuser" from within SuperSU. Did you do that before removing the app?

  18. mielo5280
    Froyo Sep 17, 2015

    mielo5280 , Sep 17, 2015 :
    yes I checked the "enable superuser" so it is currently disabled. I should clarify that I didn't fully remove the SuperSU app because it's baked into slimLP rom. should I remove it completely or just go to stock COS 5.1 because I really use the google wallet and want to start using android pay

  19. blaw2
    Froyo Sep 17, 2015

    blaw2 , Sep 17, 2015 :
    So, I went to Walgreens to buy a pack of gum to test. 2 Eclipse car cup for $6. Went up to pay for it, tapped my phone to the terminal, Android Pay app launches automatically...then proceeds to crash my OPO. So not only did Android Pay not work, but I had to force boot my phone. :(

    Will try again later at a different retailer, but I'm not hopeful.

    mls2k3, lostLambda and dipix like this.
  20. asgalvan
    Donut Sep 17, 2015

    asgalvan , Sep 17, 2015 :
    I disabled SuperSU, put in the card, and it was able to go through. I reactivated root, but I don't know if that would affect it.