Android Pay cannot be used

  1. mielo5280
    Froyo Sep 17, 2015

    mielo5280 , Sep 17, 2015 :
    oh thats some sh*t

    Ccollado likes this.
  2. tarkeshpatel
    Cupcake Sep 17, 2015

  3. Jporrata
    Froyo Sep 18, 2015

    Jporrata , Sep 18, 2015 :
    • I installed root cloak and added Android pay, rebooted, no dice
    • Enabled enforcing mode on Linux, Disabled super su, Used rootcloack, set dpi to default (400) rebooted, no dice
    The last thing I have left to try is to restore my old build.prop. I'm on the latest 12.1 mainline COS.

  4. carl_gadget
    Gingerbread Sep 18, 2015

    carl_gadget , Sep 18, 2015 :
    I used SuperSU and just unticked Superuser, then it Pay let me add card, then I ticked Superuser in SuperSU and was fine.

    COS 12.1S OPO.

  5. mielo5280
    Froyo Sep 18, 2015

    mielo5280 , Sep 18, 2015 :
    Update: I re-flashed CyanogenOS 12.1 and before root I tried to readd my card and it didn't show the"android pay cannot be used" but told me I NY card didn't work that's probably cause it was a temporary wells Fargo card that was over 30 days. I'll try again with a different card and report back

  6. carl_gadget
    Gingerbread Sep 18, 2015

    carl_gadget , Sep 18, 2015 :
    on mine it asked for unlock, then again, then froze, I had to do forced reboot.

    Android Pain, not Android Pay.

    blaw2 likes this.
  7. i5xswipe
    Ice Cream Sandwich Sep 18, 2015

    i5xswipe , Sep 18, 2015 :
    It is up and running on my OPO COS12.1, as of last night, everything is setup, I have not used it yet however to make a purchase today.

  8. Ineeditto
    Cupcake Sep 18, 2015

    Ineeditto , Sep 18, 2015 :
    I get the same issue. It seems to be caused by the fact that you have to have a lock screen. Tapping takes me to unlock the device and freezes.

    I experience the same issue trying to reset my lock screen? It freezes unless I disable android pay as a device admin.

  9. tmmacara
    Eclair Sep 18, 2015

    tmmacara , Sep 18, 2015 :
    I'm not rooted but had changed DPI. I reset to default and now I'm able to add my cards without getting the nasty message. Thanks for the tip that worked for me.

    lostLambda likes this.
  10. DafDaf42
    Eclair Sep 18, 2015

    DafDaf42 , Sep 18, 2015 :
    I think Google are missing a trick with Android Pay by not rolling out in Europe. Google wallet has been around for years but there is still no word on whether Android Pay will make it to the UK. We already have apple pay over here which was announced six months ago?

    On the plus side, by the time it gets to the UK perhaps all the bugs will be ironed out!

  11. Globalcop
    Cupcake Sep 18, 2015

    Globalcop , Sep 18, 2015 :
    Unrooted stock OPO here with only OTA stock updates, Android Pay cannot be used.

  12. blaw2
    Froyo Sep 18, 2015

    blaw2 , Sep 18, 2015 :

    UPDATE 9/18

    Went to Peet's Coffee and Tea today to try a different vendor. Had my phone unlocked and at the home screen. When I attempted to pay, Android Pay fired up again, I saw the image of my credit card, then got an error message this time. Something to the effect of "your Amex card cannot be used at this time".

    I suspect that when the card is added, there is some type of "snapshot" of your phone settings/system state. Since I had to change my DPI setting back to default to add the card, perhaps I need to change the DPI back to default for Android Pay to work??

    Next test will be using default DPI for Android Pay transaction. Will try to use it during lunch and keep you guys posted.

    Oh, Globalcop, you seem to be in similar situation as myself being nonroot and only OTA updates. I had a problem adding card with Android Pay too until I changed back to default DPI. If you haven't tried that yet, give it a go.

  13. blaw2
    Froyo Sep 18, 2015

    blaw2 , Sep 18, 2015 :

    When I paid today at Peet's, phone didn't freeze this time. You might want to try a different store and see if it still freezes. Just wondering if it also has to do with the technology each store chooses to employ. From speaking with the cashier at Walgreens, she mentioned that if they don't have it ready on their screen first the transaction will fail. When I spoke to the cashier at Peet's she mentioned that it seems the touch payments fail about 50% of the time.

  14. carl_gadget
    Gingerbread Sep 18, 2015

    carl_gadget , Sep 18, 2015 :
    The tech is too new not reliable.

    Plus I'm not even sure using a phone is any faster simpler or better.

    Its only when the phone method is 100% universal and 100% reliable (or at least as good as other methods) would I NOT be carrying a credit/debit card and some cash. I always leave home with OPO, a creditcard, I.D. and about $20. So what does the phone do any better than the card I got also?

    This is gimmickry right out there on border of pointless.

    silvagroup likes this.
  15. sbhat3
    Cupcake Sep 18, 2015

    sbhat3 , Sep 18, 2015 :

  16. goodtom
    Froyo Sep 18, 2015

    goodtom , Sep 18, 2015 :
    I still get the cannot be used, unable to verify message even I disabled the SuperSU. I don't recall I've changed and DPI thou (and not sure how to change as well)

  17. blaw2
    Froyo Sep 18, 2015

    blaw2 , Sep 18, 2015 :
    On CM OS 12.1-YOG4PAS1N0 you can change it from settings.

    Settings -> Display and LIghts -> LCD Density. The default is 480DPI

  18. Deactivated User
    Sep 18, 2015

    lostLambda likes this.
  19. PopsicleMud
    Cupcake Sep 18, 2015

    PopsicleMud , Sep 18, 2015 :
    I haven't found that to be the case. I was able to use NFC to make payments reliably with the old Google Wallet on my OPO running Sultan's Stable ROM and SuperSU. The only thing that has changed today is Android Pay and Google Wallet.

    sn809, bszuta, Mrreed98 and 1 other person like this.
  20. Kn1nJa
    Donut Sep 18, 2015

    Kn1nJa , Sep 18, 2015 :
    I'm running exodus and I've used google wallet (the old version) for well over a year. Now with android pay I'm SOL.