Android Pay cannot be used

  1. nharward
    Cupcake Sep 30, 2015

    nharward , Sep 30, 2015 :
    OPO with COS 12.1 + root + xposed. I finally got things working by disabling root in SuperSU and uninstalling xposed - only disabling root didn't work for me. Once I added my cards and verified them I re-installed xposed and enabled root through SuperSU. At this point Android Pay seems happy enough, but I haven't been out yet to see if payments work at a vendor. I'm assuming it will work and if not I'll post back. Either way hopefully this helps someone else get a step further.

    Update: failed at the register (with root + xposed on), gave me a lock screen prompt and froze.
    Last edited: Oct 1, 2015

    MustBeTrippin likes this.
  2. blaw2
    Froyo Sep 30, 2015

    blaw2 , Sep 30, 2015 :
    sorry to everyone for not updating. I had failed to get it to actually make a payment a few more times and then gave up. This past weekend I decided to give it another go at Allegro Cafe in the new Whole Foods in Willowbrook, IL because they had the Android Pay logo. I unlocked my phone and placed it by the reader and the Android Pay app loaded up as it should. However, this time it threw error message that I had no payments configured. wtf...

    On the plus side, I've noticed at most coffee shops if it fails to work they typically give you the coffee on the house assuming it's their reader that's broken. So not a total fail? ¯\_(ツ)_/¯

  3. blaw2
    Froyo Sep 30, 2015

    blaw2 , Sep 30, 2015 :
    Given the terrible experience we've had with Android Pay, I'm curious if anyone watching this thread has used the new Samsung Pay (yes I did a search and nothing came up regarding experiences using it). My co-worker has the S6 Edge but has been on vacation since Samsung Pay launched. Would love to know if it really works on the really old magnetic card readers and how the overall experience has been.

  4. laanrobe
    Honeycomb Oct 1, 2015

    laanrobe , Oct 1, 2015 :
    I managed to pay with Android Pay and my OPO today! As indicated before, I am on stock COS 12.1 and was able to upload my cards (as previously linked to Google Wallet) after setting density back to standard. This time I also disabled (uninstalled, sorry @Aaahh ) Screen Equalizer, the app that hides the dreaded yellow band... I do not know if it had anything to do with it (I seem to recall at one point getting a message when activating Android Pay that a 'screen overlay' was preventing activation), but today I managed to process two payments using Android Pay on the OPO. Both were with the same retailer (BJ's), some standard groceries and then a bottle of whiskey in their liquor store to celebrate :p.

    Although I also uploaded the BJ's membership card to Android Pay, I could not use this to read my membership card. A BJ's employee informed me that they will not accept any other bar codes than the one on the membership card, since the physical card also has a picture of the member and the card in Android Pay does not have that :mad:.

    After the first payment Android Pay froze my OPO though and I had to reboot for the second payment... There is still a lot to improve in Android Pay it seems.

    gringoboy likes this.
  5. Aaahh
    Marshmallow Oct 2, 2015

    Aaahh , Oct 2, 2015 :
    Yeah my app did,
    That's what the pause button was for

  6. DanDuke641
    Honeycomb Oct 2, 2015

    DanDuke641 , Oct 2, 2015 :
    I used it today on a vending machine. It was not a smooth process. It froze my phone, went through a soft reboot, froze again then after I forced a hard reboot it worked.
    So the answer must be to do a full reboot before purchasing and hope to be spared the embarrassment of it freezing up.

    I've no doubt part of the problem lies with the Cyanogen OS. I hope it gets resolved either way.

  7. mls2k3
    Cupcake Oct 2, 2015

    mls2k3 , Oct 2, 2015 :

  8. mls2k3
    Cupcake Oct 3, 2015

    mls2k3 , Oct 3, 2015 :
    Android pay also crashes my OPO when I tap it at a terminal. Locks up completely. OPO is stock. Never rooted. BTW the previous version of Google
    I am completely stock OPO with 12.1. Android Pay installs and allows me to set up cards. HOWEVER, it crashes on the Unlock screen when I pay at a terminal.

  9. mls2k3
    Cupcake Oct 3, 2015

    mls2k3 , Oct 3, 2015 :

    Has anyone considered OPO Android Pay issues are probably due to an OPO baked-in backdoor security hole? Another OPO crapware issue. It's now clear why the OP2 doesn't have NFC.
    Last edited: Oct 3, 2015

  10. jakemb21
    Donut Oct 3, 2015

    jakemb21 , Oct 3, 2015 :
    Thanks shirilover! I just switched from CM 12.1 Nightlies to COS 12.1 with TWRP (http://forum.xda-developers.com/oneplus-one/development/rom-cyanogen-os-12-1-t3186593) just so I could get Android Pay working on my Phone. After installing COS 12.1, I was able to add a credit card by disabling SuperSU. Have not tried it yet but it appears that I can re-enable SuperSU after adding my card.

  11. markdj
    Eclair Oct 3, 2015

    markdj , Oct 3, 2015 :
    I think the issues mentioned here with the phone rebooting is not a fault of the Android Pay app. It is the fault of the OS installed on the phone. I have just discovered a wifi bug with COS12.1 so it's not all a rosy picture, I sure hope Oxygen OS is supported and gets updates.

  12. littlemrbigglesworth
    Froyo Oct 4, 2015

    littlemrbigglesworth , Oct 4, 2015 :
    Thought I would share my Android Pay experience today... I have a rooted OPO with COS 12.1. I tested 2 configurations at Walgreens with 50% success. The first purchase was made with Superuser disabled in SuperSU and it work beautifully. I am using a Pebble Time as a trusted device so all I had to do was unlock the phone, tap from the home screen and select Credit at the terminal. Android Pay did not launch but the transaction went through (I was excepting for at least the app to open). My second attempt a couple hours later was at the same terminal and same setup except I had Superuser enabled. This time it failed with Card not supported error. Since I will be using Android Pay more than root for now I am ok leaving Superuser disabled but it would have been nice to have both.

  13. Dr. Indest
    Lollipop Oct 4, 2015

    Dr. Indest , Oct 4, 2015 :
    Simple, have a tasker task that disables SU when you open up Apple pay and then enable it when you close Apple Pay.

    @return.of.octobot may be able to help you with this ;)... Super easy app idea for your 2nd app pal :p.

  14. ouyamaster
    Honeycomb Oct 4, 2015

    ouyamaster , Oct 4, 2015 :
    Don't you mean android pay?
    I doubt there is a tasker app for an iPhone.
    But have no idea since I wouldn't touch an iPhone with ten foot pole.

  15. srgank
    Froyo Oct 9, 2015

    srgank , Oct 9, 2015 :
    I just flashed COS 12 and no root. I'm getting play services stop working each time I try to add a card. Anyone have the same issue?

  16. ikaritensi
    Cupcake Oct 9, 2015

  17. Jerome10
    Cupcake Oct 11, 2015

    Jerome10 , Oct 11, 2015 :
    I'm on official cm12.1 (I believe). I am a rookie at all this stuff but I did go to oxygen for a bit and now back to cm. Did a root check with an app, says I'm not rooted. No go on Android Pay for me either. Can't add the card. Just get a message it can't verify. So either it doesn't work or I'm rooted and don't realize it or the version of cm I'm using isn't the officially released version.

  18. Greg0410
    Ice Cream Sandwich Oct 11, 2015

    i5xswipe and Jporrata like this.
  19. blaw2
    Froyo Oct 12, 2015

    blaw2 , Oct 12, 2015 :
    Not sure if you caught the beginning part of this thread, but some of us had to change the screen density to the default 480DPI in order to add credit card. Can be found in Settings -> Display & Lights -> LCD Density.

  20. Spliffman
    KitKat Oct 13, 2015