Android Q Beta (Developer Preview) for OnePlus 6/6T

  1. rian.acca
    Cupcake May 7, 2019

  2. ZMansour
    Donut May 7, 2019

    Saumyata and NateDev like this.
  3. G_Flapjack47513
    Cupcake May 7, 2019

  4. NateDev
    Honeycomb May 7, 2019

    NateDev , May 7, 2019 :
    rollback worked fine for me

  5. NateDev
    Honeycomb May 7, 2019

    NateDev , May 7, 2019 :
    just flash the rollback zip in local update

  6. ironass
    Lollipop May 7, 2019

    Last edited: May 7, 2019

    N1555138133888 and Artemus like this.
  7. SferaDev
    Paranoid Android May 7, 2019

    SferaDev , May 7, 2019 :
    OnePlus 6 here. Installed Q Beta on top of latest Open Beta, install went fine, initial set-up went fine. Added PIN and fingerprint.

    After a reboot it leaves you in a decryption wizard asking me for the PIN but it doesn't work. Keeps telling the PIN is incorrect...

    After rebooting several times and attempting always with the correct PIN it tells me that after 9 more attempts the device will wipe everything. Instead of that I went through recovery and wiped userdata for myself.

    Now the phone seems to be working fine again but I thought this might be helpful for others who might face the same situation.

    EDIT: The problem seems to be an option called "Secure start-up" offered during the set-up wizard.

    Other issues found in OnePlus 6:

    - Set-up wizard Wireless Network needs to be added twice.

    - Set-up wizard complains about a system app crashing

    - Fingerprint does not work at all
    Last edited: May 7, 2019

  8. G_Joey_Townsend_XlLn
    Cupcake May 7, 2019

    G_Joey_Townsend_XlLn , May 7, 2019 :
    Not sure why but the MP rollback is working for me now...going to roll back and then local upgrade again back to BETA. Going to for sure wait next time and see what people say about the updates before trying them >.<

    Rebooted and now it will not start. Says build version and HW version not match. HELP

    N1555138133888 and NateDev like this.
  9. jlsmith929
    Cupcake May 7, 2019

    jlsmith929 , May 7, 2019 :
    did you do a wipe when flashing with twrp or did it do it for you I'm on a custom rom??

  10. Vladut123
    Honeycomb May 7, 2019

    ahmetkkn07 and Trevor.Hawkes like this.
  11. Ccrolls
    Cupcake May 8, 2019

    Ccrolls , May 8, 2019 :
    This was my experience. I had to reboot to recovery and do a full wipe.

  12. ryano891
    Honeycomb May 8, 2019

    ryano891 , May 8, 2019 :
    Now I'm curious if the roll back zip can be flashed in twrp?

  13. Mohin123
    Eclair May 8, 2019

  14. T1557270694434
    Cupcake May 8, 2019

  15. JeffGoldblum
    Cupcake May 8, 2019

    JeffGoldblum , May 8, 2019 :
    Is there a way to opt out? Downloading the full downgrade package doesn't show in the local upgrade menu, any help?

  16. Saliou
    Ice Cream Sandwich May 8, 2019

  17. ironass
    Lollipop May 8, 2019

    ironass , May 8, 2019 :
    The roll-back package needs to be moved to the root directory... in other words, not in a folder, before Local Upgrade can see it.

  18. D1541077305487
    Cupcake May 8, 2019

    D1541077305487 , May 8, 2019 :
    I am having the same issue. I have tried everything, but am unable to get back Pie. No local upgrade found, even though it is in the root file.

    Saumyata likes this.
  19. MichAssel92
    Gingerbread May 8, 2019

  20. JeffGoldblum
    Cupcake May 8, 2019

    JeffGoldblum , May 8, 2019 :
    Tried this several times but no luck.

    D1541077305487 likes this.