6
OxygenOS Android system "This App is using GPS" Maps

  1. shennessy
    Eclair Jun 27, 2017

    shennessy , Jun 27, 2017 :
    Is anybody else getting this constant notification when using maps? It's pretty strange and don't think it's necessary?
     

    Attached Files:


    #1
  2. munish
    Froyo Jun 27, 2017


    #2
    Jon Conley likes this.
  3. fabianintveld
    Cupcake Jun 27, 2017


    #3
  4. shennessy
    Eclair Jun 28, 2017

    shennessy , Jun 28, 2017 :
    I agree, it's completely unnecessary!
     

    #4
  5. Teerbaby
    Cupcake Jun 29, 2017


    #5
    Jon Conley likes this.
  6. G_Matt_Klein_usWa
    Cupcake Jun 29, 2017

    G_Matt_Klein_usWa , Jun 29, 2017 :
    Ditto. Actually, I've seen it for other apps as well...not just maps. Strava and Endomondo were giving me the same 'reminder'.
     

    #6
    Jon Conley likes this.
  7. shennessy
    Eclair Jun 29, 2017

    shennessy , Jun 29, 2017 :
    I submitted a ticket and I encourage all you to do the same to get some more eyes on it. They originally told me to block ALL Android system notifications which is crazy. Maybe if enough of us can send in tickets, they'll make it a priority.

    ------------------------------------------------------------------------------------------------------------------------------------

    Thank you for contacting OnePlus. This is ____ your Customer Support and I'll be glad to assist you with your concern today.

    I understand that you want to remove this notification whenever you use Maps or GPS. In order for us to resolve this issue, I would appreciate if you can follow the steps below:

    1. Press and hold "This App is using GPS", then options will pop up.
    2. Select "More Settings".
    3. Select "Block All Notification"
    This should remove the "This App is using GPS" notification. Please do let me know if this resolves your issue.

    Have a great day!
     

    #7
    Jon Conley likes this.
  8. Coolfire
    Donut Jun 29, 2017


    #8
    Jon Conley likes this.
  9. G_Urmas_Raavik_(soomaala
    Cupcake Jul 21, 2017


    #9
    Jon Conley likes this.
  10. Crystal Z.
    Global Community <3 Staff Member Jul 21, 2017

    Crystal Z. , Jul 21, 2017 :
    Hi, all

    Sorry to hear that.
    Just confirmed with the dev team, they claim this notification is not a bug or something, it's set to remind you that GPS is running in the back stage and it's draining battery.
    And currently there is no method to turn it off.

    Appreciate your understanding.

    Best regards,
    OnePlus Bug Hunters
     

    #10
    Twisster and LuisGi like this.
  11. Jon Conley
    Froyo Aug 1, 2017

    Jon Conley , Aug 1, 2017 :
    That's unfortunate.

    However, it likely is a bug that we can't block the notifications at all. I've set my preferences to always block Android System Notifications, and yet, the persistent notification remains pinned while Google Maps is running.
     

    #11
  12. anandsiddharth
    Gingerbread Aug 1, 2017

    anandsiddharth , Aug 1, 2017 :
    Also happens with the keyboard for me. As soon as I begin typing , the keyboard icon pops up on the top left corner of the screen.
     

    #12
  13. finpazuzu
    Cupcake Sep 7, 2017

    finpazuzu , Sep 7, 2017 :
    blocking all system notifications doesn't work for me either. I play a lot of ingress, so the ridiculous notification is bugging me every day. there must be something that can be done about this issue.
     

    #13
  14. coraphise
    Eclair Oct 4, 2017

    coraphise , Oct 4, 2017 :
    I've seen this before, but been able to swipe it away. Or, after selecting it and backing out, it was gone because the notification was addressed.

    Now it's persistent...

    This goes along with other complaints for me
    1) Ringtone and notification volume can't natively be split in OxygenOS
    2) Dual-SIM isn't working on OP2 (not tested on 3T or 5) anymore

    I guess I'll send in a ticket or three?
     

    #14
    rickd88 likes this.
  15. rickd88
    Eclair Jan 27, 2018

    rickd88 , Jan 27, 2018 :
    I'm guessing no progress on getting this fixed.
    Sucks! I'm gonna have to flash something instead of this. This dives me nuts.
     

    #15
  16. kspatil
    Froyo Jan 27, 2018

    kspatil , Jan 27, 2018 :
    If you do not want to give location access to certain , it can be turned off in apps setting.
     

    #16
  17. pandabat
    Froyo May 17, 2018

    pandabat , May 17, 2018 :
    It does seem that you can work around it (alternative approach here: https://www.reddit.com/r/AndroidQue...id_7_how_to_disable_the_these_apps_are_using/ ) :

    1) Trigger the notification by opening, say, Google Maps

    2) Swipe down from the top and hold down on the notification. This should expand the notification and you should see an "All categories" option - click on this!

    3) Scroll down the "Android system" notifications list, find GPS and tap on it. This should open the GPS-specific screen

    4) Tap on Importance and reduce it from "High" to either "Medium" or "Low"

    5) Exit out of the settings screens and try Google Maps again. You should have no annoying sound now
     
    Last edited: May 17, 2018

    #17
    jasonf1984 likes this.
  18. pandabat
    Froyo May 17, 2018

    pandabat , May 17, 2018 :
    It does seem that you can work around it (in Oreo at least - other method here: https://www.reddit.com/r/AndroidQue...id_7_how_to_disable_the_these_apps_are_using/ ):

    1) Trigger the notification by opening, say, Google Maps

    2) Swipe down from the top and hold down on the notification. This should expand the notification and you should see an "All categories" option - click on this!

    3) Scroll down the "Android system" notifications list, find GPS and tap on it. This should open the GPS-specific screen

    4) Tap on Importance and reduce it from "High" to "Medium" or "Low"

    5) Exit out of the settings screens and try Google Maps again. You should have no annoying sound now
     

    #18
  19. Gav_W86
    Moderator Moderator May 17, 2018

    Gav_W86 , May 17, 2018 :
    Believe Google have finally accepted it is annoying and is getting rid of it in P.
     

    #19
  20. G_Mr_....
    Jelly Bean May 17, 2018

    G_Mr_.... , May 17, 2018 :
    Or maybe try turning location services to battery saver mode not high accuracy if that's the settings you have active.
     

    #20