0
Android Wear 2.0 updates and janky Bluetooth

  1. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    I have two Wear 2.0 devices, second gen Moto 360 and a Fossil Q Marshal. Since taking the 2.0 updates both devices disconnect and throw up a device pairing notification at least once a day sometimes more. I then have to re-pair the devices. Super annoying. This doesn't happen on my first gen Moto 360 and didn't happen on the other devices until the 2.0 update. Bluetooth has been super janky on this thing since day one. Skipping music streaming, random disconnects and re-pairing. Oh yeah and wifi is weak on this thing too Anyone have any suggestions or should I go ahead and RMA this thing?
     

    #1
  2. Iuliskaya
    Ice Cream Sandwich Jun 27, 2017


    #2
    flappjaxxx likes this.
  3. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    Forgot to mention I'm running the latest open beta but this issue occurs on latest stable and beta
     

    #3
  4. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    I have an Honor 5x that this doesn't happen on.
     

    #4
  5. Bartnl
    Lollipop Jun 27, 2017

    Bartnl , Jun 27, 2017 :
    Got a Huawei watch with AW 2.0 and it works perfectly with my 3T with Open beta 9.
    As it did not happen before the update to 2.0, why pointing the finger directly too OP?
     

    #5
  6. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    I wasn't pointing a finger, but it doesn't happen with my Honor 5x only the 3t.
     

    #6
  7. F_Diganta_Koner_WIXu
    Jelly Bean Jun 27, 2017


    #7
  8. Iuliskaya
    Ice Cream Sandwich Jun 27, 2017

    Iuliskaya , Jun 27, 2017 :
    Wrong place buddy.
     

    #8
  9. vcartera
    Gingerbread Jun 27, 2017

    vcartera , Jun 27, 2017 :
    I can confirm same bug on my LG G Watch Urbane... sometimes it ask for pairing (Android Wear 2.0)
     

    #9
    flappjaxxx likes this.
  10. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    I have uninstalled and reinstalled the Wear app, updated everything on the phone and watches. if it happened on one watch and not the other I would assume it was the watch, but since it happens on two watches from two manufacturers, it makes me believe this is a hardware or software issue on the 3T. I've reset both devices more than once and paired them fresh and they typically will work without issue for a day or sometimes more then randomly start the whole disconnection and re-pairing process. I've reset my phone as well more than once. None of my watches did this until the 2.0 update and since then both of them do it. my first gen Moto 360 works fine
     

    #10
  11. Iuliskaya
    Ice Cream Sandwich Jun 27, 2017


    #11
  12. Iuliskaya
    Ice Cream Sandwich Jun 27, 2017

    Iuliskaya , Jun 27, 2017 :
    Probably there's a bug in the watches os? From what you say, the phone nor the watches have any hardware problems.
     

    #12
  13. flappjaxxx
    Froyo Jun 27, 2017

    flappjaxxx , Jun 27, 2017 :
    that's not a Wear 2.0 device though correct?
     

    #13
  14. Iuliskaya
    Ice Cream Sandwich Jun 27, 2017

    Iuliskaya , Jun 27, 2017 :
    Nope, it's just a band [e]1f602[/e]
     

    #14
  15. Phil_Holcroft_
    Cupcake Jun 27, 2017


    #15
  16. Chien93
    Jelly Bean Jun 27, 2017

    Chien93 , Jun 27, 2017 :
    I have OnePlus3 beta and moto 360 2.

    On Android Wear 1 don't have issue. Since Android Wear 2, i have this issue too.
     

    #16
  17. flappjaxxx
    Froyo Jun 28, 2017

    flappjaxxx , Jun 28, 2017 :
    I've put in a support ticket with OnePlus. we shall see what happens next. like I said in the OP, Bluetooth has been wonky since day one. some devices like my car, I have no issues
     

    #17
  18. parasietje
    Cupcake Sep 1, 2017


    #18
  19. VaibhavBhargava
    Lollipop Sep 1, 2017

    VaibhavBhargava , Sep 1, 2017 :
    The new update seems to be having some issues (for some of the people) with bluetooth (pairing part), have you tried pairing your device with any other bluetooth enabled device ?
     

    #19
  20. GraphRacer
    Cupcake Sep 18, 2017

    GraphRacer , Sep 18, 2017 :
    any update? Same issue with a Polar M600 Smartwatch since Android Wear 2.0 (note: I'm on a OnePlus One; worked flawlessly with Android Wear 1.x)
     

    #20