2
OxygenOS Animation Microstuttering

  1. AshenPaladin
    Froyo Mar 13, 2019

    AshenPaladin , Mar 13, 2019 :
    OnePlus 6
    256 GB ROM and 8 GB RAM
    A6003
    OOS 9.0.4.

    For the past two software versions, I've been running into an issue related to the animations. Simply put, from time to time, rather randomly, the animations seem to stutter or the drop frames. I see it in different parts of the UI, but it is generally the most visible in the animation that appears when you press home key and go to the launcher from an app.

    I went through multiple factory resets, and I even downgraded to Oreo once. The issue is most certainly not present on Oreo and it wasn't present on the first few Pie versions either. I doubt that it's from a third party app, since I specifically used my phone with only the default apps for a day and the issue still persisted. It's extremely difficult to pinpoint an exact reason however, as these stutters are extremely random. The phone tends to act perfectly at the beginning right after the setup though (I always do clean setups, no backups involved, no restoring previous apps), but once the updates for the preinstalled apps are done, at some point it just starts.

    The issue seems to be somehow related to the launcher - it's the only default app I've ever had any issues with (two crashes), and clearing the default launcher's cache seems to improve the situation for a while. Smart boost is also weird - disabling it on 9.0.4. seems to help, while on the latest beta, which I've tried for a while, it seems to be the opposite - the stutters are less frequent with it enabled.

    I know that there are many poorly written and annoying bug reports here, and I don't want to waste anyone's time, but I do really want to at least know whether this is a known issue or whether I'm going insane. Some people have reported it on Reddit, on both the 6 and the 6T but I couldn't find any such reports here.
    If the issue persists I will eventually try to contact support directly. Yes, it's not exactly a deal breaking issue, but one of the reasons for why I bought this phone was that I was sick of Samsung and their laggy software. I enjoyed Oxygen OS's smoothness for more than half a year, but it's just becoming frustrating.

    Thank you very much in advance for any help.
     

    #1
    X1515283729060 and BruntaX like this.
  2. BruntaX
    Cupcake Mar 27, 2019

    BruntaX , Mar 27, 2019 :
    Hello!
    Recently purchased a Oneplus 6 6/64, and I have the same problems. There are always some stutters, framerate drops especially when opening the application menu (swipe up from the bottom). When I rolled back to Anroid 8.1, I noticed that everything is very smooth. I dont know what to do, very annoying.
     

    #2
  3. AshenPaladin
    Froyo Mar 28, 2019

    AshenPaladin , Mar 28, 2019 :
    I'm not sure what the issue is honestly. It seems to be related to the launcher and to RAM management somehow, at least that's what some of us who were discussing it on Reddit concluded.
    It is annoying, but hopefully it will get fixed. The situation was better in the previous Open Beta, 14 I think, and I can only assume that it got better in OB 15 or that it will get fixed until the next stable update.
    Until them, turning smart boost off and clearing the cache of the launcher app seems to help sometimes, as does trying a different launcher.
     

    #3