0
[answered/closed] Ok Google not working via OnePlus 7 Pro

Thread Status:
Not open for further replies.
  1. G_Roepnaam_Achternaam_rr , via OnePlus 7 Pro , Feb 20, 2020 :
    Hello!

    I've been using my OP7PRO for about a few months now but I still can't get the ok Google command to work!
    I've basically tried every possible solution I could find;

    -Deleting Google and reinstalling it
    -Rebooting phone
    -Turn Google assistent off and on

    Yet it still doesn't work...
    I don't have any notification apps either.
    It'll only work when I'm in Google itself or when I just got out of the Google App.
    When I'm on my homepage or any other app it won't work.
    I find this to be extremely annoying since I'm trying to get it to work for 3 nights in a row. When I try to use voice match it wants to look for any other devices on my wifi, it doesn't show me an option for me to let Google recognize my voice.
    If anyone has a (possible) solution, please let me know! (screenshot of voice match page included, it is in dutch though)

    Thank you!
    1582241468745.jpg
     

    #1
  2. GeekOnTheHill
    Honeycomb Feb 20, 2020

    GeekOnTheHill , Feb 20, 2020 :
    Please check the permissions for the Google App.

    Also, in "Settings -> Google -> Account Services -> Search, Assistant & Voice" you'll find settings for Google Assistant and Voice. Poke around in those to make sure the needed services are enabled. They're pretty obvious.

    Richard
     

    #2
  3. G_Roepnaam_Achternaam_rr , via OnePlus 7 Pro Nebula Blue , Feb 20, 2020 :
    Thank you for responding, I've enabled and disabled and then enabled all the required fields for the assistent to work, but still nothing. My friend who also has the OP7PRO can't seem to get it to work either... Do you think it could be a national problem with the OP phones? Used to have the same problem on my 3T.
     

    #3
    O1562019771164 likes this.
  4. GeekOnTheHill
    Honeycomb Feb 20, 2020

    GeekOnTheHill , Feb 20, 2020 :
    I'm afraid I don't know. I think it's unlikely because that's a Google feature, not a OnePlus feature; and I seriously doubt that President Trump has placed the Netherlands on any naughty lists.

    You have to have the Assistant enabled in your Google account AND on the device, from what I recall (I personally don't use digital assistants). Do you have any other devices on your Google account (old phones, for example)?

    Richard
     

    #4
  5. G_Roepnaam_Achternaam_rr , via OnePlus 7 Pro Nebula Blue , Feb 21, 2020 :
    Trump is very unpredictable so who knows lol.

    But yes, I do have like 2/3 phones with the same Google account registered, could that be the source of the problem? How?
     

    #5
  6. GeekOnTheHill
    Honeycomb Feb 21, 2020

    GeekOnTheHill , Feb 21, 2020 :
    Just a guess because I don't use the feature, but *maybe* one of the other devices has bad settings. I *think* the Assistant setting is account-wide plus device-selected. Checking the account settings in the other devices (or deleting them if they're no longer in use) is probably worth a try.

    I'm guessing because this is not one of my stronger points. But sometimes two guesses are better than one, and no one else has chimed in yet.

    Richard
     

    #6
  7. Shehan vihanga
    Eclair Feb 24, 2020

    Shehan vihanga , Feb 24, 2020 :
    if you have any 3rd party notification apps or notification led apps uninstall them (notify buddy)

    worked for me, hope it does same to you all
     

    #7
    keithnyc and Manoj_kumar_Arka like this.
  8. Manoj_kumar_Arka
    Cupcake Mar 30, 2020 at 11:12 PM

    Manoj_kumar_Arka , Mar 30, 2020 at 11:12 PM :


    Shehan vihanga

    if you have any 3rd party notification apps or notification led apps uninstall them (notify buddy)

    worked for me, hope it does same to you all​


    Yes... it is working now after uninstalling" notify buddy".. thank you so much bro
     

    #8
    Shehan vihanga and keithnyc like this.
  9. keithnyc
    Marshmallow Moderator Mar 30, 2020 at 11:15 PM


    #9
    Shehan vihanga likes this.