0
Any solution yet for the Slow Wi-Fi issue?

  1. Dougal1709
    Cupcake Dec 9, 2014

    Dougal1709 , Dec 9, 2014 :
    I got my OPO about a week ago. Seems nice enough but the Wi-Fi issue is really making me think about selling it and buying something else.

    I've tried all the performance tweaks and the advanced wi-fi settings tweaks and still the Wi-Fi speeds are significantly slower and less reliable than my Galaxy Note 2 unless I am standing about 2 inches away form the router.

    I have tried a Note 2, Galaxy Tab S, Nexus 7 and the OPO all in different spots throughout the house and the OPO is the only one that suffers from much lower speeds the further I stand from the router.

    I am wondering

    1) Have we ascertained yet whether this is a software issue or a hardware issue?
    2) Have OnePlus accepted that it is an issue at all yet?
    3) Is this a general problem or do I simply have a duff device that needs replacing?

    I don't know whether to keep the OPO and wait for an update or just go back to my Note 2 and wait until another phone is released that I like the look of.
     

    #1
  2. Jonas
    Ice Cream Sandwich Dec 9, 2014

    Jonas , Dec 9, 2014 :
    Slow wifi issue?

    515.png

    And this is not the max..
    I've reached more than 7 MB/s
     

    #2
  3. kartik666
    Ice Cream Sandwich Dec 9, 2014

    kartik666 , Dec 9, 2014 :
    Seriously? My 1+1 actually picks up signals from dead spots which even my ipad and laptop aren't able to do. And getting max speeds as well.
    Check your router and phone settings.
     

    #3
    LsltheMenace and cedelutis like this.
  4. lassmat
    Jelly Bean Dec 9, 2014

    lassmat , Dec 9, 2014 :
    This issues has been raised before. I wonder how it will perform if the router is one floor up and am down downstairs about 4 meters away? Of course, there is a concrete wall and a wooden floor separing us.
     

    #4
  5. The Earl of Twatshire
    KitKat Dec 9, 2014

    The Earl of Twatshire , Dec 9, 2014 :
    Slow Wifi Sir?

    I would suggest the application of grease or WD40. This solves 99.5% of all of my speed issues.

    Especially the WD40, the fumes from that wonderful concoction sometimes rend me so senseless the original problem I was trying to solve no longer matters.

    I thank you
     

    #5
  6. Dougal1709
    Cupcake Dec 9, 2014

    Dougal1709 , Dec 9, 2014 :
    What settings should I check? The router works fine with all my other devices.

    So far I Unchecked Enable per-app profiles and Unchecked wi-fi optimisation but the phone is still much slower than all the other devices.
     

    #6
  7. gauravrathore9999
    Cupcake Dec 13, 2014

    gauravrathore9999 , Dec 13, 2014 :
    I am also facing the same problem of slow wifi in my One, kindly someone suggest some solution to it!
    #frustrated
     

    #7
  8. nafiahmed
    Cupcake Jan 16, 2015


    #8
  9. bmaz121
    Froyo Jan 16, 2015

    bmaz121 , Jan 16, 2015 :
    OK, try this, it may not be the phone. Routers are tweeky boxes and you gotta have them set up right. First go into the Router advanced setup and click administration then logs. The logs will display and the date and time the router is set too. Be sure the date and time is correct. A wrong date will mess with the connect to the 1+1. Be sure if you have 2 routers in the house that the channels are at least 6 channels apart. Next, check the type of security you are using and the phone security matches the routers PSK - AES, wep etc. I use PSK - AES. Next, check this. WIFI pirates are everywhere. Your neighbor may be stealing your WIFI. How to check is to, once in a while, go into the routers basic settings and select Attached devices. Another good trick is to turn off the wifi at the router when your not home and at night before bed. The reason for this is a pirate will stop using your wifi if it is not always on. And Last but not all is to use 5GHz instead of 2.4 if you don't have that, eBay has routers, Netgear, 3700v2 or 6300 used, is good for 30 - 50$ and work great.
     

    #9
    LsltheMenace likes this.
  10. bmaz121
    Froyo Jan 16, 2015

    bmaz121 , Jan 16, 2015 :
    Takes me back to the movie "The Thing" where the guy says "you gotta be kidding me".
     

    #10
    The Earl of Twatshire likes this.
  11. J.Pinkman
    Jelly Bean Jan 16, 2015


    #11
  12. The Earl of Twatshire
    KitKat Jan 16, 2015

    The Earl of Twatshire , Jan 16, 2015 :
    Indeed sir, originality is not my strong suit.

    Quite.
     

    #12
  13. bmaz121
    Froyo Jan 16, 2015

    bmaz121 , Jan 16, 2015 :
    Missed one possible note. I hope you all realize that the download speed from any one server depends on a lot of things other than you WIFI and device. Some servers you are downloading from may be busy or have a lot of routes to take or may just be a slow server. Verify by connecting to other servers to see the difference. You probably already knew that but it's worth mentioning because some people just don't know.
     

    #13
  14. Jamesst20
    Jelly Bean Jan 16, 2015

    Jamesst20 , Jan 16, 2015 :
    Flash CM12 nightlies and problem solved. As soon as I go back to XNPH44S I have tose issues again
     

    #14
  15. sbfisher
    Eclair Jan 16, 2015

    sbfisher , Jan 16, 2015 :
    I'm running liquidsmooth lollipop ROM and my OPO is stable and just as fast or faster than my other WiFi devices.
     

    #15
  16. bmaz121
    Froyo Jan 16, 2015

    bmaz121 , Jan 16, 2015 :
    Just fixed a weird problem I had with MMS. Maybe that issue is with your phone too. Reboot into recovery and wipe the Dalvik cache and reboot. Fixed my problem.
     

    #16
  17. hahaha2223
    Jelly Bean Jan 16, 2015


    #17
  18. OW3N111
    Jelly Bean Jan 16, 2015

    OW3N111 , Jan 16, 2015 :
    I think it's a 5ghz WiFi issue, my 2.4 gets good signal range an speed. If I switch to 5ghz then I get like 2 bar WiFi in the same room as the router, however the speeds are still great. Just the range for some reason
     

    #18
  19. Jamesst20
    Jelly Bean Jan 16, 2015

    Jamesst20 , Jan 16, 2015 :
    It's not a 5GHz issue sorry :/
     

    #19
  20. OW3N111
    Jelly Bean Jan 16, 2015

    OW3N111 , Jan 16, 2015 :
    Argh OK is it the same on all different WiFi or you only tested from one router??

    Someone one your street could be using same band as you all of a sudden messing with stuff
     

    #20