6
APN Problem N10 5G

  1. ggenglish
    Cupcake Jan 19, 2021

    ggenglish , Jan 19, 2021 :
    Sure, I will start by saying that I did originally try adding the 'sp.telus.com' manually as written on my other phone but it didn't work. So I'm guessing some of the values from jamesmack's screenshots are key.

    I did do the system update after getting the phone so my build is:
    10.5.9.BE86AA

    Suggested steps
    1. Go 'Settings' > 'Wi-Fi & network' > 'SIM & network'.
    2. Use tool to pop sim card tray out.
    3. Stay on 'SIM & network settings' as you need to next step fast.
    4. Push sim card tray back in.
    5. 'SIM & network settings' will become enabled again and immediately select 'Access Point Names'.
    6. The 'isp.telus.com' entry doesn't even show yet but you will see a '+' sign and be able to use it.
    7. As per jamesmack's screenshots use the following entries:
      1. Name: TELUS
      2. APN: sp.telus.com
      3. MMSC: http://aliasredirect.net/proxy/mmsc
      4. MMS proxy: 74.49.0.18
      5. MMS port: 80
      6. MCC: 302
      7. MNC: 220
      8. APN type: default,mms,supl
      9. APN protocol: IPv4 (Screenshot says both prots but I left as IPv4)
      10. APN roaming protocol: Not set (I don't want roaming so I left this unset)
      11. MVNO type: GID
      12. MVNO: 54
    8. Hit 3 dots on upper right and hit 'SAVE'. (Don't hit back or you lose what you did and won't get the + again)
    Your new entry should immediately have a radio button and be selected. 4G or whatever region you are in should take affect if you have wifi off.

    Probably the key elements are the APN type and the MVNO as mentioned in the screenshots. These are different from my old 5T phone's entries so must be special.

    Good luck all!

    https://pasteboard.co/JKoGnhD.png
    https://pasteboard.co/JKoGVF7.png
    https://pasteboard.co/JKoHgQG.png
     
    Last edited: Jan 19, 2021

    #41
  2. jamesmack
    Eclair Jan 19, 2021

    jamesmack , Jan 19, 2021 :
    I can confirm this works for me as well! I inputted the settings as provided by OnePlus. The APN would not save unless the MVNO was set to GID.

    1. Go 'Settings' > 'Wi-Fi & network' > 'SIM & network'
    2. Use tool to pop sim card tray out
    3. Stay on 'SIM & network settings' as you need to next step fast
    4. Push sim card tray back in
    5. 'SIM & network settings' will become enabled again and immediately select 'Access Point Names'
    6. The 'isp.telus.com' entry doesn't even show yet but you will see a '+' sign and be able to use it
    7. Use the following entries:
      1. Name: TELUS
      2. APN: sp.telus.com
      3. MMSC: http://aliasredirect.net/proxy/mmsc
      4. MMS proxy: 74.49.0.18
      5. MMS port: 80
      6. MCC: 302
      7. MNC: 220
      8. APN type: default,mms,supl
      9. APN protocol: IPv4/IPv6
      10. APN roaming protocol: IPv4/IPv6
      11. MVNO type: GID
      12. MVNO: 54
    8. Hit 3 dots on up left and hit 'SAVE'. (Don't hit back or you lose what you did and won't get the + again)
     

    #42
  3. drep4521
    Cupcake Jan 19, 2021

    drep4521 , Jan 19, 2021 :
    Ggenglish and jamessmack... Thanks! Absolute legends. Worked flawlessly for me.
     

    #43
    iamWarder and jamesmack like this.
  4. jamesmack
    Eclair Jan 19, 2021

  5. KinseySS
    Cupcake Jan 19, 2021

    KinseySS , Jan 19, 2021 :
    Doesn't let me save a new APN even after letting me input a new one

    I get this error

    "carrier does not allow adding apns of type *."
     
    Last edited: Jan 19, 2021

    #45
  6. jamesmack
    Eclair Jan 19, 2021

    jamesmack , via OnePlus Nord N10 5G , Jan 19, 2021 :
    I initially got that error as well. Keep trying those steps very carefully.. and make sure you've set the MVNO.
     

    #46
    scrawl likes this.
  7. iamWarder
    Froyo Jan 20, 2021

    iamWarder , Jan 20, 2021 :
    What worked for me was making the APN default,supl,mms try in that order rather than default,mms,supl
     

    #47
    scrawl likes this.
  8. scrawl
    Froyo Jan 20, 2021


    #48
  9. KinseySS
    Cupcake Jan 20, 2021

    KinseySS , Jan 20, 2021 :
    1611107424998.jpg
    1611107424977.jpg said:
    1611107424952.jpg
    I've been doing every settings listed by everyone including Telus official settings and others from other sites and I'm getting no success. Its honestly quite frustrating. and I hate the OP solution is wait a month for MAYBE a patch ... its very dismissive to the issue.
     

    #49
  10. scrawl
    Froyo Jan 20, 2021

    scrawl , Jan 20, 2021 :
    One other user reported that they had success by setting the APN type to default, supl, mms . That's what I used as well, and it worked. As for the rest of the settings, they appear to be the same as mine.
     

    #50
  11. KinseySS
    Cupcake Jan 20, 2021

    KinseySS , Jan 20, 2021 :
    still didn't work :(
     

    #51
  12. scrawl
    Froyo Jan 20, 2021

    scrawl , Jan 20, 2021 :
    I suppose the only thing left is to try with OP support. You could reference this thread, and the article within it, and perhaps they could suggest an alternate set of settings. Telus support might also be able to help with that, now that we at least can get to the point of adding new APNs.

    But yeah, it would be better if the thing just worked like it does for other carriers. I don't mind telling you that I was pretty frustrated when I got the new phone.
     

    #52
    G_hitham_Melhim_xzWj likes this.
  13. G_hitham_Melhim_xzWj , via OnePlus Nord N10 5G , Jan 21, 2021 :
    Thank you for the nice explanation.
    Could it be via video?
    Everyone's going to be happy about that.
     

    #53
  14. KinseySS
    Cupcake Jan 22, 2021


    #54
  15. jamesmack
    Eclair Jan 22, 2021

    Last edited: Jan 22, 2021

    #55
  16. Marian Hyjek
    Cupcake Jan 23, 2021

    Marian Hyjek , Jan 23, 2021 :
    No taping will help is all gray no editable, I had the same issue and we will have to wait till mid February for fix, I sent mine two phones back Maian
     

    #56
  17. Marian Hyjek
    Cupcake Jan 23, 2021

    Marian Hyjek , Jan 23, 2021 :
    was that Jan 12 update?,they told me it is not till February
     

    #57
  18. Marian Hyjek
    Cupcake Jan 23, 2021

    Marian Hyjek , Jan 23, 2021 :
    OnePlus seams to have a problem with Telus, I had the same problem and it should be fine in February.
     

    #58
  19. veritasaequita
    Cupcake Jan 25, 2021

    Attached Files:

    Last edited: Jan 25, 2021

    #59
  20. iamWarder
    Froyo Jan 26, 2021


    #60