Apple Airpods connection issue

  1. cassis87
    Cupcake Feb 9, 2017

    cassis87 , Feb 9, 2017 :

    I just received my OnePlus 3T yesterday and am really happy about it... great phone and great handling.

    There is just one thing that bug me is that when I connect my Apple bluetooth Airpods headset, it connects but there is no sound... i can pause the music (or podcast) and start it again so the controls are working but sound is not passing through.
    I managed to get the sound once after deactivating/reactivating the bluetooth but other than that when connecting the headset, no sound is coming.

    I have tried the Airpods with other android 7.0 phones such as the Xperia X compact or more recently with the Google Pixel and never had any issue...

    Does anyone know why would specificaly the OP3T would have any issue ?

    Thank you,

    vinhtranx likes this.
  2. iNtEnSePL
    KitKat Feb 9, 2017

  3. din100
    Gingerbread Feb 9, 2017

  4. cassis87
    Cupcake Feb 9, 2017

    cassis87 , Feb 9, 2017 :
    Strange that only the one+ would have issues though.... If someone from 1+ could confirm... Thank you.

  5. cassis87
    Cupcake Feb 9, 2017

    cassis87 , Feb 9, 2017 :
    Anyone from OnePlus could assist ? Can't understand why the oneplus phones would be the only android phones not to fully work with the Airpods...
    Thank you

  6. vrubel
    Cupcake Feb 28, 2017

    vrubel , Feb 28, 2017 :
    Just to add a bit more detail to this, I also experience an issue with AirPods connection. I can consistently reproduce the issue i'm experiencing using following steps:
    1. Pair AirPods to OnePlus 3T - no issue pairing and on the first connection everything works fine including the sound
    2. Put AirPods back in their case, this will disconnect them from the phone. Note I keep the Bluetooth always "On" on the phone.
    3. Take AirPods out of their case. They connect right the way, and I get a sound notification on the AirPods signifying the connection to the phone. At this point the phone shows headphones as connected, and Bluetooth sounds device is available to stream sound to; unfortunately even though both the AirPods and the phone recognize and connected to each other, no sounds is produced.
    4. To resolve the issue I need to turn off Bluetooth on the phone and turn it back on, this forces the devices to reconnect and this time everything works including the sound.
    5. This happens every time.
    So in short it seems that a Bluetooth needs to be reset each time the AirPods are disconnected from the phone.

    Love the phone, changed from an iPhone, but wish I can still use my AirPods with the same ease as on the iPhone.

    NAVEEN_RS and SidelingJam3 like this.
  7. geo07
    Ice Cream Sandwich Feb 28, 2017

    geo07 , Feb 28, 2017 :
    I have the airpods since I also own a 7 plus and one op3 for my work. I can tell you that the airpods it's a bit of hit and miss in op3 and other Android phones I tried them with. It's awkward though that the beats x (that also have the w1 chip) work well with the op3...

    insomniachou likes this.
  8. stevenswall
    Honeycomb Feb 28, 2017

    stevenswall , Feb 28, 2017 :
    Unfortunately, I doubt that Apple is following the Bluetooth spec with the airpods, and they may never be fully compatible with any other devices. Going forward, Any other brand should work with the OnePlus 3T, and there are some headphones that have NFC for easy pairing. Stinks that the tiny airpods aren't working though.

  9. vrubel
    Cupcake Feb 28, 2017

    vrubel , Feb 28, 2017 :
    I looked trough some other threads here and it seems that the issue is not just with the Airpods. Some people report the same issue with Bose and Jaybird headphones.

  10. Robert_Trance_Varga
    Gingerbread Mar 1, 2017

  11. vinhtranx
    Cupcake Mar 1, 2017

    vinhtranx , Mar 1, 2017 :
    Same issue with the Apple BeatsX. Good to know it's not just me. I thought I had a defective unit.

  12. swein1992
    Cupcake Mar 12, 2017

  13. jarieljimenez
    Froyo Mar 12, 2017

    valkTANK likes this.
  14. insomniachou
    Honeycomb Mar 12, 2017

  15. Dunnow
    The Lab - OnePlus 6 Reviewer Mar 12, 2017

  16. malidan
    Marshmallow Mar 12, 2017

    Dunnow likes this.
  17. malidan
    Marshmallow Mar 12, 2017

    malidan , Mar 12, 2017 :
    Also with numerous Vehicles bro, this is a long standing issue with all OP devices.

  18. Dunnow
    The Lab - OnePlus 6 Reviewer Mar 12, 2017

    Dunnow , Mar 12, 2017 :
    There, I fixed it for you.

    remedy and malidan like this.
  19. elanglois
    Lollipop Mar 13, 2017

    elanglois , Mar 13, 2017 :
    file a bug report on this. it sounds a lot like the MTP weirdness where it doesn't save the USB configuration. I think its something in the init scripts.

    remedy likes this.
  20. SidelingJam3
    Cupcake Mar 20, 2017

    SidelingJam3 , Mar 20, 2017 :
    A few more details I've found with my OP3T and AirPods.

    After taking the APs out of the case and automatically reconnecting with the OP3T, the following are true:

    Audio works in the following apps:
    - Phone

    Audio does not work in the following apps:
    - Google Play Music
    - Default Music App (OOS)
    - Sony Voice Recorder
    - Allo
    (probably any other non-system-telephony app)

    - Toggle BT on the OP3T
    - Disconnect and reconnect the APs in the BT menu
    - Toggle "Media audio" in the APs' "Paired devices" settings
    - Reboot OP3T

    I'm hoping this issue is fixed in the latest OTA OOS (Android 7.1.1), but if it's not I'll probably flash Lineage.