2
OxygenOS Background processes killer is WAAAAY too aggressive

  1. vteruni
    Cupcake Oct 9, 2018

    vteruni , Oct 9, 2018 :
    Ive been having this issue since i first got the phone and its been a bit of an inconvenience at first but now its driving me crazy. I'm ready to throw this ******* thing out the window.
    I've recently started using Adguard because im sick and tired of all the ads all over my phone but this damn thing keeps killing the process if i leave the phone sitting for bit and even WHILE IM IN THE MIDDLE OF BROWSING THE WEB. I don't know whose in charge of process management on the OP team but this is unacceptable. There are threads about this that are 3 YEARS OLD. WAKE UP ONEPLUS.
    I don't want my phone to clear adguard, i dont want my pandora app to be cleared from my recents when i stop to fill up gas, i dont wan't my phone to turn off my youtube app and force me to find the video i was watching because i got a MOTHERF***ING PHONE CALL.
    I've tried everything i could think of to fix this. I turned off battery optimization, i turned off the background process limit, i used the little lock icon in the recent apps. None of it is working. The phone keeps turning off whatever it wants whenever it feels like it.

    FIX THIS SHIT OR GIVE US THE OPTION TO DISABLE IT!!!!!!!
     

    #1
    a9100677 and nabeelahammed like this.
  2. hahaha2223
    Jelly Bean Oct 9, 2018

    hahaha2223 , Oct 9, 2018 :
    You seem to be facing a problem that not many others have.
    Contact support or submit a thread in oneplus.com/feedback to reach the team, oneplus doesn't read here
     

    #2
    Raresch, xnutzii, otto2 and 1 other person like this.
  3. GopalB.
    Nougat Oct 9, 2018

    GopalB. , Oct 9, 2018 :
    Did you turn of advanced optimization???
     

    #3
    Aks41179 likes this.
  4. B_Wrath
    Marshmallow Oct 9, 2018

    B_Wrath , Oct 9, 2018 :
    Did you try a factory reset???
     

    #4
    Aks41179 likes this.
  5. vteruni
    Cupcake Oct 9, 2018

    vteruni , Oct 9, 2018 :
    yes to all of the suggestions

    yes both of the advanced optimization options are disabled. The only thing i couldnt find was the Doze setting that people keep talking about thats supposed to be in the developer settings. Ive also turned off adaptive batter but since turned it back on since that didnt seem to make a difference.

    ive factory reset probably 5 times for unrelated issues when i was going back and forth between the beta and stable versions.

    Ive see a number of threads about this when searching on google both on the oneplus forums and on xda so i doubt its related to my phone specifically. An easy way for me to test this would be to flash a custom AOSP rom that doesnt have anything Oxygen OS related on it. There are just 2 problems with that.
    1. i really dont want to reset all of my crap again for the 6th time
    2. i actually really like the stability and smoothness of OOS along with the gestures that are offered. The above mentioned issue is literally the only problem i have with the phone.
     

    #5
  6. iOStoAndroid
    Gingerbread Oct 9, 2018

    iOStoAndroid , Oct 9, 2018 :
    I know exactly what you are going through..

    The issue is this: until 5T, you could root and use Buildprop to edit the number of background processes. People were increasing it from like 28 to 60 and reporting that apps remain on RAM much better. So editing that would directly help with your issue.

    BUT! From 6, OP disabled that option. That settings no longer exists even with root! This is because OP didn't want to lower battery life, when 6 was going to have worse battery life due to larger screen. It was ridiculous that they disabled the option for power users to tweak. I doubt that setting will make a come back with 6T..

    With day to day app and no gaming, 5T is definitely much faster with applications because of the ability to modify app limit with buildprop.

    Only a handful of people know this and care.. 6gb is fully used. For 8gb, the phone is constanly trying to free up to 1.5gb of RAM when idle. And it is killing apps like maps, Youtube, equalizer, etc that are frequently accessed.

    Pretty sure this is OP's fault. Android on 5T and 6 are the same, but setting is disabled only for 6. That was deliberate..
     

    #6
    somenothingness and a9100677 like this.
  7. maveric2170
    Cupcake Oct 9, 2018


    #7
  8. Deactivated User
    Oct 9, 2018


    #8
    venciss15 and Kytharsis like this.
  9. vteruni
    Cupcake Oct 9, 2018

    vteruni , Oct 9, 2018 :
    You are 100% correct my friend. Didn't even notice that they removed it. Does that mean there is no way of changing the limit of background apps on this phone while still using OOS?
     

    #9
  10. iOStoAndroid
    Gingerbread Oct 10, 2018

    iOStoAndroid , Oct 10, 2018 :
    There is absolutely no way.. I dont think the setting will return with 6T.. When they take something away, usually does not come back.. How things work..

    I spent weeks trying to find solution, but I gave up!
     

    #10
  11. vteruni
    Cupcake Oct 11, 2018

    vteruni , Oct 11, 2018 :
    What about switching over to a custom Rom? Is the issue Rom related or Kernel related?
     

    #11
  12. iOStoAndroid
    Gingerbread Oct 12, 2018

    iOStoAndroid , Oct 12, 2018 :
    I didnt test but i am 99.9999% sure it is kernel..

    They dont want you increasing background processes for sure... When they dont want ya, there is just no other way. .
     

    #12
  13. vteruni
    Cupcake Oct 12, 2018

    vteruni , Oct 12, 2018 :
    Wouldnt flashing a custom kernel fix the problem though? i mean at the end of the day its all just hardware. Anything can be modded.
     

    #13
  14. idkwhoiam322
    Nougat Oct 12, 2018

    idkwhoiam322 , Oct 12, 2018 :
    Not completely, but can be improved. At least that's what I managed to do on my kernel. It's not nearly as nice as it should be but my 6 GB RAM op5 doesn't kill chrome tabs every 20 minutes anymore.
    It should still be possible to do that in default.prop.
     

    #14
  15. Its.Leandroo
    The Lab - OnePlus 6 Reviewer Oct 12, 2018

    Its.Leandroo , Oct 12, 2018 :
    There's a simple solution. You can lock an app to prevent it being killed by the system. Just go to your recents screen, press the option icon, and tap on 'lock'. Now it won't be killed.

    Edit: nvm you already tried it. Then I don't know. I don't have a problem like that.
     

    #15
  16. idkwhoiam322
    Nougat Oct 12, 2018

    idkwhoiam322 , Oct 12, 2018 :
    No? That only prevents it from being cleared from the recents menu. It does not prevent it from being killed as a process itself.
     

    #16
  17. Xeny
    Honeycomb Oct 12, 2018

    Xeny , Oct 12, 2018 :
    It does, the lock has a keepalive function built in.
    I use it to avoid my smartwatch app and my VPN to die.

    As far as I know it is the best way to prevent apps to be killed.
     

    #17
  18. Dodkrake
    Ice Cream Sandwich Oct 12, 2018

    Dodkrake , Oct 12, 2018 :
    I dont have this issue with any of my apps and my screen on time frequently surpasses 8h. Terrible product
     

    #18
  19. vteruni
    Cupcake Oct 12, 2018

    vteruni , Oct 12, 2018 :
    Ive tried it and it doesnt keep it on indefinetly. I will give you that it does tend to stay alive longer if i put the lock on. Without it, i had a problem of it getting killed almost 10x a day. If i leave the lock on, it seems to only get killed off once or twice.
     

    #19
  20. Xeny
    Honeycomb Oct 12, 2018

    Xeny , Oct 12, 2018 :
    yeah, there is definitely an issue with background process management because it shouldn't override lock function.
    It works fine for me but I'm on a custom ROM/kernel.
     

    #20