2
OxygenOS Background processes killer is WAAAAY too aggressive

  1. Its.Leandroo
    The Lab - OnePlus 6 Reviewer Oct 12, 2018

    Its.Leandroo , Oct 12, 2018 :
    Woops, my bad. I never use that feature so I was guessing :confused:
     

    #21
  2. friendsanu1993
    Gingerbread Oct 12, 2018


    #22
  3. iOStoAndroid
    Gingerbread Oct 12, 2018

    iOStoAndroid , Oct 12, 2018 :
    Build.prop editing of applimit only works for up to 5T! From 6, there is no setting to change. This is what pissed me off soooooo much.. 5T is better multitasker than 6..
     

    #23
  4. idkwhoiam322
    Nougat Oct 12, 2018

    idkwhoiam322 , Oct 12, 2018 :
    It's not possible anymore on the 5/T the old way either. And it should still be possible on the 6 without a problem. Currently, I added this:
    Code:
    insert_line default.prop "ro.sys.fw.bg_apps_limit=60" before "ro.secure=1" "ro.sys.fw.bg_apps_limit=60";
    
    to my anykernel.
     

    #24
  5. iOStoAndroid
    Gingerbread Oct 12, 2018

    iOStoAndroid , Oct 12, 2018 :
    Where did you insert that code? How? Do i need to be rooted?

    Still newb to Android.. Took me 4 hrs to root! Thanks for your replies.
     

    #25
  6. vteruni
    Cupcake Oct 13, 2018

    vteruni , Oct 13, 2018 :
    This looks like an adb command, if i had to guess you gotta have your phone in fastboot and have developer mode enabled along with being rooted. This is just a guess though and i would wait for idkwhoiam322 to respond first.
    On a side note, i havent been able to find any files by the name default.prop, only build.prop. are we talking about the same file or am i missing something?
     

    #26
  7. G_Alexsandr_Smirnov_FdIC
    Cupcake Nov 21, 2018

    G_Alexsandr_Smirnov_FdIC , Nov 21, 2018 :
    Code:
    insert_line default.prop "ro.sys.fw.bg_apps_limit=60" before "ro.secure=1" "ro.sys.fw.bg_apps_limit=60"; on 9.0.2 where to register this code
     

    #27
  8. iOStoAndroid
    Gingerbread Nov 24, 2018

    iOStoAndroid , Nov 24, 2018 :
    Thank you for the reply. Do I need to stay rooted for the setting? If I unroot and lock the bootloader again, the code goes back to original?
     

    #28
  9. a9100677
    Cupcake Nov 30, 2018

    a9100677 , Nov 30, 2018 :
    Had the same problem. Switched off adaptive battery that came with Pie and restarted the phone. (Nothing changed when only turning adaptive battery off without reboot). Much much better now, I can finally use the phone productively again, it used to be a nightmare. But who knows, maybe it's the reboot itself that helps temporarily. Let's see.
     
    Last edited: Nov 30, 2018

    #29
  10. iOStoAndroid
    Gingerbread Dec 2, 2018

    iOStoAndroid , Dec 2, 2018 :
    I did that too and also went to advanced optimization and turned that off as well. How is background app performance now for you?
     

    #30
  11. a9100677
    Cupcake Dec 26, 2018

    a9100677 , Dec 26, 2018 :
    Seems okay, but I'm not really an expert in these things to judge.
     

    #31