924
Battery Calibration/Heating Tips: How To Improve Battery Life!!

?

What has been your first experience with the OnePlus 5 Screen-On Time?

  1. 3 Hours

    97 vote(s)
    5.5%
  2. 3.5 Hours

    74 vote(s)
    4.2%
  3. 4 Hours

    170 vote(s)
    9.6%
  4. 4.5 Hours

    192 vote(s)
    10.9%
  5. 5 Hours

    224 vote(s)
    12.7%
  6. 5.5 Hours

    192 vote(s)
    10.9%
  7. 6+ Hours

    815 vote(s)
    46.2%
  1. mat111
    Cupcake Aug 11, 2017

    mat111 , Aug 11, 2017 :
    My battery is on 4.5.8 better. When update to 4.5.8. charge battery to 100% then clear cache. Now is perfect.
     

  2. Hungtruong
    Eclair Aug 11, 2017

    Hungtruong , Aug 11, 2017 :
    due .I think cause your phone is not Asian version or usa version man.your is au version I think .I just update my op5 but look the battery still normal.you need to check on that bro
    1502475738403.jpg
     

  3. G_Sagar_Mendon_xlTw
    Donut Aug 11, 2017


  4. Blaze Mathews
    Gingerbread Aug 11, 2017

    Blaze Mathews , Aug 11, 2017 :
    Just try rebooting the phone. I had the same issue. I used to use WhatsApp continuously for around 15 min and the place near the camera right below it started heating up unusually. Then I just restarted the phone
    If still doesn't work just downgrade the stock version
    THAT'S it.
     

  5. Dunnow
    The Lab - OnePlus 6 Reviewer Aug 11, 2017

    Dunnow , Aug 11, 2017 :
    why? I just said that the guide should not be promoted as it is full of crap, don't know why I should actually go and talk with the guy who made it... I bet he won't even accept my points, that's what all this "battery gurus" end up doing...
     

  6. chazarss
    Honeycomb Aug 11, 2017

    chazarss , Aug 11, 2017 :
    Hi all, do u you have same problem?
    I am using wifi mostly but it is still too high

    media-20170811.png
     

  7. G_m.shanny_nur_iman_ap_L
    Cupcake Aug 11, 2017

  8. murrariv19
    Eclair Aug 11, 2017

    murrariv19 , Aug 11, 2017 :
    The battery drain still persists even after the oxygen os 4.5.8
    the update doesn't seem to have fixed anything. Any help would be highly appreciated. I attach the screenshot and the usage I had done during this drain is mild.
    1502480723946.jpg
     

    G_Zaul_cSKG likes this.
  9. Tuan anh tran
    Eclair Aug 11, 2017


  10. svvenn
    Ice Cream Sandwich Aug 11, 2017


  11. F_Rakesh_Kumar_Nayak_qbY
    Gingerbread Aug 11, 2017


  12. Goodman854
    Froyo Aug 11, 2017

    Goodman854 , Aug 11, 2017 :
    btw sot (screen on time) is an awful battery testing metric. also stop abeverating it please.
     

  13. Rikinpatel459
    Gingerbread Aug 11, 2017

    Rikinpatel459 , Aug 11, 2017 :
    same
     

  14. Funk Wizard
    Moderator Moderator Aug 11, 2017

    Funk Wizard , Aug 11, 2017 :

    To begin with, Thank you @SoniaB & @mr_priyanshu for the heads up ;-)
    I’ve moved the posts to the relevant thread in question as it would be better if we discuss this here.


    Well every user has specific/different needs and different usage pattern. I just shared the general practices that could make the device go the extra mile when we are away from the charger.

    When we talk about the gestures, disabling them does help as the device has to have a service running in the background causing a wakelock which drains the battery. So if you are not using gestures frequently or think that you can live without them, I would suggest you to turn them off.

    Doze mode is activated by default in OOS, so you need to whitelist the apps or don't optimize them and turn off advanced optimizations to run unaffected by doze

    Settings > Battery > Battery Optimizations > Don't optimize (ones you want to run on boot)

    Also there are some other hidden settings that you need to check, tweak as per preference and observe the behavior:
    1. App Auto Launch at Startup/Auto Run When Power Up
    2. Aggressive Doze & App Hibernation Settings

    Screenshot_20170617-132445.png Screenshot_20170617-132814.png Screenshot_20170617-132956.png

    One can whitelist the desired apps like whatsapp and other messaging apps so you would still receive all the notifications that you desire but still giving you that extra standby when doze hibernates other apps/services.


    When you press the power button on your phone to lock the screen, you assume that the phone will go to sleep. But that’s not always the case. There are apps that run in the background, using the device’s resources and restricting the phone from going into deep sleep mode. Because of these, the phone’s processor is constantly working, which drains the battery life even when you’re not using it. Most of these wakelocks are caused because apps want to sync data in the background or use location services. So I am just trying to minimize these wakelocks and allow only those that you care about or don’t want to miss notifications from.

    Me being a rooted user do not use this feature to backup my data as I have other better means to do so, thus I only shared my personal settings. This option Can be turned on once a week for a day or so if you don't have any other means to backup your data.


    As I have already mentioned this is optional and depends on user requirement. We can always turn it on manually and I have a one click toggle made for this. I never meant users to disable the sync completely as that would break the sync functionality which I never intend or recommend. Below is a peak at my quick toggles for easy sync and other quick settings access on the latest OOS 4.5.8

    1.jpg

    Once again I would like to clarify that these settings are based on my Android experience and may or may not work for everyone depending upon individual usage pattern, but it would definitely give you an edge if you incorporate even a few.
     

    SoniaB and mr_priyanshu like this.
  15. Funk Wizard
    Moderator Moderator Aug 11, 2017

    Funk Wizard , Aug 11, 2017 :
    Any feedback positive or negative is always appreciated. Your points are valid to some extent for an active user but at the same time as i said it all settings are optional and based on user requirements. Thanks again for sharing your thoughts with us
     

    SoniaB likes this.
  16. sharan.salem
    Gingerbread Aug 12, 2017

    sharan.salem , Aug 12, 2017 :
    Hi Funk wizard,

    Thanks for the tips, i have followed every tip you have mentioned but unfortunately my device lasts only for 5 hrs SOT. I don't have any heavy apps, I don't play any games on my mobile. I only use few light apps like WhatsApp, Hike, InShorts. Kindly comment on this. BTW I'm using OP5.

    Thanks
    [e]270c[/e]️
     

  17. Ilkozlatkov
    Cupcake Aug 12, 2017

    Ilkozlatkov , Aug 12, 2017 :
    Mine is not good...
    1502509676039.jpg

    1502509676141.jpg
    The summary of the % is 57 total, but I have 15. Does anyone have the same issue?
     

  18. Funk Wizard
    Moderator Moderator Aug 12, 2017

    Funk Wizard , Aug 12, 2017 :
    Can you please share your stats and usage pattern so I can look into it, thanks

    Looking at your stats you should try a factory reset
     

    Ilkozlatkov and sharan.salem like this.
  19. sharan.salem
    Gingerbread Aug 12, 2017

    sharan.salem , Aug 12, 2017 :
    Yes, sure i will provide you today's stats at the end of the day.

    "Also there are some other hidden settings that you need to check, tweak as per preference and observe the behavior:
    1. App Auto Launch at Startup/Auto Run When Power Up
    2. Aggressive Doze & App Hibernation Settings"

    Where can i find these 'hidden settings' ?
     

  20. SergiuXro
    Gingerbread Aug 12, 2017

    SergiuXro , Aug 12, 2017 :
    Some tests overnight, in about 7h.

    1. no gestures, pocket mode disabled ~ 3%
    2. no gestures, pocket mode enabled ~ 3%
    3. gestures (o, media), pocket mode enabled ~ 3%
    4. no gestures, pocket mode enabled ~3%

    It's interesting, i thought that disabling pocket mode (which uses the proximity sensor) will increase the battery life. Same with gestures.. it seems the battery impact is very little/negligible with those feature on.
    Also by enabling aggressive doze mode i haven't noticed any change overnight!

    ---

    Wifi on, location on (gps only), sync on, bluetooth off, nfc off, wifi scanning off.
    Wifi is the top consumer in this case! This should be definitely improved OnePlus!