1
Battery Drain/wakelock Systemupdateservice

  1. Shaker2k
    Ice Cream Sandwich Jul 6, 2014

    Shaker2k , Jul 6, 2014 :
    So I've noticed my phone is not going into deepsleep. On wakelock detector it says the drain is coming from google services/ systemupdateserevice.
    I'm rooted and running Franco kernel with almost no apps installed besides greenify, fku ,wakelock detector and better battery stats. I googled it and it seems to be a problem with cm. Has anyone else encountered this and is there a solution?
    I also had the wakelock on the stock kernel.
     

    #1
    pyccanful likes this.
  2. ionpan89
    Honeycomb Jul 6, 2014

    ionpan89 , Jul 6, 2014 :
    Yeap, here. Computer engineering. You should know what a bummer that is.

    EDIT: Now that's embarrassing..
     

    #2
  3. Shaker2k
    Ice Cream Sandwich Jul 6, 2014

    Shaker2k , Jul 6, 2014 :
    I was hoping someone else had this problem and had a solution for it. Ahh the bugs with cm. I'm tempted to run a custom rom because of this. I really want to give stock a run though.
     

    #3
    avinash_psla likes this.
  4. janek
    Donut Jul 6, 2014

    janek , Jul 6, 2014 :
    I've not had a deeper look at it yet but it seems I'm having the same problem. At least according to the stats in android settings/battery the phone has been "active" all the time without any interruption - although there have been screen off phases off ~1h and more.

    franco kernel r2
     

    #4
  5. robwho58
    Honeycomb Jul 6, 2014

    robwho58 , Jul 6, 2014 :
    Hmm, seems to be a common denominator here!
     

    #5
  6. DigitalAnarchy
    Jelly Bean Jul 6, 2014

  7. DigitalAnarchy
    Jelly Bean Jul 6, 2014

    DigitalAnarchy , Jul 6, 2014 :
    just do a full backup and try a new rom if happy stay with it if not restore the backup
     

    #7
  8. Shaker2k
    Ice Cream Sandwich Jul 6, 2014


    #8
  9. janek
    Donut Jul 6, 2014


    #9
    Bsyde and Shaker2k like this.
  10. DigitalAnarchy
    Jelly Bean Jul 6, 2014

    DigitalAnarchy , Jul 6, 2014 :
    the donated version can with xposed framework
     

    #10
  11. Shaker2k
    Ice Cream Sandwich Jul 6, 2014

    Shaker2k , Jul 6, 2014 :
    Yeah I know that. But xposed does not work with the art runtime.


     

    #11
  12. janek
    Donut Jul 6, 2014

    janek , Jul 6, 2014 :
    Ok: The SystemUpdateService wakelock issue seems to be a problem with the new Google Play Services 5.0 version and CM11 in general. See http://www.reddit.com/r/Android/com...y_services_50_is_rolling_out_with_new/ciho88i
    Many users seem to have this issue.

    But maybe I found a fix:
    • Install "Disable Service" from play store https://play.google.com/store/apps/details?id=cn.wq.disableservice
    • Swipe to "System Apps" and select "Google Play Services"
    • Search for "SystemUpdateServer" => It was unchecked in my case. If it's unchecked: Klick on it (Checks it and enables the service)
    • Do the same for "SystemUpdateServer" of Google Play Framework (Update)
    Afterwards the SystemUpdateServer wakelocks are gone for me (at least for the moment) and the devices was able to go to deep sleep.

    But why does enabling the service could possible disable the wakelocks caused by this particular service?
    There have been lots of partial wakelocks because some Apps/BroadcastReceivers tried starting the SystemUpdateServers - but because it has been disabled all requests failed. Every request caused a so called "partial wakelock" which prevents the device from entering deep sleep.

    At least that's the theory -> I'll keep you posted if this fixes the issue for me completely

    Update:
    This issue is highly discussed in cyanogenmod and xda-developers forums. See http://forum.cyanogenmod.com/topic/...ce-wakelock-on-cm11-m7-massive-battery-drain/ and http://forum.xda-developers.com/showpost.php?p=53739230&postcount=5031

    My assumption was correct: Enabling the service fixes the wakelock! Sadly this only holds until the next reboot: The service is automatically enabled again...

    For a permanent fix see this post on xda-developers: http://forum.xda-developers.com/showpost.php?p=53739230&postcount=5031

    Basically the app "Autorun Manager" makes it possible to disable the SystemUpdateServer completely (with all its BroadcastReceivers) and this fix stays also after reboot.

    This is a bug due to an incompatibility between Cyanogenmod and latest Google Play Services 5.0
    A fix is already available in the CM nightlies - hopefully CM11S will be updated soon.

    Temporary fix without root requirement:
    Downgrade to older Google Play Services version 4.x. Available here: http://www.androidpolice.com/2014/0...w-street-view-api-running-detection-and-more/
    (Scroll down to the download section)
     
    Last edited: Jul 6, 2014

    #12
  13. darkangelism
    Honeycomb Jul 9, 2014

    darkangelism , Jul 9, 2014 :
    I hope this is patched soon in 11S. Yesterday went to work, left phone at home because I don't have a sim card yet, battery went from 80%-45% Google services was chewing up 45% of the battery. Last night put it in battery saving mode, so GPS gets disabled, turned off location reporting and location history. Went from 88%-79% in 8 hours overnight, which is a big improvement from 35% loss in 10 hours, but still the wakelock detector said that the phone had been awake 90% of the time, with 500+ calls from Systemupdate server. I turned off auto sync and left with 78% battery.

    Since I have no Sim card there was no radios enabled, so battery should be barely drained over night or throughout the day.
     

    #13
  14. Jakub Smolar
    Ice Cream Sandwich Jul 10, 2014

  15. be33to9
    Honeycomb Jul 11, 2014


    #15
  16. Jakub Smolar
    Ice Cream Sandwich Jul 11, 2014

    Jakub Smolar , Jul 11, 2014 :
    Look onto what @janek said. I am using a temporary solution using the "Disable Service" resp. enabeling the services... I experienced a huge drain yesterday. After falshing franko kernel r4 yesterday and enabling the services, I am at 79% after more than 10h of moderate phone use. To fix it, you need a rooted device though.
     

    #16
  17. darkangelism
    Honeycomb Jul 11, 2014

    darkangelism , Jul 11, 2014 :
    I did the permanent fix on wednesday and it held, I was at 75% battery with 15 hrs standby and 1 hr screen time, only 4% awake time.
     

    #17
    Jakub Smolar likes this.
  18. beleaf
    Jelly Bean Jul 12, 2014

    beleaf , Jul 12, 2014 :
    Weird. With a factory reset and root, I begun having this issue. Before I had no problems...
     

    #18
  19. be33to9
    Honeycomb Jul 12, 2014


    #19
  20. beleaf
    Jelly Bean Jul 12, 2014


    #20