1
Battery Drain/wakelock Systemupdateservice

  1. darkangelism
    Honeycomb Jul 12, 2014

    darkangelism , Jul 12, 2014 :
    what does wakelock detector show?
     

    #21
  2. beleaf
    Jelly Bean Jul 12, 2014

    beleaf , Jul 12, 2014 :
    I rebooted and it looks a lot better now. "Awake" isn't constantly awake anymore, though there are some random times it is awake when my screen is off. Probably for GPS and location reporting is my best guess.
     

    #22
    darkangelism likes this.
  3. Audroid
    Gingerbread Jul 13, 2014


    #23
  4. relic242
    KitKat Jul 16, 2014

    relic242 , Jul 16, 2014 :
    dont have a that problem...
    /no root, last orig. OTA update/
     

    Attached Files:


    #24
  5. be33to9
    Honeycomb Jul 16, 2014


    #25
  6. Audroid
    Gingerbread Jul 16, 2014

    Audroid , Jul 16, 2014 :
    No, I had the problem before rooting. Because of the battery drain I rooted, to use better battery stats
     

    #26
    darkangelism likes this.
  7. pyccanful
    Ice Cream Sandwich Jul 16, 2014


    #27
  8. Hawkery
    Honeycomb Jul 17, 2014

    Hawkery , Jul 17, 2014 :
    I can't seem to get it fixed without rooting...
    I don't want to root it, as i have to maany things i need to get fixed if i would root it.
    Isn't there any other way?
     

    #28
  9. darkangelism
    Honeycomb Jul 18, 2014

    darkangelism , Jul 18, 2014 :
    Did you uninstall google services and install version 4?
     

    #29
  10. Hawkery
    Honeycomb Jul 18, 2014


    #30
  11. coolguy949
    Froyo Jul 18, 2014

    coolguy949 , Jul 18, 2014 :
    Same here. I tried another way and went in to Settings > Apps > Google Play services and clicked "Uninstall Updates." I'm now on version 4.3.25 that came with the phone. But unfortunately Hangouts and other apps wont work.
     

    #31
  12. coolguy949
    Froyo Jul 18, 2014

    coolguy949 , Jul 18, 2014 :
    OK, I can confirm rolling back to the original version on the phone has fixed the wakelock. The phone is actually going in to deep sleep. However, none of the Google apps work. They require me to update Google Play services.
     

    #32
  13. coolguy949
    Froyo Jul 18, 2014

    coolguy949 , Jul 18, 2014 :
    I think I might have stumbled on a way to fix the problem. By uninstalling and re-installing Google Play services updates, the wakelock seems to be gone. I even rebooted and it's behaving as it should. The phone goes in to deep sleep. Can someone else try this and see if it works. I'm stock, not rooted.

    When I first received my OPO, I updated Google Play services before the CM system update ran. Perhaps running Google Play services update after the CM update causes it to patch files that might have been overwritten by the CM update. Just a guess.
     

    #33
    darkangelism likes this.
  14. mhussain
    Eclair Jul 19, 2014


    #34
  15. Cool5256018
    Cupcake Jul 19, 2014


    #35
    prozaican likes this.
  16. Mahan Rad
    Eclair Jul 19, 2014

    Mahan Rad , Jul 19, 2014 :
    I managed to disable the play sync services and boost the battery power to cover about a day of fairly minimal usage. However the "better battery stats" still shows a 100% usage of the following items:

    "No Data Connection" 99%
    "No or Unknown Signal" 99%

    I'm not sure if the cellular reception that cause these items to suck up battery power.
    Is it normal to have around one day of minimal use with OPO? any ideas?
     
    Last edited: Jul 20, 2014

    #36
  17. prozaican
    Froyo Jul 20, 2014

    prozaican , Jul 20, 2014 :
    this one works for me... :D
     

    #37
  18. Ukali
    Jelly Bean Jul 20, 2014

    Ukali , Jul 20, 2014 :
    I don't have that sorry, i'm running deep sleep really quickly and loosing almost no Battery...
    And i got around 18Hours on my FIRST day.
    With 7 Hour's on screen and syncing and downloading all the time.
    Although mobile connection is really heavy on battery!
    More than on any other phone!
     

    #38
  19. coolguy949
    Froyo Jul 20, 2014

    coolguy949 , Jul 20, 2014 :
    After two days I still have no wakelock. All I did was uninstall Google Play updates and reinstall the update when prompted by one of the Google apps. Hopefully it stays this way.
     

    #39
  20. napes22
    Honeycomb Jul 21, 2014

    napes22 , Jul 21, 2014 :
    How did you do this? I can't figure out how to uninstall the updates. The box is greyed out.
     

    #40
    69gm likes this.