0
Battery Drain ..

Thread Status:
Not open for further replies.
  1. macem29
    Jelly Bean Apr 7, 2015

    macem29 , Apr 7, 2015 :
    over 8 hours since a charge and still at 87%, don't see a big problem there...

    looks like the phone was in standby the whole time, no screen time,
    no call time, no app usage....so whatever is running on standby will use
    the battery, and the process that uses the most energy will be at the
    top of the list.....if you start using the phone you'll see other processes
    start to list at the top, like screen, phone, browser etc...

    sure 48% of battery usage for google services looks funny,
    but that stat is skewed because you weren't using the phone at all

    click at the top on the battery graph, take a screen cap of that so we can see your wake situation
     

    #1
  2. LOLA001
    Froyo Apr 7, 2015

    LOLA001 , Apr 7, 2015 :
    yes the phone was on stand by for 8 hours .. i just charged it and then went to sleep
    to find it the next morning at 87% !! :(
     

    #2
  3. SpicedCrusher
    Cupcake Apr 7, 2015

    SpicedCrusher , Apr 7, 2015 :
    13% in 8 hours? That's not awful. Did you want it to still be fully charged after 8 hours??
     

    #3
  4. Mt163
    Ice Cream Sandwich Apr 7, 2015

    Mt163 , Apr 7, 2015 :
    try factory reset and just re-download the things u need lol
     

    #4
    op.pollicis likes this.
  5. wilsmits
    Jelly Bean Apr 8, 2015

    wilsmits , Apr 8, 2015 :
    That's not good enough for me
     

    #5
  6. SomeSayImHandSome
    Apr 8, 2015

    SomeSayImHandSome , Apr 8, 2015 :
    its a google p0rn virus.
     

    #6
  7. ci2ny
    Gingerbread Apr 8, 2015


    #7
  8. DeltaSky
    Ice Cream Sandwich Apr 8, 2015

    DeltaSky , Apr 8, 2015 :
    Possible solutions
    Update to xnph05q (as you're still on 44s)

    Clear Cache/Data of Google play services from settings - all apps

    Remove and re add your Google account

    Root and freeze the play services or wait for cm os 12
     

    #8
  9. reverenddak
    Ice Cream Sandwich Apr 8, 2015

    reverenddak , Apr 8, 2015 :
    This is the only REAL fix, but you have to have root:

    https://forums.oneplus.net/threads/fix-oxygenos-wakelock.291648/ or
    https://forums.oneplus.net/posts/10450093/

    You can try this first (no root required): Install "Disable Service" app from Play store, then under the System tab you need to go to Google Play Services and ENABLE SystemUpdateService. Do not reboot, use the phone normally for a couple hours, and check the stats. If you seen an improvement, the above is the fix. Still, any permanent fixes requires root.
     

    #9
  10. firewire2035
    KitKat Apr 8, 2015

    firewire2035 , Apr 8, 2015 :
    Are you rooted? Install battery monitor widget. This wouldn't reveal the source, but may give you a better idea. Don't worry, you can always reinstall, but try to find a less invasive method first. I had to do a clean install to rid of a persistent drainage.
     

    #10
  11. QuaqSim
    Gingerbread Apr 8, 2015

    QuaqSim , Apr 8, 2015 :
    It sounds to me like you've 'solved' the Google Play Services issue, I'd expect more than a 13% drain after eight hours of being permanently awake. Your battery stats have probably reset but I'd suggest you charge your phone before bed, manually reset battery stats to make sure you're starting from nothing and then unplug it.

    When you wake up, you should hopefully see a better picture of where that 13% is going. I'd be surprised if you find it's Google Play Services and if it is, it's probably not SystemUpdateService. I'd speculate that you have location turned on and one of multiple options are turned on that make it poll for your location.

    Privacy Guard will prevent it from waking up your device or keeping it awake but it won't prevent something else waking it up and Google Play Services taking that opportunity to check GPS location.
     

    #11
  12. mcmatthew1
    Cupcake Apr 9, 2015

    mcmatthew1 , Apr 9, 2015 :
    i also have a problem with my battery. Ever since the update to cm11.0xnpho5Q i have noticed worse battery. Not sure if i am just imagining things or if i changed my usage but this is the graph
     

    Attached Files:


    #12
  13. gioser
    Gingerbread Apr 9, 2015

    gioser , Apr 9, 2015 :
    Yes I removed the cache using power cleaner. It was by mistake, and now it enters into deep sleep.fixed it in 2 devices running cm12.
    D disabling Google devices did not help
     

    #13
    DaxNagtegaal likes this.
  14. Tyronekramsey
    Jelly Bean Apr 9, 2015

    Tyronekramsey , Apr 9, 2015 :
    Flash Oxygen OS :D Its horrible but battery life is ok
     

    #14
  15. Parisone
    Gingerbread Apr 9, 2015

    Parisone , Apr 9, 2015 :
    when i got your issue few days ago, i did your step plus dalvin cache wipe
     

    #15
  16. BBD
    Donut Apr 28, 2015


    #16
  17. vivek289
    Ice Cream Sandwich Apr 28, 2015

    vivek289 , Apr 28, 2015 :

    Disable Google App that you're not using
     

    #17
  18. oneminusone
    Ice Cream Sandwich Apr 28, 2015


    #18
    TeamValor91 likes this.
  19. leemartin
    Lollipop Apr 28, 2015

    leemartin , Apr 28, 2015 :
    Funny on your screen shot that it says, Google Services but on my phone that's the icon for Google Contacts sync...... Maybe google contacts is having problems syncing?
     

    #19
  20. Backslash95
    Cupcake Apr 28, 2015

    Backslash95 , Apr 28, 2015 :
    if nothing helps, save your stuff and reset your phone
     

    #20