11
Bluetooth disconnects with OxygenOS 5.1.6 OTA for the OnePlus 5T

  1. ravi.ajn
    Froyo Oct 29, 2018

    ravi.ajn , Oct 29, 2018 :
    Bluetooth disconnects with OxygenOS 5.1.6 OTA for the OnePlus 5T
    I have wiped the cache multiple times too, disconnected and reconnected the bluetooth from the CAR.
    Forgot and added it newly, But still when I'm on a call or play music..it gets connected and disconnected n lot of interruption.
    Is any one else facing the issue with the new update and any way to fix this???

    Update: ISSUE RESOLVED WITH 5.1.7 update.
     
    Last edited: Nov 14, 2018

    #1
  2. Kingopinno123
    Cupcake Oct 29, 2018


    #2
  3. J1540821526511
    Cupcake Oct 29, 2018

    J1540821526511 , Oct 29, 2018 :
    I am having the same problem in my 5t mobile . not able to connect any Bluetooth devices with my phone
     

    #3
  4. tojavuo
    Cupcake Oct 29, 2018

    tojavuo , Oct 29, 2018 :
    Same problem, no way of knowing when the output changes. Connect as didconnects all the time.
     

    #4
  5. stinga11
    Cupcake Oct 29, 2018


    #5
  6. flakpyro
    Donut Oct 29, 2018

    flakpyro , Oct 29, 2018 :
    Have the same issue too after 5.1.6 BT on this phone has become totally useless.
     

    #6
  7. SHIV@INDLA786
    Gingerbread Oct 29, 2018


    #7
    kannan333 and dareknowak like this.
  8. TobbanB
    Cupcake Oct 29, 2018


    #8
    kannan333 likes this.
  9. G_Dennis_Binnberg_qzZF
    Cupcake Oct 29, 2018

    G_Dennis_Binnberg_qzZF , Oct 29, 2018 :
    I have the same problem. Keeps disconnecting randomly from my car. No problem with my Garmin watch. I had no problem when i was on 5.1.5 but with the latest OTA the BT just gave up. Tried repairing with the car but that did not help. Any tips to make it work again?
     

    #9
  10. jolindgr1
    Cupcake Oct 30, 2018

    jolindgr1 , Oct 30, 2018 :
    +1... Connets or not, drop connection or not.
    Wiped cache with no results.
    This needs a fix asap.
     

    #10
    kannan333 likes this.
  11. effectandaffect
    Cupcake Oct 30, 2018


    #11
    kannan333 likes this.
  12. ravi.ajn
    Froyo Oct 30, 2018

    ravi.ajn , Oct 30, 2018 :
    Just an update guys, I logged the bug and Oneplus team asked to pull some log of the activities..I have send them yesterday, the development team are looking into the issue.
    Even if you all can log a bug/complaint they would prioritize this issue.. Untill then pls let ur know ones know not to updated this version..
    I know with out Bluetooth its really tough these days!!!
     

    #12
    kannan333 and pwester like this.
  13. pwester
    Donut Oct 30, 2018

    pwester , Oct 30, 2018 :
    Yes, same problem here after update to 5.1.6. No Bluetooth-problems whatsoever with 5.1.5. The only thing that solves this issue is restarting my phone while connected to my car stereo; after that the phone connects at once without problems.
     

    #13
    kannan333 likes this.
  14. sweggitity
    Ice Cream Sandwich Oct 30, 2018

    sweggitity , Oct 30, 2018 :
    I flash my ROMs manually, as i am rooted. I don't have this issue though. Maybe i do, will need to test it further, but i didn't face any bluetooth drops on my Mi Band 3 and QCY Q19 earphones.
     

    #14
  15. RXYYVN
    Eclair Oct 30, 2018

    RXYYVN , Oct 30, 2018 :
    the only fix is to rollback to 5.1.1
    I have done the same. 5.1.1. is the most stable version right now.
    OP devs are sleeping.
     

    #15
    kannan333 likes this.
  16. RXYYVN
    Eclair Oct 30, 2018

    RXYYVN , Oct 30, 2018 :
    The bug was there since 5.1.5. If they cared enough, this update would have patched it. OP has changed and are copying apple's strategy to not give a damn about their customers.
     

    #16
    kannan333 likes this.
  17. flakpyro
    Donut Oct 30, 2018

    flakpyro , Oct 30, 2018 :
    Same issue 5.1.5 was fine, 5.1.6 it just constantly connects then disconnects.
    Would be happy to send logs if you can direct me to where to do it? I tried logging a support request and the reply back was scripted and rather pointless in even trying to deal with.
     

    #17
    kannan333 likes this.
  18. pwester
    Donut Nov 1, 2018

    pwester , Nov 1, 2018 :
    The problem is solved for me when I change the Bluetooth AVRCP-version from 1.4 (Default) to 1.6 in Developer Options!!

    Update: Alas, it worked only once... :-(
     
    Last edited: Nov 2, 2018

    #18
    jolindgr1 likes this.
  19. F1512019613137
    Cupcake Nov 1, 2018

    F1512019613137 , Nov 1, 2018 :
    The same problem. Start a 5.1.5 and 5.1.6 too. Bluetoth do not work. Do not turn on and kernel process "hal_bluetooth_lock" discharge battery. Phone never go to sleep mode, always in active mode
     

    #19
    kannan333 likes this.
  20. G_Mattias_Wengelin_lGtZ
    Cupcake Nov 1, 2018

    G_Mattias_Wengelin_lGtZ , Nov 1, 2018 :
    Same problem here, cannot connect to car, it tries but immediately disconnects. Problem came after last update I did a couple of days ago.
     

    #20
    kannan333, dareknowak and arilies0 like this.