11
Bluetooth disconnects with OxygenOS 5.1.6 OTA for the OnePlus 5T

  1. marco.curatitoli
    Cupcake Nov 2, 2018

    Last edited: Nov 3, 2018

    #21
  2. renegade69
    Donut Nov 2, 2018

    renegade69 , Nov 2, 2018 :
    Same problem here. I sent a log to One Plus and they pretty much said they received it and best wishes. Wait and see???????
     

    #22
    kannan333 likes this.
  3. hartekore
    Cupcake Nov 3, 2018

    hartekore , Nov 3, 2018 :
    Same problem here when using it in the car. No problem when using the Bluetooth with my home cinema nor my Bluetooth speaker.
     

    #23
    kannan333 likes this.
  4. Awsom3D
    Cupcake Nov 3, 2018

    Awsom3D , Nov 3, 2018 :
    Same problem here with my car. Tried resetting everything, and changing Bluetooth version and codec, with no persistent result.
    Please fix it in the next OxygenOS release, or at least roll back to the previous Bluetooth version.
     

    #24
    kannan333 likes this.
  5. kannan333
    Cupcake Nov 3, 2018

    kannan333 , Nov 3, 2018 :
    Bluetooth was working fine in OxygenOS 5.1.5, but Bluetooth is stopped working in OxygenOS 5.1.6.
    I have no idea, how OnePlus rolling out broken features (Bluetooth issues) in incremental Update.
    This is highly unacceptable.
    I would say Bye Bye to OnePlus.
     

    #25
  6. callmejohn32
    Froyo Nov 4, 2018

    callmejohn32 , Nov 4, 2018 :
    Yes, after the Oct1 Security Patch Update, (OS Version: ONEPLUS 15010_43_181025) my bluetooth is also working incorrectly. I can pair my device to my car perfectly fine; however, as soon as I start playing music, the phone disconnects. I can make calls, receive them with no problems. Bluetooth keeps unpairing while I play music, though.
     

    #26
  7. hadi_753
    Cupcake Nov 4, 2018

    hadi_753 , Nov 4, 2018 :
    Same thing here .
    Keep disconnecting all the time after last update .

    If anyone found solution please post it here .

    Thanks .
     

    #27
  8. hadi_753
    Cupcake Nov 4, 2018

    hadi_753 , Nov 4, 2018 :
    Okay , found solution .
    First of all , seems like oneplus figured out that it was buggy update and that update is no where to be found now .
    My solution was to download the previous version from oneplus official website :
    https://www.oneplus.com/support/softwareupgrade/details?code=7

    Then make sure to move to root folder .
    Then go to setting > check for update > install from local .
    And install the previous version .

    Enjoy it
     

    #28
  9. ravi.ajn
    Froyo Nov 4, 2018

    ravi.ajn , Nov 4, 2018 :
    Hello,

    SO I can download this and manually update the version. wont it remove or clean any of my files?
    If yes that would be great, as without Bluetooth its very hard.
     

    #29
  10. hadi_753
    Cupcake Nov 4, 2018

    hadi_753 , Nov 4, 2018 :
    It won't delete anything .

    I'm writing to you from same oneplus phone it's working just fine
     

    #30
  11. renegade69
    Donut Nov 6, 2018

    renegade69 , Nov 6, 2018 :
    Still waiting. This issue has been reported in multiple post with the Stable version and also the Beta version. I find it very hard to believe and understand how One Plus was unaware of this issue when they sent the update out (Quality Control Issues????). This is really questioning if my next purchase of a phone in the future is going to be from One Plus. Development Engineers should have a fix by now, No one is asking for PIE, just fix the Bluetooth as it is a safety issue at this point, when operating a motor vehicle should use hands free (Bluetooth), as well as against the law in many states in the United States. Please fix ASAP.
    Thanks
     

    #31
  12. hadi_753
    Cupcake Nov 6, 2018

    hadi_753 , Nov 6, 2018 :
    You can easily install the previous version until a fix is released
     

    #32
  13. Obmann76
    Gingerbread Nov 6, 2018


    #33
  14. cieffe54
    Eclair Nov 6, 2018

    cieffe54 , Nov 6, 2018 :
    II think the problem is in the October patch. In fact it is the only thing that unites the stable and the beta. The beta 18 worked perfectly before the patch (B19).
    I have reported this my thought to bughunter for now without result.
     

    #34
  15. renegade69
    Donut Nov 8, 2018

    renegade69 , Nov 8, 2018 :
    Very true, I have already. Although it shouldn't have been required. A company like One Plus should have better Quality Control. I am back on Stable 5.1.5, The 5.1.6 has been removed????? The Beta 19 is still up for download. The problem is in 5.1.6 and Beta 19 as previously posted by Obmann76. Poor Quality Control and neglect for customers.....
     

    #35
  16. mdp01
    Eclair Nov 10, 2018

    mdp01 , Nov 10, 2018 :
    Been living with this issue so long it is a feature now. I leave my home bluetooth disconnects and before I leave my complex to start my drive it is now ready to work and I then reconnect the car's bluetooth to the phone and drive.
     

    #36
  17. RaJa657
    Donut Nov 10, 2018


    #37
  18. hartekore
    Cupcake Nov 11, 2018


    #38
    mdp01 likes this.
  19. mdp01
    Eclair Nov 14, 2018

    mdp01 , Nov 14, 2018 :
    Waiting for v5.1.7 in Canada to get this issue resolved, hopefully is true.
     

    #39
  20. Y1517938924081
    Froyo Nov 14, 2018


    #40
    mdp01 likes this.