3
Bluetooth issues after Android 12

  1. bmolhoek
    Cupcake Jan 23, 2022

    bmolhoek , Jan 23, 2022 :
    My OP9 updated to 12 yesterday morning. Since then I've had repeated issues with Bluetooth. Anytime I pause playback on podcasts or music, it repeatedly disconnects and reconnects my earbuds. I've tried the following:

    Unpair and repair earbuds
    Unpair earbuds, clear Bluetooth cache, restart phone, repair
    Unpair, reset network connections, restart phone, repair.

    Resetting network connections resolved the issue for about 14 hours, then the issue came back. Resetting the connections a second time didn't do anything. Is this an Android bug or an issue with Oxygen OS and when can we expect a fix?
     

    #1
    I1651512583090, ljb777 and perseuss like this.
  2. harshit.b.
    Jelly Bean Jan 23, 2022

  3. Caomhin
    9 Series Expert, Participator of the Year Community Expert Jan 24, 2022

    Last edited: Jan 25, 2022

    #3
    Aaron2017 likes this.
  4. U1643124354927
    Cupcake Jan 25, 2022

    U1643124354927 , Jan 25, 2022 :
    I'm having the same issues as you, op9 updated yesterday morning and all throughout the day my gear s3 watch would disconnect. I find that it will disconnect when my phone is inactive/asleep. I've turned off battery optimization on all the necessary apps the watch needs, but it still disconnects. My wireless earbuds would also disconnect and reconnect if I'm not listening to anything after a short period of time.
     

    #4
  5. I1651512583090
    Cupcake May 4, 2022

    I1651512583090 , May 4, 2022 :
    12 ruined so many things. Voice app won't work over Bluetooth and won't even switch to speaker mode. Can't answer calls with Bluetooth headset when Google voice number is called. Please fix everything now
     

    #5
  6. C1652213925151
    Cupcake May 10, 2022

    C1652213925151 , via OnePlus 8T , May 10, 2022 :
    Same issue after oneplus 8T update to Android 12 : audio devices get disconnected every few minutes (headsets, car, portable speaker,.. ). Really a pain ! Tried various solutions right and left, none worked.
     

    #6