2
Bluetooth keep crashing after oxygen os 5.0.1 update

  1. skybutter
    Cupcake Jan 11, 2018

    skybutter , Jan 11, 2018 :
    HI. after system update to oxygen is 5.0.1, when connecting to my Toyota Bluetooth, the Bluetooth keeps crashing. it gets connected, and then said the Bluetooth stopped working. then it restarted Bluetooth. connected then stopped and restarted Bluetooth. it just keep on in this cycle.

    I didn't have this problem before the 5.0.1 update.
     

    #1
    mbogaard and Seven2k like this.
  2. pdukpduk
    Cupcake Jan 11, 2018


    #2
  3. wileyc
    Jelly Bean Jan 11, 2018

    wileyc , Jan 11, 2018 :
    Of course it could be that the car software needs an update to support Oreo? Might be worth a google search to see if this is affecting other handsets (non-OP) that have been upgraded to Oreo.
     

    #3
  4. avinash2avinash
    Cupcake Jan 12, 2018


    #4
  5. pmoppy
    Froyo Jan 12, 2018


    #5
  6. G_Matthew_Gracie_vSnh
    Donut Jan 12, 2018

    G_Matthew_Gracie_vSnh , Jan 12, 2018 :
    I don't think updating a car's Bluetooth software is possible on a lot of cars and it certainly shouldn't be needed for an issue like this.
     

    #6
  7. G_Matthew_Gracie_vSnh
    Donut Jan 12, 2018


    #7
  8. skybutter
    Cupcake Jan 12, 2018

    skybutter , Jan 12, 2018 :
    I ended up disconnecting the audio player when connecting the Bluetooth. only connecting the phone Bluetooth made it worked.
    we need it fix.
     

    #8
  9. potwarka
    Cupcake Jan 18, 2018

    potwarka , Jan 18, 2018 :
    I have a Land Rover. Same problem. It's not the cars bluetooth. It's the phone's.
     

    #9
  10. bikedogrun
    Cupcake Jan 21, 2018

    bikedogrun , Jan 21, 2018 :
    Same problem on my BMW X3... worked great on Nougat release but since 5.0.1 Oreo it pairs with my car but will never connect???

    Oneplus - Please quickly issue a fix!!!

    Update on Jan 25: For other reasons we just traded the 2014 X3 for a 2017 X1 and lo and behold Bluetooth and car connection on 5.0.1 now work perfectly!!!

    Seems like newer bluetooth software in the newer vehicle made the difference???
     
    Last edited: Jan 26, 2018

    #10
  11. U1516323103340
    Cupcake Jan 21, 2018

    U1516323103340 , Jan 21, 2018 :
    I have this problem in my car and my sister's car too! It connects but the audio doesnt play. If it manages to play it'll play for a few seconds then just stop completely.
     

    #11
  12. mommu
    Gingerbread Jan 25, 2018


    #12
  13. Prinas X.
    Honeycomb Jan 26, 2018

    Prinas X. , Jan 26, 2018 :
    Hi all,

    Sorry to hear that.

    For whom encounters Bluetooth issue, please kindly help collect log so that we can look into it.

    Here’s the procedure:
    1. Input the command *#800# in dial-up interface
    2. Click “Get Wireless Log” and then click “Delete history logs”
    3. Click “Get Bluetooth Log” to start capturing. When it informs you whether to reboot, please click “cancel”
    4. (Important) Replicate the issue, take a screenshot to record the time when error happens
    5. Return to the log interface and click “Stop logging”
    6. Enter file manager, choose storage, find the oem log file and Zip it and send it to us along with the screenshots. You can transfer the logs to google and share us a link.

    Note:
    Please send email to: bughunters@oneplus.net with detailed description about the issue.

    Looking forward to hearing from you soon.

    Best regards,
    OnePlus Bug Hunters
     

    #13
    astracd likes this.
  14. skybutter
    Cupcake Feb 4, 2018

    skybutter , Feb 4, 2018 :
    the oxygen is 5.0.2 update seemed to fix this Bluetooth issue. I got updated to 5.0.2, and connected to my Toyota Sienna Bluetooth ok.
     

    #14
  15. pdukpduk
    Cupcake Feb 5, 2018

    pdukpduk , Feb 5, 2018 :
    Happy to report that the issue has been resolved for my Toyota Prius as well, in 5.0.2.
     

    #15
  16. jespersb
    Cupcake Feb 8, 2018

    jespersb , Feb 8, 2018 :
    Same issue with my 2016 VW Passat. Sometimes BT streaming works fine, but if I get a call then it refuses to stream again after the call. Looking forward to 5.0.2 for my OP3...
     

    #16
  17. G_jay_acharya_bwOE
    Cupcake Feb 15, 2018

    G_jay_acharya_bwOE , Feb 15, 2018 :
    I am having the same issue with my 2015 BMW. I have updated my car software as well but still having the same issue.
    it gets connected to car and then nothing. I can't listen to music. I called BMW they even don't know what is "OnePlus".
     

    #17
  18. jay115
    Cupcake Aug 24, 2019

    jay115 , Aug 24, 2019 :
    I am having same issue connecting to my wireless Bluetooth earphones
     

    #18