11

Bluetooth problems

  1. F_Erik_Martens_qYoM Cupcake May 29, 2018

    F_Erik_Martens_qYoM, May 29, 2018 :
    same issue. it's definitely a software issue with the phone, I would like to see a response from One Plus about it.

    besides the Bluetooth I'm very happy with the device, but I travel a lot and would really like to see this get fixed.
     

    #21
  2. Enrico_Cerami Cupcake May 29, 2018

    Enrico_Cerami, May 29, 2018 :
    Hello,

    I have the same problem, the phone doesn't recognize the car's Bluetooth and the car doesn't recognize the phone's Bluetooth. OPO 6 and Fiesta 2011 (no problem before with any device and any phone).
     

    #22
  3. BMG1900 Eclair May 31, 2018

    BMG1900, May 31, 2018 :
    Unfortunately I have to join the club - Actually it connects the 1st time & have signal bars for a short period & then signal suddenly drops to no service & will not reconnect period. Had OP5 before & has the same Bluetooth issue after the last update & now with OP6 right from the beginning. Went to developer options & set Audio codec to aptx, but didn't hold the setting & went right back to the default setting - Hope all you people are right & it's a bug & will be fixed very shortly
     

    #23
    B_i_g_g_i and nakah like this.
  4. pendragon Gingerbread May 31, 2018

    pendragon, May 31, 2018 :
    I think opo6 has a big Bluetooth problem. I can connect my OP3 fine, but my op6 doesn't or it does but I can't call. Sometimes the car device says searching for network, but phone has full network.
     

    #24
  5. karthik.kr Cupcake May 31, 2018

    karthik.kr, May 31, 2018 :
    I am having some connectivity issues with Bluetooth on my one plus 6. My earlier one plus 3t would pair perfectly with my car stereo. In the OP 6 every time I need to select the audio output manually in the notification drop-down from phone speakers to Bluetooth for the audio to get to the car speakers even after pairing successfully. Most of the calls get disconnected by then because the other person can't hear my voice.

    Is any one else facing this issue?

    Thanks,
    Karthik
     

    #25
    W1528057146857 likes this.
  6. ad73 Eclair May 31, 2018

    ad73, May 31, 2018 :
    I have sent a Bluetooth log to oneplus today as soon as I hear back I will post on this thread.
     

    #26
  7. nakah Froyo May 31, 2018

    nakah, May 31, 2018 :
    I connected 1+6 to my car Mercedes from 2017 via Bluetooth without any problems, but day after display on the car shows "no connection" but I can still make phone call from the car system. I think it is software issue as I not have any problem with my previous phone Samsung galaxy S7.

    If you have any solution please let me know
     

    #27
  8. bdavisson Donut Jun 1, 2018

    bdavisson, Jun 1, 2018 :
    Verified solution:

    I had the same issue with my Mitsubishi Outlander GT (Rockford Fosgate factory stereo). It took me about 30minutes to troubleshoot and resolve the issue.

    Fix:
    One Plus 6 - Pair with car
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth>force stop
    One Plus 6 - Settings>Apps>Application list>... >show system apps>BTtestmode>force stop
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth MIDI Service> force stop
    One Plus 6 - Reboot

    Validate changes:
    One Plus 6 - Settings>Apps>Application list>... >show system apps>BTtestmode show installed, but force stop should be grayed out.
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth MIDI show installed, but force stop should be grayed out.

    Car - Test bluetooth audio music
    Bluetooth Audio started working, continue. If bluetooth audio fails delete pairing and try again.
    Car - Test bluetooth audio calls - If calls fails (like me)
    Go to Bluetooth pairing on stereo. Verify bluetooth phone are set to allow the phone call, and bluetooth audio is set

    Turn off car, and turn back on to re-test and validate settings hold.

    Root cause:
    My guess is BTtestmode was left enabled (debug mode) on the image from the factory, or Bluetooth wan't reset before being released into production.

    Screenshot (May 31, 2018 6_17_24 PM).jpg Screenshot (May 31, 2018 6_20_37 PM).jpg IMG_20180531_181509.jpg IMG_20180531_181433.jpg
     

    Attached Files:

    Last edited: Jun 1, 2018

    #28
  9. Quota Cupcake Jun 1, 2018

    Quota, Jun 1, 2018 :
    I am having the "no signal" issue as well with my 2012 Volvo. appartement from that, I am also not able to pair my OnePlus 6 with my Polar M400 spots watch.
     

    #29
  10. bdavisson Donut Jun 1, 2018

    bdavisson, Jun 1, 2018 :
    What have you tried? When you say no signal, can you pair your device?
     

    #30
  11. Quota Cupcake Jun 1, 2018

    Quota, Jun 1, 2018 :
    I have paired my phone, can play audio and make calls, have not received calls yet. but the car display shows no signal (which it did perfectly with my OP2).
     

    #31
    B_i_g_g_i likes this.
  12. bdavisson Donut Jun 1, 2018

    bdavisson, Jun 1, 2018 :
    What does the phone show for signal?
     

    #32
  13. nakah Froyo Jun 1, 2018

    nakah, Jun 1, 2018 :
    bdavisson

    Verified solution:

    I had the same issue with my Mitsubishi Outlander GT (Rockford Fosgate factory stereo). It took me about 30minutes to troubleshoot and resolve the issue.

    Fix:
    One Plus 6 - Pair with car
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth>force stop
    One Plus 6 - Settings>Apps>Application list>... >show system apps>BTtestmode>force stop
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth MIDI Service> force sto
    One Plus 6 - Reboot

    Validate changes:
    One Plus 6 - Settings>Apps>Application list>... >show system apps>BTtestmode show installed, but force stop should be grayed out.
    One Plus 6 - Settings>Apps>Application list>... >show system apps>Bluetooth MIDI show installed, but force stop should be grayed out.

    Car - Test bluetooth audio music
    Bluetooth Audio started working, continue. If bluetooth audio fails delete pairing and try again.
    Car - Test bluetooth audio calls - If calls fails (like me)
    Go to Bluetooth pairing on stereo. Verify bluetooth phone are set to allow the phone call, and bluetooth audio is set

    Turn off car, and turn back on to re-test and validate settings hold.

    Root cause:
    My guess is BTtestmode was left enabled (debug mode) on the image from the factory, or Bluetooth wan't reset before being released into production.

    View attachment 781387 View attachment 781388 View attachment 781389 View attachment 781390



    it did not helped. I have no problem with Bluetooth connection, the problem is the phone status bar showing signal strength is zero on car display. See below phone

    1527890026104.jpg
     

    Attached Files:

    Last edited: Jun 1, 2018

    #33
    Quota likes this.
  14. GabrielAK Donut Jun 1, 2018

    GabrielAK, Jun 1, 2018 :
    I will try it.
     

    #34
  15. Quota Cupcake Jun 1, 2018

    Quota, Jun 1, 2018 :
    full strength 4G
     

    #35
  16. irishandrew Cupcake Jun 1, 2018

    irishandrew, Jun 1, 2018 :
    I have noticed the same issues:

    Phone is correctly paired with car, and I can answer calls, review texts and play music; shortly after setting off the car displays no signal, despite the phone having full signal.
    If I am on a call at the time it does not drop and I can continue the conversation.

    Making calls is a different story - like others the phone makes the call but does not swap over sound and microphone to the cars system, so I am left with a distant voice eminating from my pocket... If I immediately hang up and redial, it works fine.

    I will try the solution above and see if that helps. Otherwise hoping for a fix in the next update.

    Cheers,
    Andrew
     

    #36
  17. ananth2004 Donut Jun 1, 2018

    ananth2004, Jun 1, 2018 :
     

    #37
  18. GabrielAK Donut Jun 1, 2018

    GabrielAK, Jun 1, 2018 :
    that above fix did not solved my problem.
    I turned off the smartwatch phone connection and left only the notification checked. that way I am always connecting to the car.

    hope they will release a software soon to since the problem with connection with 2 devices and signal display in the car.
     

    #38
  19. Damol589 Cupcake Jun 1, 2018

    Damol589, Jun 1, 2018 :
    I have the same NO SIGNAL issue on my 2015 Subaru Forester and on my Wifes 2018 Subaru Crosstrek. This is definitely an OP6 software issue.
     

    #39
  20. nakah Froyo Jun 2, 2018

    nakah, Jun 2, 2018 :
    Have somebody reported to OnePlus team, so they can fix it?
     

    #40