0
Bootloader is unlocked but "OEM unlocking" not allowed in Developer Options!

  1. sbpetrack
    Cupcake Nov 25, 2018

    sbpetrack , Nov 25, 2018 :
    I recently soft-bricked my OnePlus 6, by which I mean that I would see nothing but the LED shining white when I tried to boot it or boot it into recovery. Fastboot worked fine, however, and the bootloader was still unlocked, so I restored it by using a flash-all.bat script to reset all partitions and return me to stock. Then I upgraded to A6003_22_181026, restored almost everything from the initial google setup (only WhatsApp needed to be restored by hand) and continued on my merry way.

    My question is that in "Developer options" I can't help but notice that "OEM unlocking" is NOT on, yet the bootloader is in fact unlocked. Do I need to worry about this? Should I leave things as they are? Should I turn ON "Oem unlocking". Is this an inconsistent state?

    Thanks for any information and informed advice you can offer.

    Scott
     

    #1
  2. Kytharsis
    Nougat Nov 26, 2018

    Kytharsis , Nov 26, 2018 :
    Should've used the unbrick tool.
     

    #2
    buntycubal and Deactivated User like this.
  3. Leonlu
    Donut Mar 13, 2019

    Leonlu , Mar 13, 2019 :
    if you have your bootloader unlocked oem unlock is always on and cannot be turned OFF. It is always ON. Could you send a screenshot of developer options? if you still have a problem use the unbrick tool like the previous comment suggested.
     

    #3